chiark / gitweb /
[PATCH] update udev scsi_id to scsi_id 0.3
[elogind.git] / udev.spec
index 9e301deb7c552ade47d3d83bcbe917c937a3198a..575e3cdf6069e7ab7c73975dc9d4ce7ad1a68714 100644 (file)
--- a/udev.spec
+++ b/udev.spec
@@ -5,6 +5,12 @@
 # it probably is not where you want it to be.
 %define klibc 1
 
+# if we want to have logging support in or not.
+# 0 - no logging  support
+# 1 - logging support
+# Note, it is not recommend if you use klibc to enable logging.
+%define log 0
+
 # if we want to build DBUS support in or not.
 # 0 - no DBUS support
 # 1 - DBUS support
 # 1 - debugging enabled
 %define debug 0
 
+# if we want to use the LSB version of the init script or the Redhat one
+# 0 - use Redhat version: etc/init.d/udev
+# 1 - use LSB version: etc/init.d/udev.init.LSB
+%define lsb 0
+
 Summary: A userspace implementation of devfs
 Name: udev
-Version: 012_bk
+Version: 013_bk
 Release: 1
 License: GPL
 Group: Utilities/System
@@ -40,6 +51,9 @@ make CC="gcc $RPM_OPT_FLAGS"  \
 %if %{klibc}
        USE_KLIBC=true          \
 %endif
+%if %{log}
+       USE_LOG=true            \
+%endif
 %if %{dbus}
        USE_DBUS=true           \
 %endif
@@ -52,6 +66,9 @@ make DESTDIR=$RPM_BUILD_ROOT install \
 %if %{dbus}
        USE_DBUS=true
 %endif
+%if %{lsb}
+       USE_LSB=true
+%endif
 
 %post
 /sbin/chkconfig --add udev
@@ -81,6 +98,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(0644,root,root) %{_mandir}/man8/udev.8*
 
 %changelog
+* Mon Jan 05 2004 Rolf Eike Beer <eike-hotplug@sf-tec.de>
+- add defines to choose the init script (Redhat or LSB)
+
 * Tue Dec 16 2003 Robert Love <rml@ximian.com>
 - install the initscript and run chkconfig on it
 
@@ -96,4 +116,3 @@ rm -rf $RPM_BUILD_ROOT
 
 * Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
 - Initial spec file for udev-0.2.
-