chiark / gitweb /
[PATCH] udev - reverse user query options
[elogind.git] / udev.spec
index 8cc424cacb9b48eb381aac6b3f2f797ba1555659..575e3cdf6069e7ab7c73975dc9d4ce7ad1a68714 100644 (file)
--- a/udev.spec
+++ b/udev.spec
@@ -1,6 +1,35 @@
+# if we want to build against the included version of klibc or not.
+# 0 - do not use klibc
+# 1 - use klibc
+# Watch out for where the linux symlink is in the klibc part of the tarball,
+# it probably is not where you want it to be.
+%define klibc 1
+
+# if we want to have logging support in or not.
+# 0 - no logging  support
+# 1 - logging support
+# Note, it is not recommend if you use klibc to enable logging.
+%define log 0
+
+# if we want to build DBUS support in or not.
+# 0 - no DBUS support
+# 1 - DBUS support
+%define dbus 0
+
+# if we want to enable debugging support in udev.  If it is enabled, lots of 
+# stuff will get sent to the debug syslog.
+# 0 - debugging disabled
+# 1 - debugging enabled
+%define debug 0
+
+# if we want to use the LSB version of the init script or the Redhat one
+# 0 - use Redhat version: etc/init.d/udev
+# 1 - use LSB version: etc/init.d/udev.init.LSB
+%define lsb 0
+
 Summary: A userspace implementation of devfs
 Name: udev
-Version: 007_bk
+Version: 013_bk
 Release: 1
 License: GPL
 Group: Utilities/System
@@ -18,27 +47,63 @@ udev is a implementation of devfs in userspace using sysfs and
 %setup -q
 
 %build
-make CC="gcc $RPM_OPT_FLAGS"
+make CC="gcc $RPM_OPT_FLAGS"   \
+%if %{klibc}
+       USE_KLIBC=true          \
+%endif
+%if %{log}
+       USE_LOG=true            \
+%endif
+%if %{dbus}
+       USE_DBUS=true           \
+%endif
+%if %{debug}
+       DEBUG=true              \
+%endif
 
 %install
-make DESTDIR=$RPM_BUILD_ROOT install
+make DESTDIR=$RPM_BUILD_ROOT install \
+%if %{dbus}
+       USE_DBUS=true
+%endif
+%if %{lsb}
+       USE_LSB=true
+%endif
+
+%post
+/sbin/chkconfig --add udev
+
+%postun
+if [ $1 = 0 ]; then
+       /sbin/chkconfig --del udev
+fi
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
-%defattr(0644,root,root)
+%defattr(-,root,root)
 %doc COPYING README TODO ChangeLog
 %attr(755,root,root) /sbin/udev
 %attr(755,root,root) /udev/
 %attr(755,root,root) /etc/udev/
-%attr(0644,root,root) /etc/udev/udev.conf
-%attr(0644,root,root) /etc/udev/udev.rules
-%attr(0644,root,root) /etc/udev/udev.permissions
+%config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
+%config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
+%config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
+%if %{dbus}
+       %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
+%endif
 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
+%attr(755,root,root) /etc/init.d/udev
 %attr(0644,root,root) %{_mandir}/man8/udev.8*
 
 %changelog
+* Mon Jan 05 2004 Rolf Eike Beer <eike-hotplug@sf-tec.de>
+- add defines to choose the init script (Redhat or LSB)
+
+* Tue Dec 16 2003 Robert Love <rml@ximian.com>
+- install the initscript and run chkconfig on it
+
 * Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
 - changes due to config file name changes
 
@@ -51,4 +116,3 @@ rm -rf $RPM_BUILD_ROOT
 
 * Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
 - Initial spec file for udev-0.2.
-