chiark / gitweb /
[PATCH] misc code cleanups.
[elogind.git] / udev.spec
index 07331807ef785b68550713722cb0a1ee9b73dbdc..575e3cdf6069e7ab7c73975dc9d4ce7ad1a68714 100644 (file)
--- a/udev.spec
+++ b/udev.spec
@@ -5,6 +5,12 @@
 # it probably is not where you want it to be.
 %define klibc 1
 
+# if we want to have logging support in or not.
+# 0 - no logging  support
+# 1 - logging support
+# Note, it is not recommend if you use klibc to enable logging.
+%define log 0
+
 # if we want to build DBUS support in or not.
 # 0 - no DBUS support
 # 1 - DBUS support
@@ -45,6 +51,9 @@ make CC="gcc $RPM_OPT_FLAGS"  \
 %if %{klibc}
        USE_KLIBC=true          \
 %endif
+%if %{log}
+       USE_LOG=true            \
+%endif
 %if %{dbus}
        USE_DBUS=true           \
 %endif