chiark / gitweb /
add flag for reading of precompiled rules
[elogind.git] / udev.spec
index 1df59ecdb879155fda8c40e3d70f3ca5f3f79db9..52bfa2ffaeb8aed9bb2c800fd7af102443aa5c9a 100644 (file)
--- a/udev.spec
+++ b/udev.spec
 # 1 - debugging enabled
 %define debug 0
 
-# if we want to build the DBUS "extra" package or not
-# 0 - no DBUS support
-# 1 - DBUS support
-%define dbus 0
-
-# if we want to build the SELinux "extra" package or not
-# 0 - no SELinux support
-# 1 - SELinux support
-%define selinux 0
-
 # if we want to build the scsi_id "extra" package or not
 # 0 - do not build the package
 # 1 - build it
 %define scsi_id 1
 
-Summary: A userspace implementation of devfs
+# if we want to build the volume_id "extra" package or not
+# 0 - do not build the package
+# 1 - build it
+%define volume_id 1
+
+Summary: A userspace device manager providing devfs functionality
 Name: udev
-Version: 023_bk
+Version: 065
 Release: 1
 License: GPL
 Group: Utilities/System
@@ -46,8 +41,9 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 Prereq: /bin/sh, fileutils, hotplug
 
 %description
-udev is a implementation of devfs in userspace using sysfs and
-/sbin/hotplug. It requires a 2.6 kernel to run properly.
+udev is a userspace device manager, using sysfs and uevents
+to provide a devfs-like device directory management and uevent
+dispatching.
 
 %prep
 %setup -q
@@ -71,25 +67,20 @@ make CC="gcc $RPM_OPT_FLAGS"        \
 %if %{scsi_id}
        extras/scsi_id  \
 %endif
-%if %{dbus}
-       extras/dbus     \
-%endif
-%if %{selinux}
-       extras/selinux  \
+%if %{volume_id}
+       extras/volume_id        \
 %endif
 "
 
 %install
+rm -rf $RPM_BUILD_ROOT
 make DESTDIR=$RPM_BUILD_ROOT install \
        EXTRAS="        \
 %if %{scsi_id}
        extras/scsi_id  \
 %endif
-%if %{dbus}
-       extras/dbus     \
-%endif
-%if %{selinux}
-       extras/selinux  \
+%if %{volume_id}
+       extras/volume_id        \
 %endif
 "
 
@@ -108,7 +99,6 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(-,root,root)
 %doc COPYING README TODO ChangeLog HOWTO* docs/*
 %doc etc/udev/udev.rules.{examples,gentoo,redhat}
-%doc etc/udev/udev.permissions.{gentoo,redhat}
 %attr(755,root,root) /sbin/udev
 %attr(755,root,root) /usr/bin/udevinfo
 %attr(755,root,root) /sbin/udevsend
@@ -118,23 +108,26 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %dir /udev/
 %attr(755,root,root) %dir /etc/udev/
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
-%config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
-%config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
+%attr(755,root,root) %dir /etc/udev/rules.d/
+%config(noreplace) %attr(0644,root,root) /etc/udev/rules.d/50-udev.rules
 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
 %attr(755,root,root) /etc/init.d/udev
 %attr(0644,root,root) %{_mandir}/man8/udev*.8*
 
-%if %{dbus}
-       %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
-%endif
-
 %if %{scsi_id}
        %attr(755,root,root) /sbin/scsi_id
        %config(noreplace) %attr(0644,root,root) /etc/scsi_id.config
        %attr(0644,root,root) %{_mandir}/man8/scsi_id*.8*
 %endif
+%if %{volume_id}
+       %attr(755,root,root) /sbin/udev_volume_id
+%endif
 
 %changelog
+* Fri May 14 2004 Greg Kroah-Hartman <greg@kroah.com>
+- remove dbus and selinux stuff from here
+- added volume_id option
+
 * Wed Mar 24 2004 Greg Kroah-Hartman <greg@kroah.com>
 - change the way dbus and selinux support is built (now an extra)