chiark / gitweb /
[PATCH] install udevstart
[elogind.git] / udev.spec
index bfa633ba6608955816678c5b2953a1a01318120e..49b8b131dab40392490f3dbdf6e6aec37b36f83f 100644 (file)
--- a/udev.spec
+++ b/udev.spec
 # 1 - DBUS support
 %define dbus 0
 
+# if we want to build SELinux support in or not.
+# 0 - no SELinux support
+# 1 - SELinux support
+%define selinux 1 
+
 # if we want to enable debugging support in udev.  If it is enabled, lots of 
 # stuff will get sent to the debug syslog.
 # 0 - debugging disabled
 # 1 - debugging enabled
 %define debug 0
 
-# if we want to use the LSB version of the init script or the Redhat one
-# 0 - use Redhat: etc/init.d/udev
-# 1 - use LSB: etc/init.d/udev.init.LSB
-%define lsb 0
-
 # if we want to build the scsi_id "extra" package or not
 # 0 - do not build the package
 # 1 - build it
@@ -34,7 +34,7 @@
 
 Summary: A userspace implementation of devfs
 Name: udev
-Version: 018
+Version: 019_bk
 Release: 1
 License: GPL
 Group: Utilities/System
@@ -67,6 +67,11 @@ make CC="gcc $RPM_OPT_FLAGS" \
 %else
        USE_DBUS=false          \
 %endif
+%if %{selinux}
+       USE_SELINUX=true        \
+%else
+       USE_SELINUX=false       \
+%endif
 %if %{debug}
        DEBUG=true              \
 %else
@@ -85,10 +90,10 @@ make DESTDIR=$RPM_BUILD_ROOT install \
 %else
        USE_DBUS=false          \
 %endif
-%if %{lsb}
-       USE_LSB=true            \
+%if %{selinux}
+       USE_SELINUX=true        \
 %else
-       USE_LSB=false           \
+       USE_SELINUX=false       \
 %endif
        EXTRAS="        \
 %if %{scsi_id}
@@ -115,6 +120,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) /sbin/udevsend
 %attr(755,root,root) /sbin/udevd
 %attr(755,root,root) /sbin/udevtest
+%attr(755,root,root) /sbin/udevstart
 %attr(755,root,root) %dir /udev/
 %attr(755,root,root) %dir /etc/udev/
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
@@ -135,6 +141,12 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 
 %changelog
+* Tue Mar 2 2004 Greg Kroah-Hartman <greg@kroah.com>
+- added udevstart to the list of files installed
+
+* Fri Feb 27 2004 Greg Kroah-Hartman <greg@kroah.com>
+- added ability to build with SELinux support
+
 * Thu Feb 19 2004 Greg Kroah-Hartman <greg@kroah.com>
 - add some more files to the documentation directory
 - add ability to build scsi_id and make it the default