chiark / gitweb /
[PATCH] man page udevstart
[elogind.git] / udev.spec
index aa595962f7dbcc29690c00039c217e1a87e9aba4..49b8b131dab40392490f3dbdf6e6aec37b36f83f 100644 (file)
--- a/udev.spec
+++ b/udev.spec
 # 1 - DBUS support
 %define dbus 0
 
+# if we want to build SELinux support in or not.
+# 0 - no SELinux support
+# 1 - SELinux support
+%define selinux 1 
+
 # if we want to enable debugging support in udev.  If it is enabled, lots of 
 # stuff will get sent to the debug syslog.
 # 0 - debugging disabled
 # 1 - debugging enabled
 %define debug 0
 
-# if we want to use the LSB version of the init script or the Redhat one
-# 0 - use Redhat: etc/init.d/udev
-# 1 - use LSB: etc/init.d/udev.init.LSB
-%define lsb 0
+# if we want to build the scsi_id "extra" package or not
+# 0 - do not build the package
+# 1 - build it
+%define scsi_id 1
 
 Summary: A userspace implementation of devfs
 Name: udev
-Version: 017_bk
+Version: 019_bk
 Release: 1
 License: GPL
 Group: Utilities/System
@@ -62,12 +67,21 @@ make CC="gcc $RPM_OPT_FLAGS"        \
 %else
        USE_DBUS=false          \
 %endif
+%if %{selinux}
+       USE_SELINUX=true        \
+%else
+       USE_SELINUX=false       \
+%endif
 %if %{debug}
        DEBUG=true              \
 %else
        DEBUG=false             \
 %endif
-
+       EXTRAS="        \
+%if %{scsi_id}
+       extras/scsi_id  \
+%endif
+"
 
 %install
 make DESTDIR=$RPM_BUILD_ROOT install \
@@ -76,11 +90,16 @@ make DESTDIR=$RPM_BUILD_ROOT install \
 %else
        USE_DBUS=false          \
 %endif
-%if %{lsb}
-       USE_LSB=true            \
+%if %{selinux}
+       USE_SELINUX=true        \
 %else
-       USE_LSB=false           \
+       USE_SELINUX=false       \
 %endif
+       EXTRAS="        \
+%if %{scsi_id}
+       extras/scsi_id  \
+%endif
+"
 
 %post
 /sbin/chkconfig --add udev
@@ -95,25 +114,43 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root)
-%doc COPYING README TODO ChangeLog
+%doc COPYING README TODO ChangeLog HOWTO* etc/udev/udev.rules.examples docs/*
 %attr(755,root,root) /sbin/udev
 %attr(755,root,root) /sbin/udevinfo
 %attr(755,root,root) /sbin/udevsend
 %attr(755,root,root) /sbin/udevd
 %attr(755,root,root) /sbin/udevtest
+%attr(755,root,root) /sbin/udevstart
 %attr(755,root,root) %dir /udev/
 %attr(755,root,root) %dir /etc/udev/
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
-%if %{dbus}
-       %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
-%endif
 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
 %attr(755,root,root) /etc/init.d/udev
 %attr(0644,root,root) %{_mandir}/man8/udev*.8*
 
+%if %{dbus}
+       %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
+%endif
+
+%if %{scsi_id}
+       %attr(755,root,root) /sbin/scsi_id
+       %config(noreplace) %attr(0644,root,root) /etc/scsi_id.config
+       %attr(0644,root,root) %{_mandir}/man8/scsi_id*.8*
+%endif
+
 %changelog
+* Tue Mar 2 2004 Greg Kroah-Hartman <greg@kroah.com>
+- added udevstart to the list of files installed
+
+* Fri Feb 27 2004 Greg Kroah-Hartman <greg@kroah.com>
+- added ability to build with SELinux support
+
+* Thu Feb 19 2004 Greg Kroah-Hartman <greg@kroah.com>
+- add some more files to the documentation directory
+- add ability to build scsi_id and make it the default
+
 * Mon Feb 16 2004 Greg Kroah-Hartman <greg@kroah.com>
 - fix up udevd build, as it's no longer needed to be build seperatly
 - add udevtest to list of files