chiark / gitweb /
[PATCH] fix klibc with printf() and gcc
[elogind.git] / udev.spec
index 428352132643b6cac1c02cf38118001151aa15d5..4056025df8ca8b8b0abff00fba4a137374db3588 100644 (file)
--- a/udev.spec
+++ b/udev.spec
 # 1 - debugging enabled
 %define debug 0
 
+# if we want to use the LSB version of the init script or the Redhat one
+# 0 - use Redhat version: etc/init.d/udev
+# 1 - use LSB version: etc/init.d/udev.init.LSB
+%define lsb 0
+
 Summary: A userspace implementation of devfs
 Name: udev
-Version: 011
+Version: 012_bk
 Release: 1
 License: GPL
 Group: Utilities/System
@@ -48,7 +53,13 @@ make CC="gcc $RPM_OPT_FLAGS" \
 %endif
 
 %install
-make DESTDIR=$RPM_BUILD_ROOT install
+make DESTDIR=$RPM_BUILD_ROOT install \
+%if %{dbus}
+       USE_DBUS=true
+%endif
+%if %{lsb}
+       USE_LSB=true
+%endif
 
 %post
 /sbin/chkconfig --add udev
@@ -70,11 +81,17 @@ rm -rf $RPM_BUILD_ROOT
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
+%if %{dbus}
+       %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
+%endif
 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
 %attr(755,root,root) /etc/init.d/udev
 %attr(0644,root,root) %{_mandir}/man8/udev.8*
 
 %changelog
+* Mon Jan 05 2004 Rolf Eike Beer <eike-hotplug@sf-tec.de>
+- add defines to choose the init script (Redhat or LSB)
+
 * Tue Dec 16 2003 Robert Love <rml@ximian.com>
 - install the initscript and run chkconfig on it
 
@@ -90,4 +107,3 @@ rm -rf $RPM_BUILD_ROOT
 
 * Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
 - Initial spec file for udev-0.2.
-