chiark / gitweb /
[PATCH] Include more examples in the docs area for gentoo and redhat
[elogind.git] / udev.spec
index 238494c45b61b5ada6b34cf237b7aedb3a8157bb..34e0755fda83def277d2466d7c6130ffd501f886 100644 (file)
--- a/udev.spec
+++ b/udev.spec
 # 1 - DBUS support
 %define dbus 0
 
+# if we want to build SELinux support in or not.
+# 0 - no SELinux support
+# 1 - SELinux support
+%define selinux 0
+
 # if we want to enable debugging support in udev.  If it is enabled, lots of 
 # stuff will get sent to the debug syslog.
 # 0 - debugging disabled
 # 1 - debugging enabled
 %define debug 0
 
-# if we want to use the LSB version of the init script or the Redhat one
-# 0 - use Redhat version: etc/init.d/udev
-# 1 - use LSB version: etc/init.d/udev.init.LSB
-%define lsb 0
+# if we want to build the scsi_id "extra" package or not
+# 0 - do not build the package
+# 1 - build it
+%define scsi_id 1
 
 Summary: A userspace implementation of devfs
 Name: udev
-Version: 016
+Version: 021_bk
 Release: 1
 License: GPL
 Group: Utilities/System
@@ -54,26 +59,48 @@ make CC="gcc $RPM_OPT_FLAGS"        \
 %endif
 %if %{log}
        USE_LOG=true            \
+%else
+       USE_LOG=false           \
 %endif
 %if %{dbus}
        USE_DBUS=true           \
+%else
+       USE_DBUS=false          \
+%endif
+%if %{selinux}
+       USE_SELINUX=true        \
+%else
+       USE_SELINUX=false       \
 %endif
 %if %{debug}
        DEBUG=true              \
+%else
+       DEBUG=false             \
 %endif
-
-# now build udevd on it's own, as it can't handle being built with klibc
-make CC="gcc $RPM_OPT_FLAGS" udevd
-
+       EXTRAS="        \
+%if %{scsi_id}
+       extras/scsi_id  \
+%endif
+"
 
 %install
 make DESTDIR=$RPM_BUILD_ROOT install \
 %if %{dbus}
-       USE_DBUS=true
+       USE_DBUS=true           \
+%else
+       USE_DBUS=false          \
 %endif
-%if %{lsb}
-       USE_LSB=true
+%if %{selinux}
+       USE_SELINUX=true        \
+%else
+       USE_SELINUX=false       \
 %endif
+       EXTRAS="        \
+%if %{scsi_id}
+       extras/scsi_id  \
+%endif
+"
+
 %post
 /sbin/chkconfig --add udev
 
@@ -87,24 +114,54 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root)
-%doc COPYING README TODO ChangeLog
+%doc COPYING README TODO ChangeLog HOWTO* docs/*
+%doc etc/udev/udev.rules.{examples,gentoo,redhat}
+%doc etc/udev/udev.permissions.{gentoo,redhat}
 %attr(755,root,root) /sbin/udev
-%attr(755,root,root) /sbin/udevinfo
+%attr(755,root,root) /usr/bin/udevinfo
 %attr(755,root,root) /sbin/udevsend
 %attr(755,root,root) /sbin/udevd
-%attr(755,root,root) /udev/
-%attr(755,root,root) /etc/udev/
+%attr(755,root,root) /sbin/udevtest
+%attr(755,root,root) /sbin/udevstart
+%attr(755,root,root) %dir /udev/
+%attr(755,root,root) %dir /etc/udev/
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
-%if %{dbus}
-       %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
-%endif
 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
 %attr(755,root,root) /etc/init.d/udev
 %attr(0644,root,root) %{_mandir}/man8/udev*.8*
 
+%if %{dbus}
+       %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
+%endif
+
+%if %{scsi_id}
+       %attr(755,root,root) /sbin/scsi_id
+       %config(noreplace) %attr(0644,root,root) /etc/scsi_id.config
+       %attr(0644,root,root) %{_mandir}/man8/scsi_id*.8*
+%endif
+
 %changelog
+* Tue Mar 2 2004 Greg Kroah-Hartman <greg@kroah.com>
+- added udevstart to the list of files installed
+- udevinfo is now in /usr/bin not /sbin
+
+* Fri Feb 27 2004 Greg Kroah-Hartman <greg@kroah.com>
+- added ability to build with SELinux support
+
+* Thu Feb 19 2004 Greg Kroah-Hartman <greg@kroah.com>
+- add some more files to the documentation directory
+- add ability to build scsi_id and make it the default
+
+* Mon Feb 16 2004 Greg Kroah-Hartman <greg@kroah.com>
+- fix up udevd build, as it's no longer needed to be build seperatly
+- add udevtest to list of files
+- more Red Hat sync ups.
+
+* Thu Feb 12 2004 Greg Kroah-Hartman <greg@kroah.com>
+- add some changes from the latest Fedora udev release.
+
 * Mon Feb 2 2004 Greg Kroah-Hartman <greg@kroah.com>
 - add udevsend, and udevd to the files
 - add ability to build udevd with glibc after the rest is build with klibc