chiark / gitweb /
[PATCH] The following patch fixes some warnings when compiling volume_id
[elogind.git] / udev.spec
index 34e0755fda83def277d2466d7c6130ffd501f886..32aca6196fd93e3f2edd09db82632dfcc3b58849 100644 (file)
--- a/udev.spec
+++ b/udev.spec
 # Note, it is not recommend if you use klibc to enable logging.
 %define log 0
 
-# if we want to build DBUS support in or not.
-# 0 - no DBUS support
-# 1 - DBUS support
-%define dbus 0
-
-# if we want to build SELinux support in or not.
-# 0 - no SELinux support
-# 1 - SELinux support
-%define selinux 0
-
 # if we want to enable debugging support in udev.  If it is enabled, lots of 
 # stuff will get sent to the debug syslog.
 # 0 - debugging disabled
 # 1 - build it
 %define scsi_id 1
 
+# if we want to build the volume_id "extra" package or not
+# 0 - do not build the package
+# 1 - build it
+%define volume_id 1
+
 Summary: A userspace implementation of devfs
 Name: udev
-Version: 021_bk
+Version: 054
 Release: 1
 License: GPL
 Group: Utilities/System
@@ -62,16 +57,6 @@ make CC="gcc $RPM_OPT_FLAGS" \
 %else
        USE_LOG=false           \
 %endif
-%if %{dbus}
-       USE_DBUS=true           \
-%else
-       USE_DBUS=false          \
-%endif
-%if %{selinux}
-       USE_SELINUX=true        \
-%else
-       USE_SELINUX=false       \
-%endif
 %if %{debug}
        DEBUG=true              \
 %else
@@ -81,24 +66,21 @@ make CC="gcc $RPM_OPT_FLAGS"        \
 %if %{scsi_id}
        extras/scsi_id  \
 %endif
+%if %{volume_id}
+       extras/volume_id        \
+%endif
 "
 
 %install
+rm -rf $RPM_BUILD_ROOT
 make DESTDIR=$RPM_BUILD_ROOT install \
-%if %{dbus}
-       USE_DBUS=true           \
-%else
-       USE_DBUS=false          \
-%endif
-%if %{selinux}
-       USE_SELINUX=true        \
-%else
-       USE_SELINUX=false       \
-%endif
        EXTRAS="        \
 %if %{scsi_id}
        extras/scsi_id  \
 %endif
+%if %{volume_id}
+       extras/volume_id        \
+%endif
 "
 
 %post
@@ -116,33 +98,41 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(-,root,root)
 %doc COPYING README TODO ChangeLog HOWTO* docs/*
 %doc etc/udev/udev.rules.{examples,gentoo,redhat}
-%doc etc/udev/udev.permissions.{gentoo,redhat}
 %attr(755,root,root) /sbin/udev
 %attr(755,root,root) /usr/bin/udevinfo
 %attr(755,root,root) /sbin/udevsend
 %attr(755,root,root) /sbin/udevd
-%attr(755,root,root) /sbin/udevtest
+%attr(755,root,root) /usr/bin/udevtest
 %attr(755,root,root) /sbin/udevstart
 %attr(755,root,root) %dir /udev/
 %attr(755,root,root) %dir /etc/udev/
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
-%config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
-%config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
+%attr(755,root,root) %dir /etc/udev/rules.d/
+%config(noreplace) %attr(0644,root,root) /etc/udev/rules.d/50-udev.rules
 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
 %attr(755,root,root) /etc/init.d/udev
 %attr(0644,root,root) %{_mandir}/man8/udev*.8*
-
-%if %{dbus}
-       %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
-%endif
+%attr(755,root,root) %dir /etc/dev.d/
+%attr(755,root,root) %dir /etc/dev.d/net/
+%attr(0755,root,root) /etc/dev.d/net/hotplug.dev
 
 %if %{scsi_id}
        %attr(755,root,root) /sbin/scsi_id
        %config(noreplace) %attr(0644,root,root) /etc/scsi_id.config
        %attr(0644,root,root) %{_mandir}/man8/scsi_id*.8*
 %endif
+%if %{volume_id}
+       %attr(755,root,root) /sbin/udev_volume_id
+%endif
 
 %changelog
+* Fri May 14 2004 Greg Kroah-Hartman <greg@kroah.com>
+- remove dbus and selinux stuff from here
+- added volume_id option
+
+* Wed Mar 24 2004 Greg Kroah-Hartman <greg@kroah.com>
+- change the way dbus and selinux support is built (now an extra)
+
 * Tue Mar 2 2004 Greg Kroah-Hartman <greg@kroah.com>
 - added udevstart to the list of files installed
 - udevinfo is now in /usr/bin not /sbin