chiark / gitweb /
[PATCH] add udevinfo to udev.spec file.
[elogind.git] / udev.spec
index 07331807ef785b68550713722cb0a1ee9b73dbdc..2be4496f403881e499485b83375002892aff1fe8 100644 (file)
--- a/udev.spec
+++ b/udev.spec
@@ -5,6 +5,12 @@
 # it probably is not where you want it to be.
 %define klibc 1
 
+# if we want to have logging support in or not.
+# 0 - no logging  support
+# 1 - logging support
+# Note, it is not recommend if you use klibc to enable logging.
+%define log 0
+
 # if we want to build DBUS support in or not.
 # 0 - no DBUS support
 # 1 - DBUS support
@@ -23,7 +29,7 @@
 
 Summary: A userspace implementation of devfs
 Name: udev
-Version: 013_bk
+Version: 014_bk
 Release: 1
 License: GPL
 Group: Utilities/System
@@ -45,6 +51,9 @@ make CC="gcc $RPM_OPT_FLAGS"  \
 %if %{klibc}
        USE_KLIBC=true          \
 %endif
+%if %{log}
+       USE_LOG=true            \
+%endif
 %if %{dbus}
        USE_DBUS=true           \
 %endif
@@ -76,6 +85,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(-,root,root)
 %doc COPYING README TODO ChangeLog
 %attr(755,root,root) /sbin/udev
+%attr(755,root,root) /sbin/udevinfo
 %attr(755,root,root) /udev/
 %attr(755,root,root) /etc/udev/
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
@@ -89,6 +99,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(0644,root,root) %{_mandir}/man8/udev.8*
 
 %changelog
+* Mon Jan 26 2004 Greg Kroah-Hartman <greg@kroah.com>
+- add udevinfo to rpm
+
 * Mon Jan 05 2004 Rolf Eike Beer <eike-hotplug@sf-tec.de>
 - add defines to choose the init script (Redhat or LSB)