chiark / gitweb /
remove special TIMEOUT handling from incoming queue
[elogind.git] / udev.spec
index 238494c45b61b5ada6b34cf237b7aedb3a8157bb..25bc2d7f2c4e4130394f0a29a10a71033fa025f8 100644 (file)
--- a/udev.spec
+++ b/udev.spec
 # Note, it is not recommend if you use klibc to enable logging.
 %define log 0
 
-# if we want to build DBUS support in or not.
-# 0 - no DBUS support
-# 1 - DBUS support
-%define dbus 0
-
 # if we want to enable debugging support in udev.  If it is enabled, lots of 
 # stuff will get sent to the debug syslog.
 # 0 - debugging disabled
 # 1 - debugging enabled
 %define debug 0
 
-# if we want to use the LSB version of the init script or the Redhat one
-# 0 - use Redhat version: etc/init.d/udev
-# 1 - use LSB version: etc/init.d/udev.init.LSB
-%define lsb 0
+# if we want to build the scsi_id "extra" package or not
+# 0 - do not build the package
+# 1 - build it
+%define scsi_id 1
+
+# if we want to build the volume_id "extra" package or not
+# 0 - do not build the package
+# 1 - build it
+%define volume_id 1
 
-Summary: A userspace implementation of devfs
+Summary: A userspace device manager providing devfs functionality
 Name: udev
-Version: 016
+Version: 068
 Release: 1
 License: GPL
 Group: Utilities/System
@@ -41,8 +41,9 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 Prereq: /bin/sh, fileutils, hotplug
 
 %description
-udev is a implementation of devfs in userspace using sysfs and
-/sbin/hotplug. It requires a 2.6 kernel to run properly.
+udev is a userspace device manager, using sysfs and uevents
+to provide a devfs-like device directory management and uevent
+dispatching.
 
 %prep
 %setup -q
@@ -54,26 +55,35 @@ make CC="gcc $RPM_OPT_FLAGS"        \
 %endif
 %if %{log}
        USE_LOG=true            \
-%endif
-%if %{dbus}
-       USE_DBUS=true           \
+%else
+       USE_LOG=false           \
 %endif
 %if %{debug}
        DEBUG=true              \
+%else
+       DEBUG=false             \
 %endif
-
-# now build udevd on it's own, as it can't handle being built with klibc
-make CC="gcc $RPM_OPT_FLAGS" udevd
-
+       EXTRAS="        \
+%if %{scsi_id}
+       extras/scsi_id  \
+%endif
+%if %{volume_id}
+       extras/volume_id        \
+%endif
+"
 
 %install
+rm -rf $RPM_BUILD_ROOT
 make DESTDIR=$RPM_BUILD_ROOT install \
-%if %{dbus}
-       USE_DBUS=true
+       EXTRAS="        \
+%if %{scsi_id}
+       extras/scsi_id  \
 %endif
-%if %{lsb}
-       USE_LSB=true
+%if %{volume_id}
+       extras/volume_id        \
 %endif
+"
+
 %post
 /sbin/chkconfig --add udev
 
@@ -87,24 +97,59 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root)
-%doc COPYING README TODO ChangeLog
+%doc COPYING README TODO ChangeLog HOWTO* docs/*
+%doc etc/udev/udev.rules.{examples,gentoo,redhat}
 %attr(755,root,root) /sbin/udev
-%attr(755,root,root) /sbin/udevinfo
+%attr(755,root,root) /usr/bin/udevinfo
 %attr(755,root,root) /sbin/udevsend
 %attr(755,root,root) /sbin/udevd
-%attr(755,root,root) /udev/
-%attr(755,root,root) /etc/udev/
+%attr(755,root,root) /usr/bin/udevtest
+%attr(755,root,root) /sbin/udevstart
+%attr(755,root,root) %dir /udev/
+%attr(755,root,root) %dir /etc/udev/
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
-%config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
-%config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
-%if %{dbus}
-       %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
-%endif
+%attr(755,root,root) %dir /etc/udev/rules.d/
+%config(noreplace) %attr(0644,root,root) /etc/udev/rules.d/50-udev.rules
 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
 %attr(755,root,root) /etc/init.d/udev
 %attr(0644,root,root) %{_mandir}/man8/udev*.8*
 
+%if %{scsi_id}
+       %attr(755,root,root) /sbin/scsi_id
+       %config(noreplace) %attr(0644,root,root) /etc/scsi_id.config
+       %attr(0644,root,root) %{_mandir}/man8/scsi_id*.8*
+%endif
+%if %{volume_id}
+       %attr(755,root,root) /sbin/udev_volume_id
+%endif
+
 %changelog
+* Fri May 14 2004 Greg Kroah-Hartman <greg@kroah.com>
+- remove dbus and selinux stuff from here
+- added volume_id option
+
+* Wed Mar 24 2004 Greg Kroah-Hartman <greg@kroah.com>
+- change the way dbus and selinux support is built (now an extra)
+
+* Tue Mar 2 2004 Greg Kroah-Hartman <greg@kroah.com>
+- added udevstart to the list of files installed
+- udevinfo is now in /usr/bin not /sbin
+
+* Fri Feb 27 2004 Greg Kroah-Hartman <greg@kroah.com>
+- added ability to build with SELinux support
+
+* Thu Feb 19 2004 Greg Kroah-Hartman <greg@kroah.com>
+- add some more files to the documentation directory
+- add ability to build scsi_id and make it the default
+
+* Mon Feb 16 2004 Greg Kroah-Hartman <greg@kroah.com>
+- fix up udevd build, as it's no longer needed to be build seperatly
+- add udevtest to list of files
+- more Red Hat sync ups.
+
+* Thu Feb 12 2004 Greg Kroah-Hartman <greg@kroah.com>
+- add some changes from the latest Fedora udev release.
+
 * Mon Feb 2 2004 Greg Kroah-Hartman <greg@kroah.com>
 - add udevsend, and udevd to the files
 - add ability to build udevd with glibc after the rest is build with klibc