chiark / gitweb /
remove special TIMEOUT handling from incoming queue
[elogind.git] / udev.spec
index 0c8969dfac76b3610fd0788283fdd9017026a5e4..25bc2d7f2c4e4130394f0a29a10a71033fa025f8 100644 (file)
--- a/udev.spec
+++ b/udev.spec
 # 1 - build it
 %define scsi_id 1
 
-Summary: A userspace implementation of devfs
+# if we want to build the volume_id "extra" package or not
+# 0 - do not build the package
+# 1 - build it
+%define volume_id 1
+
+Summary: A userspace device manager providing devfs functionality
 Name: udev
-Version: 025
+Version: 068
 Release: 1
 License: GPL
 Group: Utilities/System
@@ -36,8 +41,9 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 Prereq: /bin/sh, fileutils, hotplug
 
 %description
-udev is a implementation of devfs in userspace using sysfs and
-/sbin/hotplug. It requires a 2.6 kernel to run properly.
+udev is a userspace device manager, using sysfs and uevents
+to provide a devfs-like device directory management and uevent
+dispatching.
 
 %prep
 %setup -q
@@ -61,14 +67,21 @@ make CC="gcc $RPM_OPT_FLAGS"        \
 %if %{scsi_id}
        extras/scsi_id  \
 %endif
+%if %{volume_id}
+       extras/volume_id        \
+%endif
 "
 
 %install
+rm -rf $RPM_BUILD_ROOT
 make DESTDIR=$RPM_BUILD_ROOT install \
        EXTRAS="        \
 %if %{scsi_id}
        extras/scsi_id  \
 %endif
+%if %{volume_id}
+       extras/volume_id        \
+%endif
 "
 
 %post
@@ -86,7 +99,6 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(-,root,root)
 %doc COPYING README TODO ChangeLog HOWTO* docs/*
 %doc etc/udev/udev.rules.{examples,gentoo,redhat}
-%doc etc/udev/udev.permissions.{gentoo,redhat}
 %attr(755,root,root) /sbin/udev
 %attr(755,root,root) /usr/bin/udevinfo
 %attr(755,root,root) /sbin/udevsend
@@ -96,8 +108,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %dir /udev/
 %attr(755,root,root) %dir /etc/udev/
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
-%config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
-%config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
+%attr(755,root,root) %dir /etc/udev/rules.d/
+%config(noreplace) %attr(0644,root,root) /etc/udev/rules.d/50-udev.rules
 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
 %attr(755,root,root) /etc/init.d/udev
 %attr(0644,root,root) %{_mandir}/man8/udev*.8*
@@ -107,8 +119,15 @@ rm -rf $RPM_BUILD_ROOT
        %config(noreplace) %attr(0644,root,root) /etc/scsi_id.config
        %attr(0644,root,root) %{_mandir}/man8/scsi_id*.8*
 %endif
+%if %{volume_id}
+       %attr(755,root,root) /sbin/udev_volume_id
+%endif
 
 %changelog
+* Fri May 14 2004 Greg Kroah-Hartman <greg@kroah.com>
+- remove dbus and selinux stuff from here
+- added volume_id option
+
 * Wed Mar 24 2004 Greg Kroah-Hartman <greg@kroah.com>
 - change the way dbus and selinux support is built (now an extra)