chiark / gitweb /
[PATCH] better credential patch
[elogind.git] / udev.spec
index c34b1454f8e0ccf318da67d4616243bbb4acb9bd..20f415499841a2a06e5e8629b6576a8adf6bf49c 100644 (file)
--- a/udev.spec
+++ b/udev.spec
@@ -5,6 +5,12 @@
 # it probably is not where you want it to be.
 %define klibc 1
 
+# if we want to have logging support in or not.
+# 0 - no logging  support
+# 1 - logging support
+# Note, it is not recommend if you use klibc to enable logging.
+%define log 0
+
 # if we want to build DBUS support in or not.
 # 0 - no DBUS support
 # 1 - DBUS support
 # 1 - debugging enabled
 %define debug 0
 
+# if we want to use the LSB version of the init script or the Redhat one
+# 0 - use Redhat version: etc/init.d/udev
+# 1 - use LSB version: etc/init.d/udev.init.LSB
+%define lsb 0
+
 Summary: A userspace implementation of devfs
 Name: udev
-Version: 012
+Version: 016_bk
 Release: 1
 License: GPL
 Group: Utilities/System
 Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
 ExclusiveOS: Linux
 Vendor: Greg Kroah-Hartman <greg@kroah.com>
+URL : kernel.org/pub/linux/utils/kernel/hotplug/
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 Prereq: /bin/sh, fileutils, hotplug
 
@@ -40,6 +52,9 @@ make CC="gcc $RPM_OPT_FLAGS"  \
 %if %{klibc}
        USE_KLIBC=true          \
 %endif
+%if %{log}
+       USE_LOG=true            \
+%endif
 %if %{dbus}
        USE_DBUS=true           \
 %endif
@@ -47,12 +62,18 @@ make CC="gcc $RPM_OPT_FLAGS"        \
        DEBUG=true              \
 %endif
 
+# now build udevd on it's own, as it can't handle being built with klibc
+make CC="gcc $RPM_OPT_FLAGS" udevd
+
+
 %install
 make DESTDIR=$RPM_BUILD_ROOT install \
 %if %{dbus}
        USE_DBUS=true
 %endif
-
+%if %{lsb}
+       USE_LSB=true
+%endif
 %post
 /sbin/chkconfig --add udev
 
@@ -68,6 +89,9 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(-,root,root)
 %doc COPYING README TODO ChangeLog
 %attr(755,root,root) /sbin/udev
+%attr(755,root,root) /sbin/udevinfo
+%attr(755,root,root) /sbin/udevsend
+%attr(755,root,root) /sbin/udevd
 %attr(755,root,root) /udev/
 %attr(755,root,root) /etc/udev/
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
@@ -78,9 +102,21 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
 %attr(755,root,root) /etc/init.d/udev
-%attr(0644,root,root) %{_mandir}/man8/udev.8*
+%attr(0644,root,root) %{_mandir}/man8/udev*.8*
 
 %changelog
+* Mon Feb 2 2004 Greg Kroah-Hartman <greg@kroah.com>
+- add udevsend, and udevd to the files
+- add ability to build udevd with glibc after the rest is build with klibc
+
+* Mon Jan 26 2004 Greg Kroah-Hartman <greg@kroah.com>
+- added udevinfo to rpm
+- added URL to spec file
+- added udevinfo's man page
+
+* Mon Jan 05 2004 Rolf Eike Beer <eike-hotplug@sf-tec.de>
+- add defines to choose the init script (Redhat or LSB)
+
 * Tue Dec 16 2003 Robert Love <rml@ximian.com>
 - install the initscript and run chkconfig on it
 
@@ -96,4 +132,3 @@ rm -rf $RPM_BUILD_ROOT
 
 * Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
 - Initial spec file for udev-0.2.
-