chiark / gitweb /
[PATCH] 023_bk mark
[elogind.git] / udev.spec
index 4cd1f8a94bc9aaba8170826f49e1bae3fb6b5ef3..1df59ecdb879155fda8c40e3d70f3ca5f3f79db9 100644 (file)
--- a/udev.spec
+++ b/udev.spec
 # Note, it is not recommend if you use klibc to enable logging.
 %define log 0
 
-# if we want to build DBUS support in or not.
-# 0 - no DBUS support
-# 1 - DBUS support
-%define dbus 0
-
-# if we want to build SELinux support in or not.
-# 0 - no SELinux support
-# 1 - SELinux support
-%define selinux 1 
-
 # if we want to enable debugging support in udev.  If it is enabled, lots of 
 # stuff will get sent to the debug syslog.
 # 0 - debugging disabled
 # 1 - debugging enabled
 %define debug 0
 
-# if we want to use the LSB version of the init script or the Redhat one
-# 0 - use Redhat: etc/init.d/udev
-# 1 - use LSB: etc/init.d/udev.init.LSB
-%define lsb 0
+# if we want to build the DBUS "extra" package or not
+# 0 - no DBUS support
+# 1 - DBUS support
+%define dbus 0
+
+# if we want to build the SELinux "extra" package or not
+# 0 - no SELinux support
+# 1 - SELinux support
+%define selinux 0
 
 # if we want to build the scsi_id "extra" package or not
 # 0 - do not build the package
@@ -39,7 +34,7 @@
 
 Summary: A userspace implementation of devfs
 Name: udev
-Version: 018_bk
+Version: 023_bk
 Release: 1
 License: GPL
 Group: Utilities/System
@@ -67,16 +62,6 @@ make CC="gcc $RPM_OPT_FLAGS" \
 %else
        USE_LOG=false           \
 %endif
-%if %{dbus}
-       USE_DBUS=true           \
-%else
-       USE_DBUS=false          \
-%endif
-%if %{selinux}
-       USE_SELINUX=true        \
-%else
-       USE_SELINUX=false       \
-%endif
 %if %{debug}
        DEBUG=true              \
 %else
@@ -86,29 +71,26 @@ make CC="gcc $RPM_OPT_FLAGS"        \
 %if %{scsi_id}
        extras/scsi_id  \
 %endif
-"
-
-%install
-make DESTDIR=$RPM_BUILD_ROOT install \
 %if %{dbus}
-       USE_DBUS=true           \
-%else
-       USE_DBUS=false          \
+       extras/dbus     \
 %endif
 %if %{selinux}
-       USE_SELINUX=true        \
-%else
-       USE_SELINUX=false       \
-%endif
-%if %{lsb}
-       USE_LSB=true            \
-%else
-       USE_LSB=false           \
+       extras/selinux  \
 %endif
+"
+
+%install
+make DESTDIR=$RPM_BUILD_ROOT install \
        EXTRAS="        \
 %if %{scsi_id}
        extras/scsi_id  \
 %endif
+%if %{dbus}
+       extras/dbus     \
+%endif
+%if %{selinux}
+       extras/selinux  \
+%endif
 "
 
 %post
@@ -124,12 +106,15 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root)
-%doc COPYING README TODO ChangeLog HOWTO* etc/udev/udev.rules.examples docs/*
+%doc COPYING README TODO ChangeLog HOWTO* docs/*
+%doc etc/udev/udev.rules.{examples,gentoo,redhat}
+%doc etc/udev/udev.permissions.{gentoo,redhat}
 %attr(755,root,root) /sbin/udev
-%attr(755,root,root) /sbin/udevinfo
+%attr(755,root,root) /usr/bin/udevinfo
 %attr(755,root,root) /sbin/udevsend
 %attr(755,root,root) /sbin/udevd
-%attr(755,root,root) /sbin/udevtest
+%attr(755,root,root) /usr/bin/udevtest
+%attr(755,root,root) /sbin/udevstart
 %attr(755,root,root) %dir /udev/
 %attr(755,root,root) %dir /etc/udev/
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
@@ -150,6 +135,16 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 
 %changelog
+* Wed Mar 24 2004 Greg Kroah-Hartman <greg@kroah.com>
+- change the way dbus and selinux support is built (now an extra)
+
+* Tue Mar 2 2004 Greg Kroah-Hartman <greg@kroah.com>
+- added udevstart to the list of files installed
+- udevinfo is now in /usr/bin not /sbin
+
+* Fri Feb 27 2004 Greg Kroah-Hartman <greg@kroah.com>
+- added ability to build with SELinux support
+
 * Thu Feb 19 2004 Greg Kroah-Hartman <greg@kroah.com>
 - add some more files to the documentation directory
 - add ability to build scsi_id and make it the default