chiark / gitweb /
update TODO
[elogind.git] / docs / libudev / Makefile.am
index c6d7b8ca25a29e1214b870168a853fafccdca6b1..2998c3516766c85c291bf5d3bcecc7606b4e6aaa 100644 (file)
@@ -1,7 +1,7 @@
 ## Process this file with automake to produce Makefile.in
 
 # We require automake 1.10 at least.
-AUTOMAKE_OPTIONS = 1.10
+AUTOMAKE_OPTIONS = 1.10 color-tests
 
 # This is a blank Makefile.am for using gtk-doc.
 # Copy this to your project's API docs directory and modify the variables to
@@ -57,7 +57,7 @@ EXTRA_HFILES=
 
 # Header files to ignore when scanning. Use base file name, no paths
 # e.g. IGNORE_HFILES=gtkdebug.h gtkintl.h
-IGNORE_HFILES = libudev-private.h libudev-hwdb-def.h
+IGNORE_HFILES = libudev-private.h
 
 # Images to copy into HTML directory.
 # e.g. HTML_IMAGES=$(top_srcdir)/gtk/stock-icons/stock_about_24.png
@@ -102,6 +102,8 @@ EXTRA_DIST += version.xml.in
 
 # Comment this out if you want your docs-status tested during 'make check'
 if ENABLE_GTK_DOC
-TESTS_ENVIRONMENT = cd $(top_srcdir)
-TESTS = $(GTKDOC_CHECK)
+if ENABLE_GTK_DOC_TESTS
+#TESTS_ENVIRONMENT = cd $(top_srcdir)
+#TESTS = $(GTKDOC_CHECK)
+endif
 endif