chiark / gitweb /
docs: rebase html documentation for online and local use
[elogind.git] / docs / gudev / Makefile.am
index 803a2bbd80ae939dd93afd5f75727a581796bd19..f984eb5cbc509855859ec9fe9a927c42f77b1cae 100644 (file)
@@ -21,7 +21,7 @@ DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.xml
 # gtk-doc will search all .c & .h files beneath here for inline comments
 # documenting the functions and macros.
 # e.g. DOC_SOURCE_DIR=../../../gtk
-DOC_SOURCE_DIR=$(top_srcdir)/src/gudev
+DOC_SOURCE_DIR=$(top_srcdir)/src/gudev $(top_builddir)/src/gudev
 
 # Extra options to pass to gtkdoc-scangobj. Not normally needed.
 SCANGOBJ_OPTIONS=
@@ -32,7 +32,7 @@ SCAN_OPTIONS=
 
 # Extra options to supply to gtkdoc-mkdb.
 # e.g. MKDB_OPTIONS=--sgml-mode --output-format=xml
-MKDB_OPTIONS=--sgml-mode --output-format=xml --name-space=g_udev
+MKDB_OPTIONS=--xml-mode --output-format=xml --name-space=g_udev
 
 # Extra options to supply to gtkdoc-mktmpl
 # e.g. MKTMPL_OPTIONS=--only-section-tmpl
@@ -103,3 +103,6 @@ if ENABLE_GTK_DOC
 #TESTS_ENVIRONMENT = cd $(srcsrc)
 #TESTS = $(GTKDOC_CHECK)
 endif
+
+install-data-hook:
+       $(AM_V_GEN)gtkdoc-rebase --html-dir=$(top_builddir)/docs/gudev/html --relative