chiark / gitweb /
update TODO
[elogind.git] / docs / gudev / Makefile.am
index 55172f2c33a545792aeb4daa9a7ca595736ae7ec..659330303b91b771abb98f6b0b89e11ee9b56815 100644 (file)
@@ -1,7 +1,7 @@
 ## Process this file with automake to produce Makefile.in
 
 # We require automake 1.10 at least.
-AUTOMAKE_OPTIONS = 1.10
+AUTOMAKE_OPTIONS = 1.10 color-tests
 
 # This is a blank Makefile.am for using gtk-doc.
 # Copy this to your project's API docs directory and modify the variables to
@@ -43,7 +43,7 @@ MKHTML_OPTIONS=--path=$(abs_srcdir) --path=$(abs_builddir)
 
 # Extra options to supply to gtkdoc-fixref. Not normally needed.
 # e.g. FIXXREF_OPTIONS=--extra-dir=../gdk-pixbuf/html --extra-dir=../gdk/html
-FIXXREF_OPTIONS=
+FIXXREF_OPTIONS=>/dev/null 2>&1
 
 # Used for dependencies. The docs will be rebuilt if any of these change.
 # e.g. HFILE_GLOB=$(top_srcdir)/gtk/*.h
@@ -108,6 +108,8 @@ EXTRA_DIST += version.xml.in
 
 # Comment this out if you want your docs-status tested during 'make check'
 if ENABLE_GTK_DOC
-TESTS_ENVIRONMENT = cd $(top_srcdir)
-TESTS = $(GTKDOC_CHECK)
+if ENABLE_GTK_DOC_TESTS
+#TESTS_ENVIRONMENT = cd $(top_srcdir)
+#TESTS = $(GTKDOC_CHECK)
+endif
 endif