chiark / gitweb /
make sure __NR_name_to_handle_at is correctly defined
[elogind.git] / docs / gudev / Makefile.am
index 11312b679a3190b0baecb759aa640c30a602b780..55172f2c33a545792aeb4daa9a7ca595736ae7ec 100644 (file)
@@ -72,6 +72,14 @@ content_files = version.xml
 # e.g. expand_content_files=running.sgml
 expand_content_files=
 
+# Hack, hack. You silly gtk-doc, you must not add  CFLAGS multiple
+# times when calling gcc; it surely can not work with options that must
+# be listed only once.
+# Kill CFLAGS here because gtk-doc thinks adding CFLAGS to CC _and_ also
+# adding CFLAGS itself again would work.
+override CFLAGS=
+override LDFLAGS=
+
 # CFLAGS and LDFLAGS for compiling gtkdoc-scangobj with your library.
 # Only needed if you are using gtkdoc-scangobj to dynamically query widget
 # signals and properties.
@@ -87,7 +95,7 @@ GTKDOC_LIBS = \
        $(top_builddir)/libgudev-1.0.la
 
 # This includes the standard gtk-doc make rules, copied by gtkdocize.
-include $(top_srcdir)/gtk-doc.make
+include $(top_srcdir)/docs/gtk-doc.make
 
 # Other files to distribute
 # e.g. EXTRA_DIST += version.xml.in
@@ -103,6 +111,3 @@ if ENABLE_GTK_DOC
 TESTS_ENVIRONMENT = cd $(top_srcdir)
 TESTS = $(GTKDOC_CHECK)
 endif
-
-install-data-hook:
-       $(AM_V_GEN)gtkdoc-rebase --html-dir=$(top_builddir)/docs/gudev/html --relative