chiark / gitweb /
docs: hook-up gtk-doc to 'make check'
[elogind.git] / docs / gudev / Makefile.am
index 803a2bbd80ae939dd93afd5f75727a581796bd19..11312b679a3190b0baecb759aa640c30a602b780 100644 (file)
@@ -21,7 +21,7 @@ DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.xml
 # gtk-doc will search all .c & .h files beneath here for inline comments
 # documenting the functions and macros.
 # e.g. DOC_SOURCE_DIR=../../../gtk
-DOC_SOURCE_DIR=$(top_srcdir)/src/gudev
+DOC_SOURCE_DIR=$(top_srcdir)/src/gudev $(top_builddir)/src/gudev
 
 # Extra options to pass to gtkdoc-scangobj. Not normally needed.
 SCANGOBJ_OPTIONS=
@@ -32,7 +32,7 @@ SCAN_OPTIONS=
 
 # Extra options to supply to gtkdoc-mkdb.
 # e.g. MKDB_OPTIONS=--sgml-mode --output-format=xml
-MKDB_OPTIONS=--sgml-mode --output-format=xml --name-space=g_udev
+MKDB_OPTIONS=--xml-mode --output-format=xml --name-space=g_udev
 
 # Extra options to supply to gtkdoc-mktmpl
 # e.g. MKTMPL_OPTIONS=--only-section-tmpl
@@ -57,7 +57,7 @@ EXTRA_HFILES=
 
 # Header files to ignore when scanning. Use base file name, no paths
 # e.g. IGNORE_HFILES=gtkdebug.h gtkintl.h
-IGNORE_HFILES=
+IGNORE_HFILES=gudevenumtypes.h gudevmarshal.h
 
 # Images to copy into HTML directory.
 # e.g. HTML_IMAGES=$(top_srcdir)/gtk/stock-icons/stock_about_24.png
@@ -83,8 +83,8 @@ GTKDOC_CFLAGS = \
        -I$(top_builddir)/src/gudev
 
 GTKDOC_LIBS = \
-        $(GLIB_LIBS) \
-        $(top_builddir)/libgudev-1.0.la
+       $(GLIB_LIBS) \
+       $(top_builddir)/libgudev-1.0.la
 
 # This includes the standard gtk-doc make rules, copied by gtkdocize.
 include $(top_srcdir)/gtk-doc.make
@@ -100,6 +100,9 @@ EXTRA_DIST += version.xml.in
 
 # Comment this out if you want your docs-status tested during 'make check'
 if ENABLE_GTK_DOC
-#TESTS_ENVIRONMENT = cd $(srcsrc)
-#TESTS = $(GTKDOC_CHECK)
+TESTS_ENVIRONMENT = cd $(top_srcdir)
+TESTS = $(GTKDOC_CHECK)
 endif
+
+install-data-hook:
+       $(AM_V_GEN)gtkdoc-rebase --html-dir=$(top_builddir)/docs/gudev/html --relative