chiark / gitweb /
Commit patch queue (exported by git-debrebase)
[elogind.git] / debian / rules
index 1207d9174fd96fcd10e2ab8b29dd5be691950375..ca23621d94f4f548a05a9cd5b0ebefdf8476d69f 100755 (executable)
@@ -1,27 +1,35 @@
 #! /usr/bin/make -f
 
-DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+# The options have been chooses as follows:
+# - manually set pamlibdir because we'Re installing in /usr by default but 
+#   pam libs must go to /lib/*/security
+# - Disable lto because this makes the build fail with static library 
+#   warnings and with  linking errors. (It seems taht instead of ar/ld 
+#   gcc-ar and gcc should be used)
+# - tests disabled beacuase some of the tests seem to require elogind running.
+#   Need to sort out which tests could be run
 
-# disable lto because this does not work for me. Building static libraries with i
-# libtool/ar failes. I think this a apackage problem, it should use gcc-ar instead
-# also some of the tests fail
 CONFFLAGS = \
-  --exec-prefix= \
-  --with-rootprefix= \
-  --with-rootlibdir=/lib/$(DEB_HOST_MULTIARCH) \
-  --enable-kdbus \
+  --with-pamlibdir=/lib/$(DEB_HOST_MULTIARCH)/security \
+  --with-udevrulesdir=/lib/udev/rules.d \
   --disable-lto \
   --disable-tests
 
-autoreconf:
-       ./autogen.sh
-       
+CONFFLAGS_CGROUPCTRL_ELOGIND= \
+  --with-cgroup-controller=elogind
+
 override_dh_autoreconf:
-       dh_autoreconf debian/rules -- autoreconf
+       dh_autoreconf ./autogen.sh
 
 override_dh_auto_configure:
        dh_auto_configure --builddirectory=build \
-    -- $(CONFFLAGS)
+    -- $(CONFFLAGS) $(CONFFLAGS_CGROUPCTRL_ELOGIND)
+
+override_dh_missing:
+       dh_missing --list-missing
+
+override_dh_shlibdeps:
+       dh_shlibdeps -- -xlibeudev1
 
 %:
        dh $@ --builddirectory=build --with autoreconf --parallel