chiark / gitweb /
Fix install locations
[elogind.git] / debian / rules
index 99bed261089aba209d2179a5b777ba6688246e1c..1207d9174fd96fcd10e2ab8b29dd5be691950375 100755 (executable)
@@ -4,8 +4,11 @@ DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
 
 # disable lto because this does not work for me. Building static libraries with i
 # libtool/ar failes. I think this a apackage problem, it should use gcc-ar instead
+# also some of the tests fail
 CONFFLAGS = \
-  --libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) \
+  --exec-prefix= \
+  --with-rootprefix= \
+  --with-rootlibdir=/lib/$(DEB_HOST_MULTIARCH) \
   --enable-kdbus \
   --disable-lto \
   --disable-tests