chiark / gitweb /
sd-device: enumerator - match only on initialized devices by default
[elogind.git] / autogen.sh
index 234e829..3997db3 100755 (executable)
@@ -1,57 +1,41 @@
-#!/bin/sh -e
+#!/bin/sh
 
-(autoconf --version) < /dev/null > /dev/null 2>&1 || {
-       echo
-       echo "You must have autoconf installed to generate the build system."
-       echo
-       exit 1
-}
-(libtoolize --version) < /dev/null > /dev/null 2>&1 || {
-       echo
-       echo "You must have libtool installed to generate the build system."
-       echo
-       exit 1
-}
-(autoheader --version) < /dev/null > /dev/null 2>&1 || {
-       echo
-       echo "You must have autoheader installed to generate the build system."
-       echo
-       exit 1
-}
-(automake --version) < /dev/null > /dev/null 2>&1 || {
-       echo
-       echo "You must have automake installed to generate the build system."
-       echo
-       exit 1
-}
+#  This file is part of systemd.
+#
+#  systemd is free software; you can redistribute it and/or modify it
+#  under the terms of the GNU Lesser General Public License as published by
+#  the Free Software Foundation; either version 2.1 of the License, or
+#  (at your option) any later version.
+#
+#  systemd is distributed in the hope that it will be useful, but
+#  WITHOUT ANY WARRANTY; without even the implied warranty of
+#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+#  Lesser General Public License for more details.
+#
+#  You should have received a copy of the GNU Lesser General Public License
+#  along with systemd; If not, see <http://www.gnu.org/licenses/>.
 
-test -f udev/udevd.c || {
-       echo "You must run this script in the top-level source directory"
-       exit 1
-}
+set -e
 
-echo "   aclocal:    $(aclocal --version | head -1)"
-aclocal
-echo "   autoconf:   $(autoconf --version | head -1)"
-autoconf
-echo "   libtool:   $(automake --version | head -1)"
-libtoolize --force
-echo "   autoheader: $(autoheader --version | head -1)"
-autoheader
-echo "   automake:   $(automake --version | head -1)"
-automake --add-missing
+oldpwd=$(pwd)
+topdir=$(dirname $0)
+cd $topdir
 
-if test -z "$@"; then
-       args="--prefix=/usr --exec-prefix= --sysconfdir=/etc"
-       args="$args --with-libdir-name=$(basename $(gcc -print-multi-os-directory))"
-       export CFLAGS="-g -Wall \
--Wmissing-declarations -Wmissing-prototypes \
--Wnested-externs -Wpointer-arith \
--Wpointer-arith -Wsign-compare -Wchar-subscripts \
--Wstrict-prototypes -Wshadow"
+if [ -f .git/hooks/pre-commit.sample ] && [ ! -f .git/hooks/pre-commit ]; then
+        # This part is allowed to fail
+        cp -p .git/hooks/pre-commit.sample .git/hooks/pre-commit && \
+        chmod +x .git/hooks/pre-commit && \
+        echo "Activated pre-commit hook." || :
+fi
+
+if which gtkdocize >/dev/null 2>/dev/null; then
+        gtkdocize --docdir docs/ --flavour no-tmpl
+        gtkdocargs=--enable-gtk-doc
 else
-       args=$@
+        echo "You don't have gtk-doc installed, and thus won't be able to generate the documentation."
+        rm -f docs/gtk-doc.make
+        echo 'EXTRA_DIST =' > docs/gtk-doc.make
 fi
-echo "   configure:  $args"
-echo
-./configure $args
+
+intltoolize --force --automake
+autoreconf --force --install --symlink