chiark / gitweb /
[PATCH] remove dbus and selinux stuff from the udev.spec file.
[elogind.git] / udev.spec
1 # if we want to build against the included version of klibc or not.
2 # 0 - do not use klibc
3 # 1 - use klibc
4 # Watch out for where the linux symlink is in the klibc part of the tarball,
5 # it probably is not where you want it to be.
6 %define klibc 1
7
8 # if we want to have logging support in or not.
9 # 0 - no logging  support
10 # 1 - logging support
11 # Note, it is not recommend if you use klibc to enable logging.
12 %define log 0
13
14 # if we want to enable debugging support in udev.  If it is enabled, lots of 
15 # stuff will get sent to the debug syslog.
16 # 0 - debugging disabled
17 # 1 - debugging enabled
18 %define debug 0
19
20 # if we want to build the scsi_id "extra" package or not
21 # 0 - do not build the package
22 # 1 - build it
23 %define scsi_id 1
24
25 Summary: A userspace implementation of devfs
26 Name: udev
27 Version: 025
28 Release: 1
29 License: GPL
30 Group: Utilities/System
31 Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
32 ExclusiveOS: Linux
33 Vendor: Greg Kroah-Hartman <greg@kroah.com>
34 URL : kernel.org/pub/linux/utils/kernel/hotplug/
35 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
36 Prereq: /bin/sh, fileutils, hotplug
37
38 %description
39 udev is a implementation of devfs in userspace using sysfs and
40 /sbin/hotplug. It requires a 2.6 kernel to run properly.
41
42 %prep
43 %setup -q
44
45 %build
46 make CC="gcc $RPM_OPT_FLAGS"    \
47 %if %{klibc}
48         USE_KLIBC=true          \
49 %endif
50 %if %{log}
51         USE_LOG=true            \
52 %else
53         USE_LOG=false           \
54 %endif
55 %if %{debug}
56         DEBUG=true              \
57 %else
58         DEBUG=false             \
59 %endif
60         EXTRAS="        \
61 %if %{scsi_id}
62         extras/scsi_id  \
63 %endif
64 "
65
66 %install
67 make DESTDIR=$RPM_BUILD_ROOT install \
68         EXTRAS="        \
69 %if %{scsi_id}
70         extras/scsi_id  \
71 %endif
72 "
73
74 %post
75 /sbin/chkconfig --add udev
76
77 %postun
78 if [ $1 = 0 ]; then
79         /sbin/chkconfig --del udev
80 fi
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(-,root,root)
87 %doc COPYING README TODO ChangeLog HOWTO* docs/*
88 %doc etc/udev/udev.rules.{examples,gentoo,redhat}
89 %doc etc/udev/udev.permissions.{gentoo,redhat}
90 %attr(755,root,root) /sbin/udev
91 %attr(755,root,root) /usr/bin/udevinfo
92 %attr(755,root,root) /sbin/udevsend
93 %attr(755,root,root) /sbin/udevd
94 %attr(755,root,root) /usr/bin/udevtest
95 %attr(755,root,root) /sbin/udevstart
96 %attr(755,root,root) %dir /udev/
97 %attr(755,root,root) %dir /etc/udev/
98 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
99 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
100 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
101 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
102 %attr(755,root,root) /etc/init.d/udev
103 %attr(0644,root,root) %{_mandir}/man8/udev*.8*
104
105 %if %{scsi_id}
106         %attr(755,root,root) /sbin/scsi_id
107         %config(noreplace) %attr(0644,root,root) /etc/scsi_id.config
108         %attr(0644,root,root) %{_mandir}/man8/scsi_id*.8*
109 %endif
110
111 %changelog
112 * Wed Mar 24 2004 Greg Kroah-Hartman <greg@kroah.com>
113 - change the way dbus and selinux support is built (now an extra)
114
115 * Tue Mar 2 2004 Greg Kroah-Hartman <greg@kroah.com>
116 - added udevstart to the list of files installed
117 - udevinfo is now in /usr/bin not /sbin
118
119 * Fri Feb 27 2004 Greg Kroah-Hartman <greg@kroah.com>
120 - added ability to build with SELinux support
121
122 * Thu Feb 19 2004 Greg Kroah-Hartman <greg@kroah.com>
123 - add some more files to the documentation directory
124 - add ability to build scsi_id and make it the default
125
126 * Mon Feb 16 2004 Greg Kroah-Hartman <greg@kroah.com>
127 - fix up udevd build, as it's no longer needed to be build seperatly
128 - add udevtest to list of files
129 - more Red Hat sync ups.
130
131 * Thu Feb 12 2004 Greg Kroah-Hartman <greg@kroah.com>
132 - add some changes from the latest Fedora udev release.
133
134 * Mon Feb 2 2004 Greg Kroah-Hartman <greg@kroah.com>
135 - add udevsend, and udevd to the files
136 - add ability to build udevd with glibc after the rest is build with klibc
137
138 * Mon Jan 26 2004 Greg Kroah-Hartman <greg@kroah.com>
139 - added udevinfo to rpm
140 - added URL to spec file
141 - added udevinfo's man page
142
143 * Mon Jan 05 2004 Rolf Eike Beer <eike-hotplug@sf-tec.de>
144 - add defines to choose the init script (Redhat or LSB)
145
146 * Tue Dec 16 2003 Robert Love <rml@ximian.com>
147 - install the initscript and run chkconfig on it
148
149 * Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
150 - changes due to config file name changes
151
152 * Fri Oct 17 2003 Robert Love <rml@tech9.net>
153 - Make work without a build root
154 - Correctly install the right files
155 - Pass the RPM_OPT_FLAGS to gcc so we can build per the build policy
156 - Put some prereqs in
157 - Install the hotplug symlink to udev
158
159 * Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
160 - Initial spec file for udev-0.2.