chiark / gitweb /
[PATCH] fix udev.spec to find udevinfo now that it has moved to /usr/bin
[elogind.git] / udev.spec
1 # if we want to build against the included version of klibc or not.
2 # 0 - do not use klibc
3 # 1 - use klibc
4 # Watch out for where the linux symlink is in the klibc part of the tarball,
5 # it probably is not where you want it to be.
6 %define klibc 1
7
8 # if we want to have logging support in or not.
9 # 0 - no logging  support
10 # 1 - logging support
11 # Note, it is not recommend if you use klibc to enable logging.
12 %define log 0
13
14 # if we want to build DBUS support in or not.
15 # 0 - no DBUS support
16 # 1 - DBUS support
17 %define dbus 0
18
19 # if we want to build SELinux support in or not.
20 # 0 - no SELinux support
21 # 1 - SELinux support
22 %define selinux 0
23
24 # if we want to enable debugging support in udev.  If it is enabled, lots of 
25 # stuff will get sent to the debug syslog.
26 # 0 - debugging disabled
27 # 1 - debugging enabled
28 %define debug 0
29
30 # if we want to build the scsi_id "extra" package or not
31 # 0 - do not build the package
32 # 1 - build it
33 %define scsi_id 1
34
35 Summary: A userspace implementation of devfs
36 Name: udev
37 Version: 020
38 Release: 1
39 License: GPL
40 Group: Utilities/System
41 Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
42 ExclusiveOS: Linux
43 Vendor: Greg Kroah-Hartman <greg@kroah.com>
44 URL : kernel.org/pub/linux/utils/kernel/hotplug/
45 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
46 Prereq: /bin/sh, fileutils, hotplug
47
48 %description
49 udev is a implementation of devfs in userspace using sysfs and
50 /sbin/hotplug. It requires a 2.6 kernel to run properly.
51
52 %prep
53 %setup -q
54
55 %build
56 make CC="gcc $RPM_OPT_FLAGS"    \
57 %if %{klibc}
58         USE_KLIBC=true          \
59 %endif
60 %if %{log}
61         USE_LOG=true            \
62 %else
63         USE_LOG=false           \
64 %endif
65 %if %{dbus}
66         USE_DBUS=true           \
67 %else
68         USE_DBUS=false          \
69 %endif
70 %if %{selinux}
71         USE_SELINUX=true        \
72 %else
73         USE_SELINUX=false       \
74 %endif
75 %if %{debug}
76         DEBUG=true              \
77 %else
78         DEBUG=false             \
79 %endif
80         EXTRAS="        \
81 %if %{scsi_id}
82         extras/scsi_id  \
83 %endif
84 "
85
86 %install
87 make DESTDIR=$RPM_BUILD_ROOT install \
88 %if %{dbus}
89         USE_DBUS=true           \
90 %else
91         USE_DBUS=false          \
92 %endif
93 %if %{selinux}
94         USE_SELINUX=true        \
95 %else
96         USE_SELINUX=false       \
97 %endif
98         EXTRAS="        \
99 %if %{scsi_id}
100         extras/scsi_id  \
101 %endif
102 "
103
104 %post
105 /sbin/chkconfig --add udev
106
107 %postun
108 if [ $1 = 0 ]; then
109         /sbin/chkconfig --del udev
110 fi
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %files
116 %defattr(-,root,root)
117 %doc COPYING README TODO ChangeLog HOWTO* etc/udev/udev.rules.examples docs/*
118 %attr(755,root,root) /sbin/udev
119 %attr(755,root,root) /usr/bin/udevinfo
120 %attr(755,root,root) /sbin/udevsend
121 %attr(755,root,root) /sbin/udevd
122 %attr(755,root,root) /sbin/udevtest
123 %attr(755,root,root) /sbin/udevstart
124 %attr(755,root,root) %dir /udev/
125 %attr(755,root,root) %dir /etc/udev/
126 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
127 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
128 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
129 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
130 %attr(755,root,root) /etc/init.d/udev
131 %attr(0644,root,root) %{_mandir}/man8/udev*.8*
132
133 %if %{dbus}
134         %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
135 %endif
136
137 %if %{scsi_id}
138         %attr(755,root,root) /sbin/scsi_id
139         %config(noreplace) %attr(0644,root,root) /etc/scsi_id.config
140         %attr(0644,root,root) %{_mandir}/man8/scsi_id*.8*
141 %endif
142
143 %changelog
144 * Tue Mar 2 2004 Greg Kroah-Hartman <greg@kroah.com>
145 - added udevstart to the list of files installed
146 - udevinfo is now in /usr/bin not /sbin
147
148 * Fri Feb 27 2004 Greg Kroah-Hartman <greg@kroah.com>
149 - added ability to build with SELinux support
150
151 * Thu Feb 19 2004 Greg Kroah-Hartman <greg@kroah.com>
152 - add some more files to the documentation directory
153 - add ability to build scsi_id and make it the default
154
155 * Mon Feb 16 2004 Greg Kroah-Hartman <greg@kroah.com>
156 - fix up udevd build, as it's no longer needed to be build seperatly
157 - add udevtest to list of files
158 - more Red Hat sync ups.
159
160 * Thu Feb 12 2004 Greg Kroah-Hartman <greg@kroah.com>
161 - add some changes from the latest Fedora udev release.
162
163 * Mon Feb 2 2004 Greg Kroah-Hartman <greg@kroah.com>
164 - add udevsend, and udevd to the files
165 - add ability to build udevd with glibc after the rest is build with klibc
166
167 * Mon Jan 26 2004 Greg Kroah-Hartman <greg@kroah.com>
168 - added udevinfo to rpm
169 - added URL to spec file
170 - added udevinfo's man page
171
172 * Mon Jan 05 2004 Rolf Eike Beer <eike-hotplug@sf-tec.de>
173 - add defines to choose the init script (Redhat or LSB)
174
175 * Tue Dec 16 2003 Robert Love <rml@ximian.com>
176 - install the initscript and run chkconfig on it
177
178 * Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
179 - changes due to config file name changes
180
181 * Fri Oct 17 2003 Robert Love <rml@tech9.net>
182 - Make work without a build root
183 - Correctly install the right files
184 - Pass the RPM_OPT_FLAGS to gcc so we can build per the build policy
185 - Put some prereqs in
186 - Install the hotplug symlink to udev
187
188 * Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
189 - Initial spec file for udev-0.2.