chiark / gitweb /
[PATCH] remove limit of the number of args passed to PROGRAM
[elogind.git] / udev.spec
1 # if we want to build against the included version of klibc or not.
2 # 0 - do not use klibc
3 # 1 - use klibc
4 # Watch out for where the linux symlink is in the klibc part of the tarball,
5 # it probably is not where you want it to be.
6 %define klibc 1
7
8 # if we want to have logging support in or not.
9 # 0 - no logging  support
10 # 1 - logging support
11 # Note, it is not recommend if you use klibc to enable logging.
12 %define log 0
13
14 # if we want to build DBUS support in or not.
15 # 0 - no DBUS support
16 # 1 - DBUS support
17 %define dbus 0
18
19 # if we want to enable debugging support in udev.  If it is enabled, lots of 
20 # stuff will get sent to the debug syslog.
21 # 0 - debugging disabled
22 # 1 - debugging enabled
23 %define debug 0
24
25 # if we want to use the LSB version of the init script or the Redhat one
26 # 0 - use Redhat: etc/init.d/udev
27 # 1 - use LSB: etc/init.d/udev.init.LSB
28 %define lsb 0
29
30 # if we want to build the scsi_id "extra" package or not
31 # 0 - do not build the package
32 # 1 - build it
33 %define scsi_id 1
34
35 Summary: A userspace implementation of devfs
36 Name: udev
37 Version: 018_bk
38 Release: 1
39 License: GPL
40 Group: Utilities/System
41 Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
42 ExclusiveOS: Linux
43 Vendor: Greg Kroah-Hartman <greg@kroah.com>
44 URL : kernel.org/pub/linux/utils/kernel/hotplug/
45 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
46 Prereq: /bin/sh, fileutils, hotplug
47
48 %description
49 udev is a implementation of devfs in userspace using sysfs and
50 /sbin/hotplug. It requires a 2.6 kernel to run properly.
51
52 %prep
53 %setup -q
54
55 %build
56 make CC="gcc $RPM_OPT_FLAGS"    \
57 %if %{klibc}
58         USE_KLIBC=true          \
59 %endif
60 %if %{log}
61         USE_LOG=true            \
62 %else
63         USE_LOG=false           \
64 %endif
65 %if %{dbus}
66         USE_DBUS=true           \
67 %else
68         USE_DBUS=false          \
69 %endif
70 %if %{debug}
71         DEBUG=true              \
72 %else
73         DEBUG=false             \
74 %endif
75         EXTRAS="        \
76 %if %{scsi_id}
77         extras/scsi_id  \
78 %endif
79 "
80
81 %install
82 make DESTDIR=$RPM_BUILD_ROOT install \
83 %if %{dbus}
84         USE_DBUS=true           \
85 %else
86         USE_DBUS=false          \
87 %endif
88 %if %{lsb}
89         USE_LSB=true            \
90 %else
91         USE_LSB=false           \
92 %endif
93         EXTRAS="        \
94 %if %{scsi_id}
95         extras/scsi_id  \
96 %endif
97 "
98
99 %post
100 /sbin/chkconfig --add udev
101
102 %postun
103 if [ $1 = 0 ]; then
104         /sbin/chkconfig --del udev
105 fi
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %files
111 %defattr(-,root,root)
112 %doc COPYING README TODO ChangeLog HOWTO* etc/udev/udev.rules.examples docs/*
113 %attr(755,root,root) /sbin/udev
114 %attr(755,root,root) /sbin/udevinfo
115 %attr(755,root,root) /sbin/udevsend
116 %attr(755,root,root) /sbin/udevd
117 %attr(755,root,root) /sbin/udevtest
118 %attr(755,root,root) %dir /udev/
119 %attr(755,root,root) %dir /etc/udev/
120 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
121 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
122 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
123 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
124 %attr(755,root,root) /etc/init.d/udev
125 %attr(0644,root,root) %{_mandir}/man8/udev*.8*
126
127 %if %{dbus}
128         %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
129 %endif
130
131 %if %{scsi_id}
132         %attr(755,root,root) /sbin/scsi_id
133         %config(noreplace) %attr(0644,root,root) /etc/scsi_id.config
134         %attr(0644,root,root) %{_mandir}/man8/scsi_id*.8*
135 %endif
136
137 %changelog
138 * Thu Feb 19 2004 Greg Kroah-Hartman <greg@kroah.com>
139 - add some more files to the documentation directory
140 - add ability to build scsi_id and make it the default
141
142 * Mon Feb 16 2004 Greg Kroah-Hartman <greg@kroah.com>
143 - fix up udevd build, as it's no longer needed to be build seperatly
144 - add udevtest to list of files
145 - more Red Hat sync ups.
146
147 * Thu Feb 12 2004 Greg Kroah-Hartman <greg@kroah.com>
148 - add some changes from the latest Fedora udev release.
149
150 * Mon Feb 2 2004 Greg Kroah-Hartman <greg@kroah.com>
151 - add udevsend, and udevd to the files
152 - add ability to build udevd with glibc after the rest is build with klibc
153
154 * Mon Jan 26 2004 Greg Kroah-Hartman <greg@kroah.com>
155 - added udevinfo to rpm
156 - added URL to spec file
157 - added udevinfo's man page
158
159 * Mon Jan 05 2004 Rolf Eike Beer <eike-hotplug@sf-tec.de>
160 - add defines to choose the init script (Redhat or LSB)
161
162 * Tue Dec 16 2003 Robert Love <rml@ximian.com>
163 - install the initscript and run chkconfig on it
164
165 * Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
166 - changes due to config file name changes
167
168 * Fri Oct 17 2003 Robert Love <rml@tech9.net>
169 - Make work without a build root
170 - Correctly install the right files
171 - Pass the RPM_OPT_FLAGS to gcc so we can build per the build policy
172 - Put some prereqs in
173 - Install the hotplug symlink to udev
174
175 * Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
176 - Initial spec file for udev-0.2.