chiark / gitweb /
trivial text cleanups
[elogind.git] / udev.spec
1 # if we want to build against the included version of klibc or not.
2 # 0 - do not use klibc
3 # 1 - use klibc
4 # Watch out for where the linux symlink is in the klibc part of the tarball,
5 # it probably is not where you want it to be.
6 %define klibc 1
7
8 # if we want to have logging support in or not.
9 # 0 - no logging  support
10 # 1 - logging support
11 # Note, it is not recommend if you use klibc to enable logging.
12 %define log 0
13
14 # if we want to enable debugging support in udev.  If it is enabled, lots of 
15 # stuff will get sent to the debug syslog.
16 # 0 - debugging disabled
17 # 1 - debugging enabled
18 %define debug 0
19
20 # if we want to build the scsi_id "extra" package or not
21 # 0 - do not build the package
22 # 1 - build it
23 %define scsi_id 1
24
25 # if we want to build the volume_id "extra" package or not
26 # 0 - do not build the package
27 # 1 - build it
28 %define volume_id 1
29
30 Summary: A userspace device manager providing devfs functionality
31 Name: udev
32 Version: 065
33 Release: 1
34 License: GPL
35 Group: Utilities/System
36 Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
37 ExclusiveOS: Linux
38 Vendor: Greg Kroah-Hartman <greg@kroah.com>
39 URL : kernel.org/pub/linux/utils/kernel/hotplug/
40 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
41 Prereq: /bin/sh, fileutils, hotplug
42
43 %description
44 udev is a userspace device manager, using sysfs and uevents
45 to provide a devfs-like device directory management and uevent
46 dispatching.
47
48 %prep
49 %setup -q
50
51 %build
52 make CC="gcc $RPM_OPT_FLAGS"    \
53 %if %{klibc}
54         USE_KLIBC=true          \
55 %endif
56 %if %{log}
57         USE_LOG=true            \
58 %else
59         USE_LOG=false           \
60 %endif
61 %if %{debug}
62         DEBUG=true              \
63 %else
64         DEBUG=false             \
65 %endif
66         EXTRAS="        \
67 %if %{scsi_id}
68         extras/scsi_id  \
69 %endif
70 %if %{volume_id}
71         extras/volume_id        \
72 %endif
73 "
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 make DESTDIR=$RPM_BUILD_ROOT install \
78         EXTRAS="        \
79 %if %{scsi_id}
80         extras/scsi_id  \
81 %endif
82 %if %{volume_id}
83         extras/volume_id        \
84 %endif
85 "
86
87 %post
88 /sbin/chkconfig --add udev
89
90 %postun
91 if [ $1 = 0 ]; then
92         /sbin/chkconfig --del udev
93 fi
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %files
99 %defattr(-,root,root)
100 %doc COPYING README TODO ChangeLog HOWTO* docs/*
101 %doc etc/udev/udev.rules.{examples,gentoo,redhat}
102 %attr(755,root,root) /sbin/udev
103 %attr(755,root,root) /usr/bin/udevinfo
104 %attr(755,root,root) /sbin/udevsend
105 %attr(755,root,root) /sbin/udevd
106 %attr(755,root,root) /usr/bin/udevtest
107 %attr(755,root,root) /sbin/udevstart
108 %attr(755,root,root) %dir /udev/
109 %attr(755,root,root) %dir /etc/udev/
110 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
111 %attr(755,root,root) %dir /etc/udev/rules.d/
112 %config(noreplace) %attr(0644,root,root) /etc/udev/rules.d/50-udev.rules
113 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
114 %attr(755,root,root) /etc/init.d/udev
115 %attr(0644,root,root) %{_mandir}/man8/udev*.8*
116
117 %if %{scsi_id}
118         %attr(755,root,root) /sbin/scsi_id
119         %config(noreplace) %attr(0644,root,root) /etc/scsi_id.config
120         %attr(0644,root,root) %{_mandir}/man8/scsi_id*.8*
121 %endif
122 %if %{volume_id}
123         %attr(755,root,root) /sbin/udev_volume_id
124 %endif
125
126 %changelog
127 * Fri May 14 2004 Greg Kroah-Hartman <greg@kroah.com>
128 - remove dbus and selinux stuff from here
129 - added volume_id option
130
131 * Wed Mar 24 2004 Greg Kroah-Hartman <greg@kroah.com>
132 - change the way dbus and selinux support is built (now an extra)
133
134 * Tue Mar 2 2004 Greg Kroah-Hartman <greg@kroah.com>
135 - added udevstart to the list of files installed
136 - udevinfo is now in /usr/bin not /sbin
137
138 * Fri Feb 27 2004 Greg Kroah-Hartman <greg@kroah.com>
139 - added ability to build with SELinux support
140
141 * Thu Feb 19 2004 Greg Kroah-Hartman <greg@kroah.com>
142 - add some more files to the documentation directory
143 - add ability to build scsi_id and make it the default
144
145 * Mon Feb 16 2004 Greg Kroah-Hartman <greg@kroah.com>
146 - fix up udevd build, as it's no longer needed to be build seperatly
147 - add udevtest to list of files
148 - more Red Hat sync ups.
149
150 * Thu Feb 12 2004 Greg Kroah-Hartman <greg@kroah.com>
151 - add some changes from the latest Fedora udev release.
152
153 * Mon Feb 2 2004 Greg Kroah-Hartman <greg@kroah.com>
154 - add udevsend, and udevd to the files
155 - add ability to build udevd with glibc after the rest is build with klibc
156
157 * Mon Jan 26 2004 Greg Kroah-Hartman <greg@kroah.com>
158 - added udevinfo to rpm
159 - added URL to spec file
160 - added udevinfo's man page
161
162 * Mon Jan 05 2004 Rolf Eike Beer <eike-hotplug@sf-tec.de>
163 - add defines to choose the init script (Redhat or LSB)
164
165 * Tue Dec 16 2003 Robert Love <rml@ximian.com>
166 - install the initscript and run chkconfig on it
167
168 * Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
169 - changes due to config file name changes
170
171 * Fri Oct 17 2003 Robert Love <rml@tech9.net>
172 - Make work without a build root
173 - Correctly install the right files
174 - Pass the RPM_OPT_FLAGS to gcc so we can build per the build policy
175 - Put some prereqs in
176 - Install the hotplug symlink to udev
177
178 * Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
179 - Initial spec file for udev-0.2.