chiark / gitweb /
[PATCH] extras multipath update
[elogind.git] / udev.spec
1 Summary: A userspace implementation of devfs
2 Name: udev
3 Version: 009_bk
4 Release: 1
5 License: GPL
6 Group: Utilities/System
7 Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
8 ExclusiveOS: Linux
9 Vendor: Greg Kroah-Hartman <greg@kroah.com>
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
11 Prereq: /bin/sh, fileutils, hotplug
12
13 %description
14 udev is a implementation of devfs in userspace using sysfs and
15 /sbin/hotplug. It requires a 2.6 kernel to run properly.
16
17 %prep
18 %setup -q
19
20 %build
21 make CC="gcc $RPM_OPT_FLAGS"
22
23 %install
24 make DESTDIR=$RPM_BUILD_ROOT install
25
26 %post
27 /sbin/chkconfig --add udev
28
29 %postun
30 if [ $1 = 0 ]; then
31         /sbin/chkconfig --del udev
32 fi
33
34 %clean
35 rm -rf $RPM_BUILD_ROOT
36
37 %files
38 %defattr(0644,root,root)
39 %doc COPYING README TODO ChangeLog
40 %attr(755,root,root) /sbin/udev
41 %attr(755,root,root) /udev/
42 %attr(755,root,root) /etc/udev/
43 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
44 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
45 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
46 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
47 %attr(755,root,root) /etc/init.d/udev
48 %attr(0644,root,root) %{_mandir}/man8/udev.8*
49
50 %changelog
51 * Tue Dec 16 2003 Robert Love <rml@ximian.com>
52 - install the initscript and run chkconfig on it
53
54 * Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
55 - changes due to config file name changes
56
57 * Fri Oct 17 2003 Robert Love <rml@tech9.net>
58 - Make work without a build root
59 - Correctly install the right files
60 - Pass the RPM_OPT_FLAGS to gcc so we can build per the build policy
61 - Put some prereqs in
62 - Install the hotplug symlink to udev
63
64 * Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
65 - Initial spec file for udev-0.2.
66