chiark / gitweb /
0b142f0942a93cba6a0549194a12b7f1bef145ab
[elogind.git] / udev.spec
1 # if we want to build against the included version of klibc or not.
2 # 0 - do not use klibc
3 # 1 - use klibc
4 # Watch out for where the linux symlink is in the klibc part of the tarball,
5 # it probably is not where you want it to be.
6 %define klibc 1
7
8 # if we want to have logging support in or not.
9 # 0 - no logging  support
10 # 1 - logging support
11 # Note, it is not recommend if you use klibc to enable logging.
12 %define log 0
13
14 # if we want to build DBUS support in or not.
15 # 0 - no DBUS support
16 # 1 - DBUS support
17 %define dbus 0
18
19 # if we want to enable debugging support in udev.  If it is enabled, lots of 
20 # stuff will get sent to the debug syslog.
21 # 0 - debugging disabled
22 # 1 - debugging enabled
23 %define debug 0
24
25 # if we want to use the LSB version of the init script or the Redhat one
26 # 0 - use Redhat version: etc/init.d/udev
27 # 1 - use LSB version: etc/init.d/udev.init.LSB
28 %define lsb 0
29
30 Summary: A userspace implementation of devfs
31 Name: udev
32 Version: 016_bk
33 Release: 1
34 License: GPL
35 Group: Utilities/System
36 Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
37 ExclusiveOS: Linux
38 Vendor: Greg Kroah-Hartman <greg@kroah.com>
39 URL : kernel.org/pub/linux/utils/kernel/hotplug/
40 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
41 Prereq: /bin/sh, fileutils, hotplug
42
43 %description
44 udev is a implementation of devfs in userspace using sysfs and
45 /sbin/hotplug. It requires a 2.6 kernel to run properly.
46
47 %prep
48 %setup -q
49
50 %build
51 make CC="gcc $RPM_OPT_FLAGS"    \
52 %if %{klibc}
53         USE_KLIBC=true          \
54 %endif
55 %if %{log}
56         USE_LOG=true            \
57 %else
58         USE_LOG=false           \
59 %endif
60 %if %{dbus}
61         USE_DBUS=true           \
62 %else
63         USE_DBUS=false          \
64 %endif
65 %if %{debug}
66         DEBUG=true              \
67 %else
68         DEBUG=false             \
69 %endif
70
71 # now build udevd on it's own, as it can't handle being built with klibc
72 make CC="gcc $RPM_OPT_FLAGS" udevd
73
74
75 %install
76 make DESTDIR=$RPM_BUILD_ROOT install \
77 %if %{dbus}
78         USE_DBUS=true
79 %endif
80 %if %{lsb}
81         USE_LSB=true
82 %endif
83 %post
84 /sbin/chkconfig --add udev
85
86 %postun
87 if [ $1 = 0 ]; then
88         /sbin/chkconfig --del udev
89 fi
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(-,root,root)
96 %doc COPYING README TODO ChangeLog
97 %attr(755,root,root) /sbin/udev
98 %attr(755,root,root) /sbin/udevinfo
99 %attr(755,root,root) /sbin/udevsend
100 %attr(755,root,root) /sbin/udevd
101 %attr(755,root,root) /udev/
102 %attr(755,root,root) /etc/udev/
103 %attr(755,root,root) %dir
104 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
105 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
106 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
107 %if %{dbus}
108         %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
109 %endif
110 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
111 %attr(755,root,root) /etc/init.d/udev
112 %attr(0644,root,root) %{_mandir}/man8/udev*.8*
113
114 %changelog
115 * Thu Feb 12 2004 Greg Kroah-Hartman <greg@kroah.com>
116 - add some changes from the latest Fedora udev release.
117
118 * Mon Feb 2 2004 Greg Kroah-Hartman <greg@kroah.com>
119 - add udevsend, and udevd to the files
120 - add ability to build udevd with glibc after the rest is build with klibc
121
122 * Mon Jan 26 2004 Greg Kroah-Hartman <greg@kroah.com>
123 - added udevinfo to rpm
124 - added URL to spec file
125 - added udevinfo's man page
126
127 * Mon Jan 05 2004 Rolf Eike Beer <eike-hotplug@sf-tec.de>
128 - add defines to choose the init script (Redhat or LSB)
129
130 * Tue Dec 16 2003 Robert Love <rml@ximian.com>
131 - install the initscript and run chkconfig on it
132
133 * Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
134 - changes due to config file name changes
135
136 * Fri Oct 17 2003 Robert Love <rml@tech9.net>
137 - Make work without a build root
138 - Correctly install the right files
139 - Pass the RPM_OPT_FLAGS to gcc so we can build per the build policy
140 - Put some prereqs in
141 - Install the hotplug symlink to udev
142
143 * Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
144 - Initial spec file for udev-0.2.