chiark / gitweb /
udev man page: add operators
[elogind.git] / udev.spec
1 # if we want to build against the included version of klibc or not.
2 # 0 - do not use klibc
3 # 1 - use klibc
4 # Watch out for where the linux symlink is in the klibc part of the tarball,
5 # it probably is not where you want it to be.
6 %define klibc 1
7
8 # if we want to have logging support in or not.
9 # 0 - no logging  support
10 # 1 - logging support
11 # Note, it is not recommend if you use klibc to enable logging.
12 %define log 0
13
14 # if we want to enable debugging support in udev.  If it is enabled, lots of 
15 # stuff will get sent to the debug syslog.
16 # 0 - debugging disabled
17 # 1 - debugging enabled
18 %define debug 0
19
20 # if we want to build the scsi_id "extra" package or not
21 # 0 - do not build the package
22 # 1 - build it
23 %define scsi_id 1
24
25 # if we want to build the volume_id "extra" package or not
26 # 0 - do not build the package
27 # 1 - build it
28 %define volume_id 1
29
30 Summary: A userspace implementation of devfs
31 Name: udev
32 Version: 058
33 Release: 1
34 License: GPL
35 Group: Utilities/System
36 Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
37 ExclusiveOS: Linux
38 Vendor: Greg Kroah-Hartman <greg@kroah.com>
39 URL : kernel.org/pub/linux/utils/kernel/hotplug/
40 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
41 Prereq: /bin/sh, fileutils, hotplug
42
43 %description
44 udev is a implementation of devfs in userspace using sysfs and
45 /sbin/hotplug. It requires a 2.6 kernel to run properly.
46
47 %prep
48 %setup -q
49
50 %build
51 make CC="gcc $RPM_OPT_FLAGS"    \
52 %if %{klibc}
53         USE_KLIBC=true          \
54 %endif
55 %if %{log}
56         USE_LOG=true            \
57 %else
58         USE_LOG=false           \
59 %endif
60 %if %{debug}
61         DEBUG=true              \
62 %else
63         DEBUG=false             \
64 %endif
65         EXTRAS="        \
66 %if %{scsi_id}
67         extras/scsi_id  \
68 %endif
69 %if %{volume_id}
70         extras/volume_id        \
71 %endif
72 "
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 make DESTDIR=$RPM_BUILD_ROOT install \
77         EXTRAS="        \
78 %if %{scsi_id}
79         extras/scsi_id  \
80 %endif
81 %if %{volume_id}
82         extras/volume_id        \
83 %endif
84 "
85
86 %post
87 /sbin/chkconfig --add udev
88
89 %postun
90 if [ $1 = 0 ]; then
91         /sbin/chkconfig --del udev
92 fi
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files
98 %defattr(-,root,root)
99 %doc COPYING README TODO ChangeLog HOWTO* docs/*
100 %doc etc/udev/udev.rules.{examples,gentoo,redhat}
101 %attr(755,root,root) /sbin/udev
102 %attr(755,root,root) /usr/bin/udevinfo
103 %attr(755,root,root) /sbin/udevsend
104 %attr(755,root,root) /sbin/udevd
105 %attr(755,root,root) /usr/bin/udevtest
106 %attr(755,root,root) /sbin/udevstart
107 %attr(755,root,root) %dir /udev/
108 %attr(755,root,root) %dir /etc/udev/
109 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
110 %attr(755,root,root) %dir /etc/udev/rules.d/
111 %config(noreplace) %attr(0644,root,root) /etc/udev/rules.d/50-udev.rules
112 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
113 %attr(755,root,root) /etc/init.d/udev
114 %attr(0644,root,root) %{_mandir}/man8/udev*.8*
115
116 %if %{scsi_id}
117         %attr(755,root,root) /sbin/scsi_id
118         %config(noreplace) %attr(0644,root,root) /etc/scsi_id.config
119         %attr(0644,root,root) %{_mandir}/man8/scsi_id*.8*
120 %endif
121 %if %{volume_id}
122         %attr(755,root,root) /sbin/udev_volume_id
123 %endif
124
125 %changelog
126 * Fri May 14 2004 Greg Kroah-Hartman <greg@kroah.com>
127 - remove dbus and selinux stuff from here
128 - added volume_id option
129
130 * Wed Mar 24 2004 Greg Kroah-Hartman <greg@kroah.com>
131 - change the way dbus and selinux support is built (now an extra)
132
133 * Tue Mar 2 2004 Greg Kroah-Hartman <greg@kroah.com>
134 - added udevstart to the list of files installed
135 - udevinfo is now in /usr/bin not /sbin
136
137 * Fri Feb 27 2004 Greg Kroah-Hartman <greg@kroah.com>
138 - added ability to build with SELinux support
139
140 * Thu Feb 19 2004 Greg Kroah-Hartman <greg@kroah.com>
141 - add some more files to the documentation directory
142 - add ability to build scsi_id and make it the default
143
144 * Mon Feb 16 2004 Greg Kroah-Hartman <greg@kroah.com>
145 - fix up udevd build, as it's no longer needed to be build seperatly
146 - add udevtest to list of files
147 - more Red Hat sync ups.
148
149 * Thu Feb 12 2004 Greg Kroah-Hartman <greg@kroah.com>
150 - add some changes from the latest Fedora udev release.
151
152 * Mon Feb 2 2004 Greg Kroah-Hartman <greg@kroah.com>
153 - add udevsend, and udevd to the files
154 - add ability to build udevd with glibc after the rest is build with klibc
155
156 * Mon Jan 26 2004 Greg Kroah-Hartman <greg@kroah.com>
157 - added udevinfo to rpm
158 - added URL to spec file
159 - added udevinfo's man page
160
161 * Mon Jan 05 2004 Rolf Eike Beer <eike-hotplug@sf-tec.de>
162 - add defines to choose the init script (Redhat or LSB)
163
164 * Tue Dec 16 2003 Robert Love <rml@ximian.com>
165 - install the initscript and run chkconfig on it
166
167 * Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
168 - changes due to config file name changes
169
170 * Fri Oct 17 2003 Robert Love <rml@tech9.net>
171 - Make work without a build root
172 - Correctly install the right files
173 - Pass the RPM_OPT_FLAGS to gcc so we can build per the build policy
174 - Put some prereqs in
175 - Install the hotplug symlink to udev
176
177 * Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
178 - Initial spec file for udev-0.2.