chiark / gitweb /
add bc to -recommended
[dsa-metapackages.git] / debian / control
1 Source: debian.org
2 Section: local/admin
3 Priority: required
4 Maintainer: Debian sysadmin Team <debian-admin@debian.org>
5 Uploaders: Peter Palfrader <weasel@debian.org>, Martin Zobel-Helas <zobel@debian.org>, Stephen Gran <sgran@debian.org>
6 Build-Depends: debhelper (>= 7)
7 Standards-Version: 3.8.1
8
9 Package: debian.org
10 Architecture: all
11 Depends: userdir-ldap, zsh, tcsh, pdksh, ksh, csh, ntp, locales-all, exim4-daemon-heavy | postfix, sudo, libpam-pwdfile, vim, munin-node, gnupg, bzip2, cacert-spi | ca-certificates (>> 20080411), ed, cron, dialog, libterm-readline-gnu-perl, logrotate, syslog-ng (>= 3.1), nagios-plugins-standard (>= 1.4.15) | nagios-plugins-basic
12 Recommends: debian.org-recommended
13 Conflicts: dchroot-dsa (<= 2:1)
14 Description: DSA's host metapackage
15  This package depends on packages that should be installed on every
16  debian.org host, and conflicts with packages that should never be
17  installed.
18
19 Package: debian.org-recommended-linux
20 Architecture: all
21 Depends: vlan, ifenslave, bridge-utils, iproute,
22         strace,
23         lsscsi
24 Description: metapackage to pull in recommended, but not essential tools for linux system
25  This package depends on packages that are recommended to  be installed on
26  every Linux debian.org host but are not essential.
27
28 Package: debian.org-recommended
29 Architecture: all
30 Depends: debian.org,
31         busybox-static,
32         debian.org-recommended-linux | not+gnu-linux,
33         molly-guard
34         ,
35         man-db
36         ,
37         subversion, rcs, git-core, bzr,
38                 git-svn,
39                 subversion-tools,
40                 mercurial,
41                 cvs
42         ,
43         mtr-tiny, tcpdump, tcptraceroute, ndisc6,
44         traceroute | not+gnu-linux,
45         iputils-tracepath | not+gnu-linux,
46         bind9-host, dnsutils, whois, unbound-host
47         ,
48         emacs23-nox | emacs23 | emacs22-nox | emacs22 | emacs21-nox | emacs21
49         ,
50         at, uptimed,
51         puppet,
52                 libaugeas-ruby,
53                 libaugeas-ruby1.8,
54                 libaugeas0,
55                 augeas-lenses (>= 0.7),
56         locate, dlocate
57         ,
58         dsa-nagios-checks
59         ,
60         lshw | not+gnu-linux,
61         dmidecode | not+amd64,
62         dmidecode | not+i386,
63         dmidecode | not+ia64
64         ,
65         ipython
66         ,
67         mcelog | not+amd64 | not+gnu-linux,
68         mcelog | not+i386 | not+gnu-linux,
69         ,
70         htop, psmisc,
71         lsof | not+gnu-linux,
72         ,
73         ncdu,
74         mc,
75                 genisoimage,
76         less,
77         rsync,
78         screen,
79         tmux,
80         ldap-utils, ldapvi,
81         mmv,
82         moreutils,
83         patchutils,
84         diffstat,
85         bc,
86         netcat-openbsd, socat, telnet
87         ,
88         deborphan
89         ,
90         file
91         ,
92         buffer
93         ,
94         bsd-mailx
95         ,
96         timeout | coreutils (>= 8.0-1)
97         ,
98         wget, curl, lftp, ftp,
99         ,
100         dput
101         ,
102         uuid-runtime
103         ,
104         finger
105         ,
106         unzip
107         ,
108         w3m,
109         elinks,
110         mutt
111 Description: metapackage to pull in recommended, but not essential tools
112  This package depends on packages that are recommended to  be installed on
113  every debian.org host but are not essential.
114
115 Package: debian.org-bugs.debian.org
116 Architecture: all
117 Depends: graphviz,
118         libcgi-simple-perl,
119         libio-stringy-perl,
120         liblist-moreutils-perl,
121         libmime-tools-perl,
122         libmldbm-perl,
123         libparams-validate-perl,
124         libsafe-hole-perl,
125         libtext-template-perl,
126         liburi-perl,
127         libhtml-tree-perl,
128         libsoap-lite-perl,
129         libdbd-pg-perl,
130         python-pyinotify,
131         python-yaml
132 Description: metapackages for bugs.debian.org dependencies
133  This package depends on everything that is needed for a bugs.debian.org
134  mirror or (in the future) bugs-master.
135
136 Package: debian.org-bugs.debian.org-mx
137 Architecture: all
138 Depends: debian.org-bugs.debian.org,
139         spamassassin,
140         build-essential,
141         spamc,
142         libmail-spf-perl,
143         re2c,
144         libsys-syslog-perl,
145         libio-socket-inet6-perl,
146         libnet-ident-perl,
147         libdbi-perl,
148         pyzor,
149         libmail-dkim-perl,
150         libdbd-pg-perl
151 Description: metapackages for bugs.debian.org mail exchanger
152  This package depends on everything that is needed for a bugs.debian.org
153  MX.
154
155
156 Package: debian.org-packages.debian.org
157 Architecture: all
158 Depends: db4.6-util,
159         liblocale-maketext-lexicon-perl,
160         libi18n-acceptlanguage-perl,
161         libnumber-format-perl,
162         libcompress-zlib-perl,
163         libhtml-parser-perl,
164         libmldbm-perl,
165         libtext-iconv-perl,
166         libclass-accessor-perl,
167         liburi-perl,
168         libtemplate-perl,
169         liblingua-stem-perl,
170         libsearch-xapian-perl,
171         libtimedate-perl,
172         libapache2-mod-perl2,
173         libapache2-reload-perl
174 Description: metapackages for packages.debian.org dependencies
175  This package depends on everything that is needed for a packages.debian.org
176  mirror or (in the future) packages-master.
177
178 Package: debian.org-www-master.debian.org
179 Architecture: all
180 Depends: debiandoc-sgml,
181         asciidoc,
182         cm-super,
183         debhelper,
184         docbook,
185         docbook-dsssl,
186         docbook-xsl,
187         dpkg-dev,
188         gettext,
189         ghostscript,
190         imagemagick,
191         iso-codes,
192         isoquery,
193         jadetex,
194         kcc,
195         ko.tex-base,
196         latex-cjk-all,
197         latex-cjk-chinese,
198         ldap-utils,
199         libemail-address-perl,
200         libintl-perl,
201         libmime-lite-perl,
202         libnet-ldap-perl,
203         libsoap-lite-perl,
204         libtimedate-perl,
205         libwww-perl,
206         libxml2-utils,
207         libxml-rss-perl,
208         locales, locales-all,
209         lmodern,
210         maildrop,
211         openjade,
212         openjade1.3,
213         po4a,
214         poxml,
215         procmail,
216         texlive-fonts-recommended,
217         texlive-lang-all,
218         latex-cjk-japanese,
219         texlive-latex-base,
220         texlive-latex-extra,
221         texlive-latex-recommended,
222         tidy,
223         time,
224         ttf-arphic-uming,
225         ttf-malayalam-fonts,
226         uni2ascii,
227         wml,
228         xmlroff, dblatex,
229         xplanet,
230         xplanet-images,
231         xsltproc,
232         libjson-perl
233 Description: metapackages for www-master.debian.org dependencies
234  This package depends on everything that is needed for a www-master.debian.org.
235
236
237 Package: debian.org-buildd.debian.org
238 Architecture: all
239 Depends: edos-distcheck,
240         ghostscript,
241         libcompress-bzip2-perl,
242         libcompress-zlib-perl,
243         libhash-merge-perl,
244         libmailtools-perl,
245         libdbi-perl,
246         libdbd-pg-perl,
247         libfile-spec-perl,
248         libstring-escape-perl,
249         libstring-format-perl,
250         libyaml-tiny-perl,
251         python-apt,
252         python-contract,
253         python-coverage,
254         python-debian,
255         python-psycopg2,
256         python-mako,
257         python-nose,
258         python-sqlalchemy,
259         r-base-core,
260         r-cran-lattice,
261         php5,
262         moreutils (>= 0.39~),
263         libdpkg-perl
264 Description: metapackages for buildd.debian.org dependencies
265  This package depends on everything that is needed for a buildd.debian.org.
266
267
268 Package: debian.org-patch-tracker.debian.org
269 Architecture: all
270 Depends: patchutils,
271         python,
272         python-cheetah,
273         python-pygments,
274         python-debian,
275         reprepro,
276         python-wsgiref,
277         python-simplejson,
278         python-pysqlite2,
279         diffstat
280 Description: metapackages for patch-tracker.debian.org dependencies
281  This package depends on everything that is needed for a patch-tracker.debian.org.
282
283 Package: debian.org-planet.debian.org
284 Architecture: all
285 Depends: libwww-perl,
286         timeout | coreutils (>= 8.0-1),
287         debianutils,
288         python-django,
289         python,
290         libdbi-perl, libdate-manip-perl, libdbd-sqlite3-perl
291 Description: metapackages for planet.debian.org dependencies
292  This package depends on everything that is needed for a planet.debian.org.
293
294 Package: debian.org-testing-security.debian.org
295 Architecture: all
296 Depends: libdbd-sqlite3-perl,
297         sqlite3,
298         python-apsw,
299         libterm-readline-gnu-perl,
300         python-apt
301 Description: metapackages for testing-security.debian.org dependencies
302  This package depends on everything that is needed for a testing-security.debian.org.
303
304 Package: debian.org-ftpmaster.debian.org
305 Architecture: all
306 Depends: apt-utils,
307         libapt-pkg-dev,
308         libemail-send-perl,
309         python-apt,
310         python-debianbts (>= 1.4~bpo50+1),
311         lintian,
312         python,
313         python-debian,
314         python-gnupginterface,
315         python-ldap,
316         python-psycopg2,
317         python-pygresql,
318         python-pyrss2gen,
319         python-yaml,
320         python-rrdtool,
321         python-sqlalchemy,
322         binutils-multiarch,
323         build-essential,
324         devscripts,
325         graphviz,
326         ikiwiki,
327         libdbd-pg-ruby,
328         python-epydoc,
329         python-numpy,
330         python-soappy,
331         r-base,
332         symlinks,
333         python-magic,
334         unp,
335         procmail,
336         cvs,
337         ruby,
338         lynx,
339         libxml-rss-perl,
340         ghostscript,
341         perforate,
342         wdiff,
343         xz-utils (>= 4.999.9beta+20100713-1~bpo50+1)
344 Description: metapackage for ftpmaster
345  This package depends on everything that is needed for an ftpmaster setup.
346
347 Package: debian.org-ftpmaster.debian.org-poneys
348 Architecture: all
349 Depends: bicyclerepair,
350         dpkg-dev-el,
351         easypg,
352         emacs-goodies-el,
353         pychecker,
354         pylint,
355         python-mode,
356         ruby-elisp,
357         gitstats,
358         colordiff
359 Description: metapackage for ftpmaster extras
360  Things not really needed needed.
361
362 Package: debian.org-release.debian.org
363 Architecture: all
364 Depends: edos-debcheck,
365         mutt,
366         subversion,
367         python2.6,
368         python2.6-dev,
369         python-dev,
370         devscripts,
371         wdiff,
372         python-pygresql,
373         python-libxslt1,
374         python-apt,
375         python-debian,
376         libapt-pkg-perl,
377         libapt-pkg-dev,
378         dpkg-dev,
379         procmail,
380         rrdtool,
381         python3.1,
382         python3.1-dev,
383         python3-apt,
384         picosat,
385         openjdk-6-jre-headless
386 Description: metapackage for release
387  This package depends on everything that is needed for a release.debian.org
388  setup.
389
390 Package: debian.org-cdbuilder.debian.org
391 Architecture: all
392 Depends: bittornado,
393         build-essential,
394         debhelper,
395         debian-cd,
396         jigit,
397         m4,
398         tofrodos,
399         zip,
400         zsync,
401         fakeroot,
402         dosfstools,
403         libsoap-lite-perl,
404         devscripts
405 Description: metapackage for cdbuilder
406  This package depends on all the packages that are needed for a cdbuilder setup.
407
408 Package: debian.org-cdimage-search.debian.org
409 Architecture: all
410 Depends: libconfigreader-simple-perl
411 Description: metapackage for cdimage-search.debian.org
412  This package depends on all the packages that are needed for the CD/DVD search CGI website
413
414 Package: debian.org-manpages.debian.org
415 Architecture: all
416 Depends: locales-all,
417         gs-common
418 Description: metapackage for manpages
419  This package depends on all the packages that are needed for manpages.d.o setup.
420
421 Package: debian.org-nm.debian.org
422 Architecture: all
423 Depends: libapache2-mod-php5, libapache2-mod-wsgi,
424         php5-cli,
425         php5-ldap, php5-pgsql,
426         wml,
427         mutt, mboxgrep,
428         python,
429         python-mako (>= 0.2.5), python-gnupginterface, python-ldap,
430         python-apt, python-beautifulsoup, python-debianbts, python-dns,
431         python-dnspython, python-egenix-mxdatetime, python-egenix-mxtools,
432         python-elementtree | python (>= 2.6), python-flup, python-libxml2,
433         python-lxml, python-psycopg2, python-soappy, python-virtualenv,
434         python-sqlalchemy (>= 0.6), python (>= 2.5.4-5~) | python-simplejson,
435         python-flask (>= 0.6), python-flaskext.wtf, python-wtforms,
436         python-xapian,
437         python-dateutil,
438         perl,
439         libdbi-perl, libdbd-pg-perl, libdbd-sqlite3-perl,
440         procmail,
441         moreutils
442 Description: metapackage for nm.debian.org
443  This package depends on all the packages that are needed for nm.debian.org setup.
444
445 Package: debian.org-backports.debian.org
446 Architecture: all
447 Depends: debian.org-ftpmaster.debian.org,
448         libdbi-perl, libdbd-pg-perl
449 Description: metapackage for backports.debian.org
450  This package depends on all the packages that are needed for backports.debian.org setup.
451
452 Package: debian.org-qa.debian.org
453 Architecture: all
454 Depends: db4.8-util,
455         gnuplot-nox,
456         wml,
457         libapt-pkg-perl,
458                 libdbd-pg-perl,
459                 libdate-manip-perl,
460                 libdpkg-perl,
461                 libmailtools-perl,
462                 libsoap-lite-perl,
463                 libtemplate-perl,
464                 libxml-simple-perl,
465                 libmail-sendmail-perl,
466                 libdate-calc-perl,
467                 libnet-ldap-perl,
468         php5, php5-cgi, php5-cli,
469                 php5-ldap, php5-pgsql,
470                 libapache2-mod-fcgid,
471         python-apt, python-psycopg2,
472         libdbd-pg-ruby,
473         rrdtool
474 Description: metapackage for qa.debian.org
475  This package depends on all the packages that are needed for qa.debian.org setup.
476
477 Package: debian.org-packages.qa.debian.org
478 Architecture: all
479 Depends: db4.7-util,
480         libmailtools-perl,
481         libmime-tools-perl,
482         libmail-verp-perl,
483         xsltproc,
484         mhonarc,
485         python,
486         python-lxml,
487         python-soappy,
488         python-debian,
489         python-yaml,
490         python-zsi
491 Description: metapackage for packages.qa.debian.org
492  This package depends on all the packages that are needed for packages.qa.debian.org setup.
493
494 Package: debian.org-udd.debian.org
495 Architecture: all
496 Depends: dpkg-dev,
497         graphviz,
498         libapt-pkg-dev,
499         libcgi-simple-perl,
500         libdbd-pg-ruby,
501         libdbi-ruby,
502         libjson-ruby,
503         liblist-moreutils-perl,
504         libmime-tools-perl,
505         libparams-validate-perl,
506         libperl-dev,
507         libmldbm-perl,
508         libsafe-hole-perl,
509         libtext-template-perl,
510         libyaml-syck-perl,
511         python-debian,
512         python-dev,
513         python-launchpadlib,
514         python-psycopg2,
515         python-yaml
516 Description: metapackage for udd.debian.org
517  This package depends on all the packages that are needed for udd.debian.org setup.
518
519 Package: debian.org-snapshot.debian.org
520 Architecture: all
521 Depends: ruby, libdbd-pg-ruby1.8, libbz2-ruby1.8, libbz2-ruby1.8, python-yaml, python-psycopg2, python-lockfile, fuse-utils, python-fuse, uuid-runtime,
522         python-dev, gcc,
523         python-pylons
524 Description: metapackage for snapshot.debian.org
525  This package depends on all the packages that are needed for snapshot.debian.org setup.
526
527 Package: debian.org-women.debian.org
528 Architecture: all
529 Depends: wml
530 Description: metapackages for women.debian.org dependencies
531  This package depends on everything that is needed for women.debian.org.
532
533
534 Package: debian.org-lintian.debian.org
535 Architecture: all
536 Depends:   binutils,
537         binutils-multiarch,
538         bzip2,
539         diffstat,
540         dpkg-dev,
541         debhelper,
542         fakeroot,
543         file,
544         gettext,
545         intltool-debian,
546         libapt-pkg-perl,
547         libclass-accessor-perl,
548         libdigest-sha-perl,
549         libdpkg-perl,
550         libemail-valid-perl,
551         libhtml-parser-perl,
552         libipc-run-perl,
553         libparse-debianchangelog-perl,
554         libtimedate-perl,
555         libtext-template-perl,
556         liburi-perl,
557         locales,
558         man-db,
559         perl,
560         unzip,
561         xz-utils
562         ,
563         docbook-utils,
564         docbook-xml
565 Description: metapackages for lintian.debian.org dependencies
566  This package depends on everything that is needed for lintian.debian.org.
567
568 Package: debian.org-popcon.debian.org
569 Architecture: all
570 Depends:  libchart-perl
571 Description: metapackages for popcon.debian.org dependencies
572  This package depends on everything that is needed for popcon.debian.org.
573
574 Package: debian.org-dde.debian.net
575 Architecture: all
576 Depends: python-apt,
577         python-debian,
578         python-debianbts,
579         python-feedparser,
580         python-flup,
581         python-nose,
582         python-paste,
583         python-psycopg2,
584         python-pyrss2gen,
585         python-soappy,
586         python-werkzeug,
587         python-xapian,
588         python-yaml
589 Description: metapackages for dde.debian.net dependencies
590  This package depends on everything that is needed for dde.debian.net.