chiark / gitweb /
Merge remote-tracking branch 'sledge/master'
[dsa-metapackages.git] / debian / control
1 Source: debian.org
2 Section: local/admin
3 Priority: required
4 Maintainer: Debian sysadmin Team <debian-admin@debian.org>
5 Uploaders: Peter Palfrader <weasel@debian.org>, Martin Zobel-Helas <zobel@debian.org>, Stephen Gran <sgran@debian.org>, Luca Filipozzi <lfilipoz@debian.org>
6 Build-Depends: debhelper (>= 7)
7 Standards-Version: 3.8.1
8
9 Package: debian.org
10 Architecture: all
11 Depends: userdir-ldap, zsh, tcsh, pdksh, ksh, csh, ntp, locales-all, exim4-daemon-heavy | postfix, sudo, libpam-pwdfile, vim, munin-node, gnupg, bzip2, cacert-spi | ca-certificates (>> 20080411), ed, cron, dialog, libterm-readline-gnu-perl, logrotate, syslog-ng (>= 3.1), nagios-plugins-standard (>= 1.4.15) | nagios-plugins-basic
12 Recommends: debian.org-recommended
13 Conflicts: dchroot-dsa (<= 2:1)
14 Description: DSA's host metapackage
15  This package depends on packages that should be installed on every
16  debian.org host, and conflicts with packages that should never be
17  installed.
18
19 Package: debian.org-recommended-linux
20 Architecture: all
21 Depends: vlan, ifenslave, bridge-utils, iproute,
22         strace,
23         lsscsi,
24         ethtool
25 Description: metapackage to pull in recommended, but not essential tools for linux system
26  This package depends on packages that are recommended to  be installed on
27  every Linux debian.org host but are not essential.
28
29 Package: debian.org-recommended
30 Architecture: all
31 Depends: debian.org,
32         busybox-static,
33         debian.org-recommended-linux | not+gnu-linux,
34         molly-guard
35         ,
36         man-db
37         ,
38         subversion, rcs, git-core, bzr,
39                 git-svn,
40                 subversion-tools,
41                 mercurial,
42                 cvs
43         ,
44         mtr-tiny, tcpdump, tcptraceroute, ndisc6, bwm-ng
45         traceroute | not+gnu-linux,
46         iputils-tracepath | not+gnu-linux,
47         bind9-host, dnsutils, whois, unbound-host
48         ,
49         emacs23-nox | emacs23 | emacs22-nox | emacs22 | emacs21-nox | emacs21
50         ,
51         at, uptimed,
52         puppet,
53                 libaugeas-ruby,
54                 libaugeas-ruby1.8,
55                 libaugeas0,
56                 augeas-lenses (>= 0.7),
57         locate, dlocate
58         ,
59         dsa-nagios-checks
60         ,
61         lshw | not+gnu-linux,
62         dmidecode | not+amd64,
63         dmidecode | not+i386,
64         dmidecode | not+ia64
65         ,
66         ipython
67         ,
68         mcelog | not+amd64 | not+gnu-linux,
69         mcelog | not+i386 | not+gnu-linux,
70         ,
71         htop, psmisc,
72         lsof | not+gnu-linux,
73         ,
74         ncdu,
75         mc,
76                 genisoimage,
77         less,
78         rsync,
79         screen,
80         tmux,
81         ldap-utils, ldapvi,
82         mmv,
83         moreutils,
84         patchutils,
85         diffstat,
86         bc,
87         netcat-openbsd, socat, telnet
88         ,
89         deborphan
90         ,
91         file
92         ,
93         buffer
94         ,
95         bsd-mailx
96         ,
97         timeout | coreutils (>= 8.0-1)
98         ,
99         wget, curl, lftp, ftp,
100         ,
101         dput
102         ,
103         uuid-runtime
104         ,
105         finger
106         ,
107         unzip
108         ,
109         w3m,
110         elinks,
111         mutt
112         ,
113         ccze
114 Description: metapackage to pull in recommended, but not essential tools
115  This package depends on packages that are recommended to  be installed on
116  every debian.org host but are not essential.
117
118 Package: debian.org-bugs.debian.org
119 Architecture: all
120 Depends: graphviz,
121         libcgi-simple-perl,
122         libio-stringy-perl,
123         liblist-moreutils-perl,
124         libmail-rfc822-address-perl,
125         libmime-tools-perl,
126         libmldbm-perl,
127         libparams-validate-perl,
128         libsafe-hole-perl,
129         libtext-template-perl,
130         liburi-perl,
131         libhtml-tree-perl,
132         libsoap-lite-perl,
133         libtext-iconv-perl,
134         libdbd-pg-perl,
135         python-pyinotify,
136         python-yaml
137 Description: metapackages for bugs.debian.org dependencies
138  This package depends on everything that is needed for a bugs.debian.org
139  mirror or (in the future) bugs-master.
140
141 Package: debian.org-bugs.debian.org-master
142 Architecture: all
143 Depends: debian.org-bugs.debian.org,
144         gnuplot,
145         ttf-liberation,
146         kgb-client-git,
147         lynx    
148 Description: metapackages for bugs-master.debian.org dependencies
149  This package depends on everything that is needed for a
150  bugs-master.debian.org
151
152 Package: debian.org-bugs.debian.org-search
153 Architecture: all
154 Depends: debian.org-bugs.debian.org,
155         hyperestraier,
156         libsearch-estraier-perl
157 Description: metapackages for bugs-search.debian.org dependencies
158  This package depends on everything that is needed for a
159  bugs-search.debian.org
160
161 Package: debian.org-bugs.debian.org-mx
162 Architecture: all
163 Depends: debian.org-bugs.debian.org,
164         spamassassin,
165         build-essential,
166         spamc,
167         libmail-spf-perl,
168         re2c,
169         libsys-syslog-perl,
170         libio-socket-inet6-perl,
171         libnet-ident-perl,
172         libdbi-perl,
173         pyzor,
174         libmail-dkim-perl,
175         libdbd-pg-perl
176 Description: metapackages for bugs.debian.org mail exchanger
177  This package depends on everything that is needed for a bugs.debian.org
178  MX.
179
180
181 Package: debian.org-packages.debian.org
182 Architecture: all
183 Depends: db4.6-util,
184         liblocale-maketext-lexicon-perl,
185         libi18n-acceptlanguage-perl,
186         libnumber-format-perl,
187         libcompress-zlib-perl,
188         libhtml-parser-perl,
189         libmldbm-perl,
190         libtext-iconv-perl,
191         libclass-accessor-perl,
192         liburi-perl,
193         libtemplate-perl,
194         liblingua-stem-perl,
195         libsearch-xapian-perl,
196         libtimedate-perl,
197         libapache2-mod-perl2,
198         libapache2-reload-perl
199 Description: metapackages for packages.debian.org dependencies
200  This package depends on everything that is needed for a packages.debian.org
201  mirror or (in the future) packages-master.
202
203 Package: debian.org-www-master.debian.org
204 Architecture: all
205 Depends: debiandoc-sgml,
206         asciidoc,
207         cm-super,
208         debhelper,
209         docbook,
210         docbook-dsssl,
211         docbook-xsl,
212         dpkg-dev,
213         gawk (>= 1:4.0.1),
214         gettext,
215         ghostscript,
216         imagemagick,
217         iso-codes,
218         isoquery,
219         jadetex,
220         kcc,
221         ko.tex-base,
222         latex-cjk-all,
223         latex-cjk-chinese,
224         ldap-utils,
225         libemail-address-perl,
226         libintl-perl,
227         libmime-lite-perl,
228         libnet-ldap-perl,
229         libsoap-lite-perl,
230         libtimedate-perl,
231         libwww-perl,
232         libxml2-utils,
233         libxml-rss-perl,
234         locales, locales-all,
235         lmodern,
236         maildrop,
237         opencc,
238         openjade,
239         openjade1.3,
240         po4a,
241         poxml,
242         procmail,
243         texlive-fonts-recommended,
244         texlive-lang-all,
245         latex-cjk-japanese,
246         texlive-latex-base,
247         texlive-latex-extra,
248         texlive-latex-recommended,
249         tidy,
250         time,
251         ttf-arphic-uming,
252         ttf-malayalam-fonts,
253         uni2ascii,
254         wml,
255         xmlroff, dblatex,
256         xplanet,
257         xplanet-images,
258         xsltproc,
259         libjson-perl
260 Description: metapackages for www-master.debian.org dependencies
261  This package depends on everything that is needed for a www-master.debian.org.
262
263
264 Package: debian.org-buildd.debian.org
265 Architecture: all
266 Depends: edos-distcheck,
267         ghostscript,
268         libcompress-bzip2-perl,
269         libcompress-zlib-perl,
270         libhash-merge-perl,
271         libmailtools-perl,
272         libdbi-perl,
273         libdbd-pg-perl,
274         libfile-spec-perl,
275         libstring-escape-perl,
276         libstring-format-perl,
277         libyaml-tiny-perl,
278         python-apt,
279         python-contract,
280         python-coverage,
281         python-debian,
282         python-psycopg2,
283         python-mako,
284         python-nose,
285         python-sqlalchemy,
286         r-base-core,
287         r-cran-lattice,
288         php5,
289         moreutils (>= 0.39~),
290         libdpkg-perl
291 Description: metapackages for buildd.debian.org dependencies
292  This package depends on everything that is needed for a buildd.debian.org.
293
294
295 Package: debian.org-patch-tracker.debian.org
296 Architecture: all
297 Depends: patchutils,
298         python,
299         python-cheetah,
300         python-pygments,
301         python-debian,
302         reprepro,
303         python-wsgiref,
304         python-simplejson,
305         python-pysqlite2,
306         diffstat
307 Description: metapackages for patch-tracker.debian.org dependencies
308  This package depends on everything that is needed for a patch-tracker.debian.org.
309
310 Package: debian.org-planet.debian.org
311 Architecture: all
312 Depends: libwww-perl,
313         timeout | coreutils (>= 8.0-1),
314         debianutils,
315         python-django,
316         python,
317         libdbi-perl, libdate-manip-perl, libdbd-sqlite3-perl
318 Description: metapackages for planet.debian.org dependencies
319  This package depends on everything that is needed for a planet.debian.org.
320
321 Package: debian.org-testing-security.debian.org
322 Architecture: all
323 Depends: libdbd-sqlite3-perl,
324         sqlite3,
325         python-apsw,
326         libterm-readline-gnu-perl,
327         python-apt
328 Description: metapackages for testing-security.debian.org dependencies
329  This package depends on everything that is needed for a testing-security.debian.org.
330
331 Package: debian.org-ftpmaster.debian.org
332 Architecture: all
333 Depends: apt-utils,
334         libapt-pkg-dev,
335         libemail-send-perl,
336         python-apt,
337         python-debianbts (>= 1.4~bpo50+1),
338         lintian,
339         python,
340         python-debian,
341         python-gnupginterface,
342         python-ldap,
343         python-psycopg2,
344         python-pygresql,
345         python-pyrss2gen,
346         python-yaml,
347         python-rrdtool,
348         python-sqlalchemy,
349         binutils-multiarch,
350         build-essential,
351         devscripts,
352         graphviz,
353         ikiwiki,
354         libdbd-pg-ruby,
355         python-epydoc,
356         python-numpy,
357         python-soappy,
358         r-base,
359         symlinks,
360         python-magic,
361         unp,
362         procmail,
363         cvs,
364         ruby,
365         lynx,
366         libxml-rss-perl,
367         ghostscript,
368         perforate,
369         wdiff,
370         xz-utils (>= 4.999.9beta+20100713-1~bpo50+1)
371 Description: metapackage for ftpmaster
372  This package depends on everything that is needed for an ftpmaster setup.
373
374 Package: debian.org-ftpmaster.debian.org-poneys
375 Architecture: all
376 Depends: bicyclerepair,
377         dpkg-dev-el,
378         easypg,
379         emacs-goodies-el,
380         pychecker,
381         pylint,
382         python-mode,
383         ruby-elisp,
384         gitstats,
385         colordiff
386 Description: metapackage for ftpmaster extras
387  Things not really needed needed.
388
389 Package: debian.org-release.debian.org
390 Architecture: all
391 Depends: edos-debcheck,
392         mutt,
393         subversion,
394         python2.6,
395         python2.6-dev,
396         python-dev,
397         devscripts,
398         wdiff,
399         python-pygresql,
400         python-libxslt1,
401         python-apt,
402         python-debian,
403         libapt-pkg-perl,
404         libapt-pkg-dev,
405         dpkg-dev,
406         procmail,
407         rrdtool,
408         python3.1,
409         python3.1-dev,
410         python3-apt,
411         picosat,
412         openjdk-6-jre-headless,
413         git-email,
414         python-networkx,
415         python-pygraphviz,
416 Description: metapackage for release
417  This package depends on everything that is needed for a release.debian.org
418  setup.
419
420 Package: debian.org-cdbuilder.debian.org
421 Architecture: all
422 Depends: bittornado,
423         build-essential,
424         debhelper,
425         debian-cd,
426         jigit,
427         m4,
428         tofrodos,
429         zip,
430         zsync,
431         fakeroot,
432         dosfstools,
433         libsoap-lite-perl,
434         devscripts,
435         mtools
436 Description: metapackage for cdbuilder
437  This package depends on all the packages that are needed for a cdbuilder setup.
438
439 Package: debian.org-cdimage-search.debian.org
440 Architecture: all
441 Depends: libconfigreader-simple-perl
442 Description: metapackage for cdimage-search.debian.org
443  This package depends on all the packages that are needed for the CD/DVD search CGI website
444
445 Package: debian.org-manpages.debian.org
446 Architecture: all
447 Depends: locales-all,
448         gs-common
449 Description: metapackage for manpages
450  This package depends on all the packages that are needed for manpages.d.o setup.
451
452 Package: debian.org-nm.debian.org
453 Architecture: all
454 Depends: libapache2-mod-php5, libapache2-mod-wsgi,
455         php5-cli,
456         php5-ldap, php5-pgsql,
457         wml,
458         mutt, mboxgrep,
459         python,
460         python-mako (>= 0.2.5), python-gnupginterface, python-ldap,
461         python-apt, python-beautifulsoup, python-debianbts, python-dns,
462         python-dnspython, python-egenix-mxdatetime, python-egenix-mxtools,
463         python-elementtree | python (>= 2.6), python-flup, python-libxml2,
464         python-lxml, python-psycopg2, python-soappy, python-virtualenv,
465         python-sqlalchemy (>= 0.6), python (>= 2.5.4-5~) | python-simplejson,
466         python-flask (>= 0.6),
467         python-xapian,
468         python-dateutil,
469         perl,
470         libdbi-perl, libdbd-pg-perl, libdbd-sqlite3-perl,
471         procmail,
472         moreutils,
473         python-flup
474 # These are also needed, but they are currently not available in squeeze and
475 # difficult to backport:
476 # python-flaskext.wtf, python-wtforms
477 Description: metapackage for nm.debian.org
478  This package depends on all the packages that are needed for nm.debian.org setup.
479
480 Package: debian.org-backports.debian.org
481 Architecture: all
482 Depends: debian.org-ftpmaster.debian.org,
483         libdbi-perl, libdbd-pg-perl
484 Description: metapackage for backports.debian.org
485  This package depends on all the packages that are needed for backports.debian.org setup.
486
487 Package: debian.org-qa.debian.org
488 Architecture: all
489 Depends: db4.8-util,
490         devscripts,
491         gnuplot-nox,
492         wml,
493         libapt-pkg-perl,
494                 libdbd-pg-perl,
495                 libdate-manip-perl,
496                 libdpkg-perl,
497                 libmailtools-perl,
498                 libsoap-lite-perl,
499                 libtemplate-perl,
500                 libxml-simple-perl,
501                 libmail-sendmail-perl,
502                 libdate-calc-perl,
503                 libnet-ldap-perl,
504         php5, php5-cgi, php5-cli,
505                 php5-ldap, php5-pgsql,
506                 libapache2-mod-fcgid,
507         python-apt, python-psycopg2,
508         libdbd-pg-ruby,
509         rrdtool
510 Description: metapackage for qa.debian.org
511  This package depends on all the packages that are needed for qa.debian.org setup.
512
513 Package: debian.org-packages.qa.debian.org
514 Architecture: all
515 Depends: db4.7-util,
516         libmailtools-perl,
517         libmime-tools-perl,
518         libmail-verp-perl,
519         xsltproc,
520         mhonarc,
521         python,
522         python-lxml,
523         python-soappy,
524         python-debian,
525         python-yaml,
526         python-zsi
527 Description: metapackage for packages.qa.debian.org
528  This package depends on all the packages that are needed for packages.qa.debian.org setup.
529
530 Package: debian.org-udd.debian.org
531 Architecture: all
532 Depends: curl,
533         dpkg-dev,
534         graphviz,
535         libapt-pkg-dev,
536         libcrypt-ssleay-perl,
537         libcgi-simple-perl,
538         libdbd-pg-perl,
539         libdbd-pg-ruby,
540         libdbi-perl,
541         libdbi-ruby,
542         libdpkg-ruby,
543         libio-stringy-perl,
544         libjson-ruby,
545         liblist-moreutils-perl,
546         libmime-tools-perl,
547         libmldbm-perl,
548         libparams-validate-perl,
549         libperl-dev,
550         libsafe-hole-perl,
551         libtext-template-perl,
552         libyaml-syck-perl,
553         postgresql-autodoc,
554         python-dateutil,
555         python-debian,
556         python-dev,
557         python-launchpadlib,
558         python-psycopg2,
559         python-yaml
560 Description: metapackage for udd.debian.org
561  This package depends on all the packages that are needed for udd.debian.org setup.
562
563 Package: debian.org-snapshot.debian.org
564 Architecture: all
565 Depends: ruby, libdbd-pg-ruby1.8, libbz2-ruby1.8, libbz2-ruby1.8, python-yaml, python-psycopg2, python-lockfile, fuse-utils, python-fuse, uuid-runtime,
566         python-dev, gcc,
567         python-pylons
568 Description: metapackage for snapshot.debian.org
569  This package depends on all the packages that are needed for snapshot.debian.org setup.
570
571 Package: debian.org-women.debian.org
572 Architecture: all
573 Depends: wml
574 Description: metapackages for women.debian.org dependencies
575  This package depends on everything that is needed for women.debian.org.
576
577
578 Package: debian.org-lintian.debian.org
579 Architecture: all
580 Depends:   binutils,
581         binutils-multiarch,
582         bzip2,
583         diffstat,
584         dpkg-dev,
585         debhelper,
586         devscripts,
587         fakeroot,
588         file,
589         gettext,
590         gnuplot-nox | gnuplot,
591         intltool-debian,
592         libapt-pkg-perl,
593         libarchive-zip-perl,
594         libclass-accessor-perl,
595         libclone-perl,
596         libdigest-sha-perl,
597         libdpkg-perl,
598         libemail-valid-perl,
599         libhtml-parser-perl,
600         libipc-run-perl,
601         libparse-debianchangelog-perl,
602         libtimedate-perl,
603         libtext-levenshtein-perl,
604         libtext-template-perl,
605         liburi-perl,
606         locales,
607         man-db,
608         perl,
609         t1utils,
610         unzip,
611         xz-utils
612         ,
613         docbook-utils,
614         docbook-xml
615         ,
616         hardening-includes (>= 2.0)
617 Description: metapackages for lintian.debian.org dependencies
618  This package depends on everything that is needed for lintian.debian.org.
619
620 Package: debian.org-popcon.debian.org
621 Architecture: all
622 Depends:  libchart-perl
623 Description: metapackages for popcon.debian.org dependencies
624  This package depends on everything that is needed for popcon.debian.org.
625
626 Package: debian.org-dde.debian.net
627 Architecture: all
628 Depends: python-apt,
629         python-debian,
630         python-debianbts,
631         python-feedparser,
632         python-flup,
633         python-nose,
634         python-paste,
635         python-psycopg2,
636         python-pyrss2gen,
637         python-soappy,
638         python-werkzeug,
639         python-xapian,
640         python-yaml
641 Description: metapackages for dde.debian.net dependencies
642  This package depends on everything that is needed for dde.debian.net.
643
644 Package: debian.org-debtags.debian.net
645 Architecture: all
646 Depends: python-apt,
647         python-debian,
648         python-django,
649         python-django-registration,
650         python-xapian (>= 1.2.7-1~bpo60+1),
651         python-psycopg2
652 Description: metapackages for debtags.debian.net dependencies
653  This package depends on everything that is needed for debtags.debian.net.
654
655 Package: debian.org-sso.debian.org
656 Architecture: all
657 Depends: libcatalyst-modules-perl,
658         libcatalyst-engine-apache-perl,
659         libapache2-mod-perl2,
660         libapache2-reload-perl,
661         libcatalyst-devel-perl,
662         libhtml-mason-perl
663 Description: metapackages for sso.debian.org dependencies
664  This package depends on everything that is needed for sso.debian.org.
665
666 Package: debian.org-lists.debian.org
667 Architecture: all
668 Depends: xapian-tools,
669         xapian-omega,
670         smartlist,
671         procmail,
672         gnuplot,
673         rrdtool,
674         libdpkg-perl,
675         gettext,
676         grepmail,
677         libcompress-raw-zlib-perl,
678         amavisd-new,
679         amavis-lists,
680         zoo,
681         lha,
682         p7zip,
683         unrar-free,
684         ripole,
685         pfqueue,
686         pyzor,
687         razor,
688         mrtgutils,
689         pax,
690         pwgen,
691         rbldnsd,
692         rng-tools,
693         speedy-cgi-perl,
694         ccze
695 Description: metapackages for lists.debian.org dependencies
696  This package depends on everything that is needed for lists.debian.org.
697
698 Package: debian.org-ddtp.debian.org
699 Architecture: all
700 Depends: libalgorithm-diff-xs-perl,
701         libdbd-pg-perl,
702         libdbi-perl,
703         libmail-sender-perl,
704         libmime-tools-perl,
705         libtext-diff-perl,
706         libtext-iconv-perl
707         ,
708         gnuplot
709         ,
710         libapache2-mod-wsgi,
711         python-setuptools,
712         python-psycopg2,
713         python-django,
714         python-sqlalchemy
715         ,
716         tig,
717         postgresql-client-9.1
718 Description: metapackages for ddtp.debian.org dependencies
719  This package depends on everything that is needed for ddtp.debian.org.
720
721 Package: debian.org-i18n.debian.org
722 Architecture: all
723 Depends: gettext,
724         po-debconf
725         ,
726         liblocale-gettext-perl,
727         libmailtools-perl,
728         libsoap-lite-perl,
729         libtimedate-perl
730         ,
731         tig,
732         rrdtool
733 Description: metapackages for i18n.debian.org dependencies
734  This package depends on everything that is needed for i18n.debian.org.
735
736 Package: debian.org-l10n.debian.org
737 Architecture: all
738 Depends: gettext,
739         po-debconf
740         ,
741         liblocale-gettext-perl,
742         libmailtools-perl,
743         libsoap-lite-perl,
744         libtimedate-perl
745         ,
746         tig,
747         rrdtool
748 Description: metapackages for l10n.debian.org dependencies
749  This package depends on everything that is needed for l10n.debian.org.
750
751 Package: debian.org-piuparts.debian.org
752 Architecture: all
753 Depends: asciidoc,
754         git,
755         xmlto,
756         debootstrap,
757         debsums,
758         lsb-release,
759         lsof,
760         python-debian,
761         python-debianbts,
762         apache2,
763         ghostscript,
764         python-rpy,
765         r-base-dev,
766         r-recommended,
767         tango-icon-theme,
768         screen,
769         python-apt
770 Description: metapackage for piuparts.debian.org
771  This package depends on all the packages that are needed for the
772  piuparts.debian.org setup.
773
774 Package: debian.org-wiki.debian.org
775 Architecture: all
776 Depends: libapache2-mod-wsgi,
777          libjson-perl,
778          python-moinmoin,
779          python-launchpadlib,
780          libsoap-lite-perl
781 Description: metapackage for wiki.debian.org
782  This package depends on all the packages that are needed for the Debian wiki
783