chiark / gitweb /
autopkgtests: Provide fake "ssh" program in tests/ which does nothing much.
[dgit.git] / debian / rules
index e4a246057f610592cd1409e8f76cc14901200b8a..fece672aef8cbf8f3be503c4bf72fef9b0bacc78 100755 (executable)
@@ -22,3 +22,10 @@ export prefix=/usr
 
 %:
        dh $@
+
+override_dh_gencontrol:
+       dh_gencontrol
+       set -e; \
+        cd debian/dgit; \
+        v=$$(perl -ne 'print if s/^version:\s+//i' DEBIAN/control); \
+        perl -i -pe "s/UNRELEASED/$$v/g if m/###substituted###/" usr/bin/dgit