chiark / gitweb /
d/copyright: Update copyright years
[dgit.git] / debian / rules
index 614fb7a55e0d465134b82d9dc63ad41390b23acd..8beb109f3cc3a6090a1608d066bc8a1659ae6c50 100755 (executable)
@@ -40,6 +40,10 @@ override_dh_auto_install: specpkg_install_gdr specpkg_install_infra
        make install prefix=/usr DESTDIR=debian/dgit
        make -C po install prefix=/usr DESTDIR=../debian/tmp \
                SUPPRESS_PO_UPDATE=1 S=''
+       make -C po4a install DESTDIR=../debian/tmp S=''
+
+override_dh_missing:
+       dh_missing --fail-missing
 
 specpkg_install_gdr: p=git-debrebase
 specpkg_install_gdr: pm=GDR
@@ -47,10 +51,14 @@ specpkg_install_gdr: pm=GDR
 specpkg_install_infra: p=dgit-infrastructure
 specpkg_install_infra: pm=Infra
 
+define specpkg_install_common
+       make install-$(tok) prefix=/usr DESTDIR=debian/$(p) perldir=$(specperl)
+endef
+
 specpkg_install_%: tok=$*
 specpkg_install_%: specperl=/usr/share/dgit/$(tok)/perl5
 specpkg_install_%:
-       make install-$(tok) prefix=/usr DESTDIR=debian/$(p) perldir=$(specperl)
+       $(specpkg_install_common)
 #      # Most of the Perl modules in this package live in
 #      # $(specperl).  The exception is Debian::Dgit::Infra, which
 #      # lives in $(globalperl) and adds $(specperl) to @INC.