chiark / gitweb /
git-playtree-setup: Rewrite in shell and call it from Perl
[dgit.git] / debian / rules
index 9c2afb38b2ce68ae7634f51902230cc2428db50e..4e44118d8b245efb21a643b9de798e45c980489e 100755 (executable)
@@ -43,6 +43,7 @@ override_dh_auto_install: specpkg_install_gdp \
        make install prefix=/usr DESTDIR=debian/dgit
        make -C po install prefix=/usr DESTDIR=../debian/tmp \
                SUPPRESS_PO_UPDATE=1 S=''
+       mv debian/dgit/usr/bin/git-playtree-create debian/dgit/usr/share/dgit
        make -C po4a install DESTDIR=../debian/tmp S=''
 
 override_dh_missing:
@@ -72,6 +73,8 @@ specpkg_install_%:
 #      # Most of the Perl modules in this package live in
 #      # $(specperl).  The exception is Debian::Dgit::Infra, which
 #      # lives in $(globalperl) and adds $(specperl) to @INC.
+#      # We also abuse this for git-playtree-create.  In .debs, this
+#      # goes in the per-.deb @INC dir.  See Dgit.pm::playtree_setup.
        set -ex; \
         base=debian/$(p); \
         mod=Debian/Dgit/$(pm).pm; \
@@ -79,6 +82,7 @@ specpkg_install_%:
         dst=$${base}$(globalperl)/$${mod}; \
         mkdir -p $${dst%/*}; \
         mv -f $$src $$dst; \
+        install -m 755 git-playtree-create $${base}$(specperl); \
         perl -i -p -e 'next unless m/###substituted###/;' \
                -e 'next unless s/^# (?=unshift \@INC,)//;' \
                -e 'die unless s{q\{\S+\}}{q{$(specperl)}};' \