chiark / gitweb /
git-playtree-setup: Rename from git-playtree-create
[dgit.git] / debian / rules
index 4e44118d8b245efb21a643b9de798e45c980489e..4d1a760274e419a93444c3e98291881f28839ab9 100755 (executable)
@@ -43,7 +43,7 @@ override_dh_auto_install: specpkg_install_gdp \
        make install prefix=/usr DESTDIR=debian/dgit
        make -C po install prefix=/usr DESTDIR=../debian/tmp \
                SUPPRESS_PO_UPDATE=1 S=''
-       mv debian/dgit/usr/bin/git-playtree-create debian/dgit/usr/share/dgit
+       mv debian/dgit/usr/bin/git-playtree-setup debian/dgit/usr/share/dgit
        make -C po4a install DESTDIR=../debian/tmp S=''
 
 override_dh_missing:
@@ -65,6 +65,9 @@ specpkg_install_gdp: tok=gdp
 specpkg_install_gdp: specperl=/usr/share/dgit/gdp/perl5
 specpkg_install_gdp:
        $(specpkg_install_common)
+       set -x; perl -i -pe 'next unless m/###substituted###/;' \
+ -e 's{^(git_playtree_setup)=.*}{$$1=/usr/share/$p/git-playtree-setup};' \
+               debian/$(p)/usr/bin/*
 
 specpkg_install_%: tok=$*
 specpkg_install_%: specperl=/usr/share/dgit/$(tok)/perl5
@@ -73,7 +76,7 @@ specpkg_install_%:
 #      # Most of the Perl modules in this package live in
 #      # $(specperl).  The exception is Debian::Dgit::Infra, which
 #      # lives in $(globalperl) and adds $(specperl) to @INC.
-#      # We also abuse this for git-playtree-create.  In .debs, this
+#      # We also abuse this for git-playtree-setup.  In .debs, this
 #      # goes in the per-.deb @INC dir.  See Dgit.pm::playtree_setup.
        set -ex; \
         base=debian/$(p); \
@@ -82,7 +85,7 @@ specpkg_install_%:
         dst=$${base}$(globalperl)/$${mod}; \
         mkdir -p $${dst%/*}; \
         mv -f $$src $$dst; \
-        install -m 755 git-playtree-create $${base}$(specperl); \
+        install -m 755 git-playtree-setup $${base}$(specperl); \
         perl -i -p -e 'next unless m/###substituted###/;' \
                -e 'next unless s/^# (?=unshift \@INC,)//;' \
                -e 'die unless s{q\{\S+\}}{q{$(specperl)}};' \