chiark / gitweb /
Remove any pre-existing _source.changes file before building source, as a safety...
[dgit.git] / debian / changelog
index 2f296309086665ec6593209448df87faa2930a8b..b02081ee339bbaadc9f13f91832e16a84c22f6ef 100644 (file)
-dgit (1.1~~) unstable; urgency=low
+dgit (1.5~~) unstable; urgency=medium
+
+  Incompatible change:
+  * dgit sbuild does not pass -A to sbuild.  Consequently the default
+    build is now simply sbuild's default.  With older sbuilds it was
+    possible to override dgit's -A by passing another option.  But this
+    has been changed recently and now this default setting is very awkward
+    to change for the dgit user.
+
+  New checks and improved behaviours:
+  * When running dpkg-buildpackage, cope if user specified -g or -G.
+  * dgit sbuild: check that the set of .changes files found is as we
+    expect, before calling mergechanges.
+  * dgit sbuild: Rename the used-up .changes files to `.inmulti' to
+    avoid accidental  use of the wrong one (by software, or by users).
+  * dgit sbuild: Check that the binary .changes file doesn't contain a
+    .dsc.
+  * Introduce --rm-old-changes to delete previous builds' changes files.
+  * Remove any pre-existing _source.changes file before building source,
+    as a safety check.
+
+  Documentation:
+  * Document the dgit-distro.DISTRO.quilt-mode config setting.
 
-  * Fix Vcs-Git and Vcs-Browse to refer to chiark.  (The dgit-repos on
-    alioth aren't suitable right now because the master there can
-    currently only be updated with an actual upload, ie dgit push.)
+  Bugfixes:
+  * When cleaning up after failed clone, stat the to-be-cleaned-up
+    directory before running rmtree on it.  Closes:#796773.
+  * Do not call "warn" on failure of cleanup handler in END block
+    (since warn has been made fatal and aborts the cleanup chain).
+  * Print better error message (with `fail' rather than `die') if
+    `dgit clone' cannot create the destination directory.
+  * Properly substitute $changesfile in one of the `You can retry'
+    messages.  Closes:#800078.
+  * Pass --ch:* and -v options to dpkg-buildpackage when building
+    source.  Fixes bad Perl poetry syntax.  Closes:#829121.
+
+  Test suite:
+  * When sbuild fails, do not crash due to sed not finding the log
+    file.  Instead, simply tolerate the absence of the log file.
+  * Put --no-arch-all in build-modes-sbuild act, not only its real_act.
+    Cosmetic change only.
+  * Set GIT_COMMITTER_DATE and GIT_AUTHOR_DATE and increment them
+    explicitly in drs-push-rejects test.  This avoids date dependencies
+    which can cause that test to fail on fast computers.
+  * Remove some spurios .debs from the example_1.0.tar.
+  * Increase sqlite_busy_timeout in debpolicy-dbretry, because
+    zealot is very slow and we need to give the other processes time
+    to rollback and release the lock.
+  * Test quilt single-debian-patch.
+
+ --
+
+dgit (1.4) unstable; urgency=high
+
+  Bugfixes:
+  * Unbreak --dry-run (`exiting subroutine via next', broken in
+    ac221d67, bug released in 0.22).
+  * When running git-add in commit-quilty-patch, properly escape
+    filenames (which git-add treats as glob patterns).
+  * When running git-add in commit-quilty-patch, use -f and sometimes -A,
+    so as to avoid being broken by any .gitignore, etc.
+  * When quilt linearisation fails, print the right information in
+    the error message.  (This has been broken forever.)
+  * Cope properly with `3.0 (quilt)' with single-debian-patch.
+    Closes:#796016.  (Still does not work with wheezy's dpkg-source, so
+    no test case yet.)
+  * With dgit sbuild, pass our -d before the user's arguments, so that
+    the user can override it.  Closes:#796019.
+
+  New checks and improved behaviours:
+  * Detect and reject git trees containing debian/source/local-options
+    or debian/source/local-patch-header.
+  * In --dry-run mode, _do_ actually run dpkg-source --commit so that we
+    actually do construct the quilt fixup commit; instead, honour
+    --dry-run by avoiding pulling it back to your HEAD.
+  * quilt-fixup checks that the git tree is clean, as for build-prep.
+
+  Documentation:
+  * In dgit(7), discuss binaries and documentation present in upstream but
+    removed by rules clean.
+
+  Test suite:
+  * Run quilt-fixup with -wgf in distropatches-reject,
+    so that we don't need build-depends.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sat, 22 Aug 2015 15:31:02 +0100
+
+dgit (1.3) unstable; urgency=high
+
+  Important bugfixes:
+  * In option parser test `@ARGV' not `length @ARGV'.  Closes:#795710.
+  * Properly quote package name when constructing regexp in
+    complete_file_from_dsc.  Closes:#795736.  Also, grep the code for
+    likely similar problems elsewhere and improve a (harmless) instance in
+    dgit-repos-server.
+
+  Other improvements:
+  * If a .orig in .. is a symlink, hardlink the link target into our
+    private unpack directory, rather than the link itself (since latter
+    won't work if the symlink is relative).  Closes:#795665.
+  * Test suite: Fix t-restriction-x-dgit-schroot-build in non-adt mode.
+  * Infrastructure: Improve an error message in dgit-repos-policy-debian.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sun, 16 Aug 2015 17:51:02 +0100
+
+dgit (1.2) unstable; urgency=high
+
+  Improvements:
+  * Honour *.clean-mode configuration setting for --clean= mode.
+  * No longer require option values to be cuddled: support `--opt val' and
+    `-o val'.  Closes:#763332.
+
+  Manpages:
+  * Fix typos.
+  * Document that tags are in DEP-14 format, and that they
+    are used for authenticating pushes.
+  * Correct cross-reference to point to browse.d.d.o.
+  * Move dgit.default.* to main CONFIGURATION section.
+
+  Administrivia:
+  * Add missing close of #793060 to changelog for version 1.1.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Fri, 14 Aug 2015 18:27:20 +0100
+
+dgit (1.1) unstable; urgency=medium
+
+  Bugfixes:
+  * When source package contains things called .git (even files, and even
+    in subdirectories), remove them.  Closes:#793671.
+  * Work around curl -sS -I printing `HTTP/1.0 200 Connection established'
+    before the actual header, so dgit works with https_proxy set (!)
+  * --new is needed for read access to packages in NEW, too.  Document
+    this, and make it work properly.
+  * Work around #793471 (madness with $SIG{__WARN__} and Perl's system
+    builtin): move $SIG{} setting into setup_sigwarn in Dgit.pm, and
+    check getppid.
+  * When invoking git-buildpackage via dgit gbp-build, consider our
+    command line arguments when massaging the dpkg-buildpackage arguments,
+    so that we don't end up giving dpkg-buildpackage contradictory
+    instructions.
+  * Cope with new git-buildpackage which provides gbp, rather than the
+    eponymous command, on PATH.
+
+  Configurability:
+  * Honour dgit-distros.DISTRO.cmd-CMD and .opts-CMD.  Closes:#793427.
+  * Make configuration able to prevent dpkg-mergechangelogs setup.
+  * Provide dgit setup-new-tree (like dpkg-setup-mergechangelogs
+    but only does it if not disabled in config).
+  * Set up git user.email and user.name from distro access config
+    or DEBEMAIL/DEBFULLNAME.  Closes:#793410.
+  * When key to use not specified any other way, use the debian/changelog
+    trailer line.  Closes:#793423.
+  * Honour --git= (mostly).
+
+  Documentation:
   * Fix some manpage typos.  [ Richard Hartmann ]
   * Manpage said that --clean=check was -wn but that is --clean=none;
     correctly document that --clean=check is actually -wc.
-  * Document that up to -DDD (not just -DD) is meaningfully different.
+  * Document that up to -DDDD (not just -DD) is meaningfully different.
   * Document that -cname=value applies only for this run.
   * Improve manpage comment about defining a new distro.
   * Document that --quilt=linear is the default for Debian.
@@ -21,38 +171,13 @@ dgit (1.1~~) unstable; urgency=low
   * Manpage: Clarify wording of readonly config.
   * Manpage: Better cross-references for -k and keyid.
   * dgit(7): No longer say that dgit-repos lives on Alioth.
-  * Infrastructure: Get mirroring right for fresh repos of existing
-    packages (!)
-  * --new is needed for read access to packages in NEW, too.  Document
-    this, and make it work properly.
-  * Work around #793471 (madness with $SIG{__WARN__} and Perl's system
-    builtin): move $SIG{} setting into setup_sigwarn in Dgit.pm, and
-    check getppid.
-  * Make warnings fatal in dpkg-repos-admin-debian, dgit-ssh-dispatch
-    (using setup_sigwarn).
-  * Make warnings fatal in tstunt/dpkg-parsechangelog (directly).
-  * When source package contains things called .git (even files, and even
-    in subdirectories), remove them.  Closes:#793671.
+
+  Improvements:
   * Introduce more sophisticated protocol negotiation for rpush.
   * Do not quote `:' in shellquote.
-  * Test suite: Honour DGIT_TEST_DEBUG=''.
   * Print a supplementary message when push fails, giving advice to
     the user about how to retry.  Closes:#793144.
-  * Honour dgit-distros.DISTRO.cmd-CMD and .opts-CMD.  Closes:#793427.
   * Slurp in entire git config, for better performance.
-  * With -DDDD, print out all gitcfg references (copious!)
-  * Fix a debug message in the obsolete sshpsql archive access driver.
-  * Make configuration able to prevent dpkg-mergechangelogs setup.
-  * Provide dgit setup-new-tree (like dpkg-setup-mergechangelogs
-    but only does it if not disabled in config).
-  * Set up git user.email and user.name from distro access config
-    or DEBEMAIL/DEBFULLNAME.  Closes:#793410.
-  * Work around curl -sS -I printing `HTTP/1.0 200 Connection established'
-    before the actual header, so dgit works with https_proxy set (!)
-  * When key to use not specified any other way, use the debian/changelog
-    trailer line.  Closes:#793423.
-  * Honour --git= (mostly).
-  * Test suite: More automatic enumeration of tests.
   * Rename `git-build' operation to `gbp-build' to make it clearer what
     it's for.  Keep the old name as an alias.
   * Show `dgit sbuild' in usage message.
@@ -60,9 +185,32 @@ dgit (1.1~~) unstable; urgency=low
     do the build, let it do its cleaning thing as part of its run, rather
     than running it twice.  When we are _not_ supposed to be using
     dpkg-buildpackage to clean, but we are running it to do the build,
-    pass -nc.
+    pass -nc.  Closes:#793060.
+  * Also suppress spurious runs of the clean target when building using
+    git-buildpackage.
+  * When exec fails, always print the program name in the error message.
 
- --
+  Infrastructure:
+  * Infrastructure: Get mirroring right for fresh repos of existing
+    packages (!)
+
+  Packaging, cleanups, debugging and test suite:
+  * Fix Vcs-Git and Vcs-Browse to refer to chiark.  (The dgit-repos on
+    alioth aren't suitable right now because the master there can
+    currently only be updated with an actual upload, ie dgit push.)
+  * Make warnings fatal in dpkg-repos-admin-debian, dgit-ssh-dispatch
+    (using setup_sigwarn).
+  * Make warnings fatal in tstunt/dpkg-parsechangelog (directly).
+  * Test suite: Honour DGIT_TEST_DEBUG=''.
+  * With -DDDD, print out all gitcfg references (copious!)
+  * Fix a debug message in the obsolete sshpsql archive access driver.
+  * Test suite: More automatic enumeration of tests.
+  * Test suite: Provide tests which check that all our various build
+    operations run the right targets as expected (ie, that we are massaging
+    the arguments to dpkg-buildpackage, and suppressing our clean target,
+    etc., correctly).
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Mon, 27 Jul 2015 16:34:31 +0100
 
 dgit (1.0) unstable; urgency=medium