chiark / gitweb /
dgit: Get sense of failed clone failed cleanup error reporting check correct.
[dgit.git] / debian / changelog
index 37a746a4437dc69efd03b2f8bec26645538bd8a2..9c52188cec5d677c55e4aa31f4d3c3f0a3e9140f 100644 (file)
@@ -15,7 +15,7 @@ dgit (1.5~~) unstable; urgency=medium
   New checks and improved behaviours:
   * When running dpkg-buildpackage, cope if user specified -g or -G.
   * dgit sbuild: check that the set of .changes files found is as we
-    expect, before calling mergechanges.
+    expect, before calling mergechanges.  Re:#800060.
   * dgit sbuild: Rename the used-up .changes files to `.inmulti' to
     avoid accidental use of the wrong one (by software, or by users).
   * dgit sbuild: Check that the binary .changes file doesn't contain a
@@ -24,7 +24,7 @@ dgit (1.5~~) unstable; urgency=medium
   * Remove any pre-existing _source.changes file before building source,
     as a safety check.
   * No longer tolerate a multitude of .changes files when doing push.
-    Instead, insist on a single one.
+    Instead, insist on a single one.  Closes:#800110.
   * dgit sbuild no longer deletes extranious .changes files; instead
     we rely on --rm-old-changes, or failing that, fail early.
   * When doing quilt linearisation, treat upstream .gitignores not
@@ -42,6 +42,13 @@ dgit (1.5~~) unstable; urgency=medium
     from dgit about what it was doing.
   * Make --quilt=gbp the default for dgit gbp-build.
   * New tag format (for dgit view) archive/debian/VERSION.
+  * Before committing to push, check that .dsc and .changes correspond.
+    Closes:#800060.
+  * Better error message if non-split-brain patch stack no longer
+    applies (due to new upstream version, or user messing with it).
+    Closes:#833025.
+  * Better error message if HEAD contains changes unrepresentable
+    by `3.0 (quilt)'.  Closes:#834618.
 
   Infrastructure:
   * Better error handling in dgit-repos-policy-debian.
@@ -50,6 +57,10 @@ dgit (1.5~~) unstable; urgency=medium
 
   Documentation:
   * Document the dgit-distro.DISTRO.quilt-mode config setting.
+  * Clarify the --clean= options' documentation.  Closes:#800054.
+  * Discourage use of the --PROGRAM:OPTION escape hatch.  (Apropos
+    of various bug reports including #800060 and #833025.)
+  * Document the expected form of HEAD for each --quilt= mode.
 
   Bugfixes:
   * When cleaning up after failed clone, stat the to-be-cleaned-up
@@ -74,6 +85,15 @@ dgit (1.5~~) unstable; urgency=medium
     .orig-comp components accorging to dpkg-source(1).
   * Fix up .orig detection to handle .asc's (and other signatures)
     of .orig components the same way as their tarballs.
+  * Tidy up refs/dgit-fetch/ after dgit fetch (if successful).
+  * Fix handling of in-archive copies.
+  * Don't break if user has push.followTags=true.  Closes:#827878.
+  * Arrange for the special dgit remote to be skipped by git fetch --all
+    etc.  Closes:#827892.
+  * Allow local git config options to override user-global ones,
+    as is proper.  Closes:#835858.
+  * Get sense of failed clone failed cleanup error reporting check
+    correct.  Closes:#796773.
 
   Test suite:
   * When sbuild fails, do not crash due to sed not finding the log