chiark / gitweb /
po4a: pairwise-pocheck: Force it to be run sometimes
[dgit.git] / debian / changelog
index a766e8f64c597964060b29a9167dec350b73ce54..86181b75aee33ef879ada1998b702ec196aa2443 100644 (file)
@@ -1,4 +1,136 @@
-dgit (6.10~) unstable; urgency=medium
+dgit (8.1~) unstable; urgency=medium
+
+  * 
+
+ --
+
+dgit (8.0) unstable; urgency=medium
+
+  dgit - Behavioural change with compatibility implications:
+  * Check (with --clean=dpkg-source[-d], ie, by default) that rules
+    clean does not leave untracked files (ie, trip if it looks like
+    a `git add' may have been forgotten).  dgit will now fail in
+    some situations where previously it would have just carried on.
+  * Honour new clean modes --dpkg-source[-d],no-check aka -wdn / -wddn
+    which suppress this check.  (Whether the untracked files are
+    used or disregarded depends on --include-dirty.)
+  * Honour new .clean-mode-newer access config option, to allow git
+    configs to be compatible with both new and old dgits.
+    See relevant parts of dgit(1) for more information.
+
+  dgit - Improved behaviours:
+  * Better handling of cross-filesystem operations, including
+    build-products-dir on a different fs.  Closes:#910730.
+  * Change to git toplevel dir before starting.  Closes:#910724.
+  * Provide --clean=check,ignores aka -wci.
+  * Provide --clean=dpkg-source[-d],all-check aka -wda / -wdda.
+
+  dgit - Important bugfixes:
+  * Check that tree does not contain untracked files (depending on clean
+    mode) when building source using git branch rather than using working
+    tree.  In particular, honour --clean=check.  Closes:#910705.
+  * Also apply that new cleanliness check during build-source or
+    push-source etc. with --clean=dpkg-source; even though rules
+    clean was not run.  See above.  Again, -wdn / -wddn may be needed.
+  * dgit: Forbid source building with --include-dirty and non-.. bpd,
+    which can seriously malfunction.  Closes:#910725; see #910740.
+
+  dgit - Additional sanity checks:
+  * quilt linearisation: Stop at debian/source/format changes.
+  * quilt fixup: Cope if gdr analysis finds origin.  Closes:#910687.
+  * Add missing error check in single-debian-patch handling.
+  * Refuse to work if critical files have uncommitted changes.
+  * Reject all git config options containing newlines.
+  * Better error message for not in git tree.  (For git-debrebase too.)
+
+  dgit - Minor bugfixes:
+  * Fix spelling errors etc. in messages.
+  * Replace mention of alioth by salsa in a message.
+  * clean_tree: confess rather than die on unknown clean mode.
+  * Add missing \n to crash from git_cat_file.  (git-debrebase too.)
+
+  Documentation:
+  * dgit(1): Document that cleaning is sometimes not needed and
+    is therefore not done.
+  * README.md: Add this document for the benefit of Salsa.
+  * po/README: Mention -k10 threshold.
+  * po/README: Give a pointer to salsa; remind the translator to commit.
+  * dgit(1): Fix spelling errors.
+  * dgit(7): Fix spelling errors.
+  * dgit-sponsorship(7): Fix spelling error.
+
+  Consequential changes:
+  * Internal refactoring to support all these changes.
+  * Tests adjusted to correspond to, and somewhat test, these changes.
+  * Slight reorganisation to documentation of --clean=dpkg-source etc.
+
+  Build system:
+  * Makefile: Provide i18n-commit target.
+  * po/list-documents: Set translation threshold to 10%.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sat, 13 Oct 2018 23:56:35 +0100
+
+dgit (7.0) unstable; urgency=medium
+
+  Bugfixes:
+  * dgit: Do not sometimes crash in quilt-fixup if git-debrebase
+    is not installed.  Closes:#910221.
+  * git-debrebase: new-upstream: Drop `sleep 2' (!)
+  * git-debrebase: anchor: Print the anchor, not the breakwater tip (!)
+  * Get rid of perl warning "Statement unlikely to be reached"
+    (introduced in 7.0~pre1).
+  * git-debrebase: merges: Make warnings of lossage less overblown
+
+  i18n (translation):
+  * Support message translation for git-debrebase.  (Re #904883.)
+  * Support document translation.  Closes:#904883.
+  * po: Rename `all-po' target to `pofiles'
+
+  Error message improvements (prompted by i18n work)
+  * Replaced `die' with `confess' in many unexpected syscall errors
+    and internal error cases.
+  * git-debrebase; Print a proper message for failure to opendir
+    the bpd and for failure to chdir to the toplevel.
+
+  Internal changes:
+  * Minor refactoring to support translation.
+  * i18n-diff-auditor: New script to support translation markup.
+
+  Packaging:
+  * Use dh_missing --fail-missing
+  * Add missing build-dependency on xgettext
+
+  Test suite:
+  * gdr-makepatches7: Fixes to dgit/git-debrebase interaction
+  * gdr-makepatches7: Test dgit with missing git-debrebase
+  * Test that the binary packages can be built
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Thu, 04 Oct 2018 20:33:12 +0100
+
+dgit (7.0~pre1) experimental; urgency=medium
+
+  * i18n: Support messgae translation for the program dgit.
+    (Working towards #904883.)
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Tue, 02 Oct 2018 13:20:24 +0100
+
+dgit (6.12) unstable; urgency=medium
+
+  * test suite: t-check-only-bpd: Check $tmp/.. not .. .  Fixes bogus
+    failure in Ubuntu CI.  Thanks to Mattia Rizzolo for the report.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Fri, 28 Sep 2018 18:17:36 +0100
+
+dgit (6.11) unstable; urgency=medium
+
+  * dgit-maint-debrebase(7): move and improve the section
+    "Inspecting the history".  [Sean Whitton]
+  * Makefile: Adjust scope of dgit(7) pod rule.
+  * local-pod-man: developer script, obsoleteed by `make %.view': drop it.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sun, 26 Aug 2018 14:59:32 +0100
+
+dgit (6.10) unstable; urgency=medium
 
   git-debrebase bugfixes:
   * Patches in subdirectories: fix malfunctions.  Closes:#907202,#907206.
@@ -48,7 +180,7 @@ dgit (6.10~) unstable; urgency=medium
   * Work if $tmp is on a different filesystem.
   * Internal changes and refactoring to support other changes.
 
- --
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sun, 26 Aug 2018 14:58:18 +0100
 
 dgit (6.9) unstable; urgency=medium