chiark / gitweb /
dgit.1: Discourage use of the --PROGRAM:OPTION escape hatch.
[dgit.git] / debian / changelog
index e97cb3c1a644eb88b7e908bfe97a49a82ae5fbaf..83c602c122835722617a58f22d0b60aa25435851 100644 (file)
@@ -7,10 +7,15 @@ dgit (1.5~~) unstable; urgency=medium
     has been changed recently and now this default setting is very awkward
     to change for the dgit user.
 
+  Major new feature:
+  * --quilt=gbp, --quilt=dpm, --quilt=unpacked: Introduce facility for
+    split view (dgit/mainiainer view), to improve compatibility with some
+    other workflow tools.
+
   New checks and improved behaviours:
   * When running dpkg-buildpackage, cope if user specified -g or -G.
   * dgit sbuild: check that the set of .changes files found is as we
-    expect, before calling mergechanges.
+    expect, before calling mergechanges.  Re:#800060.
   * dgit sbuild: Rename the used-up .changes files to `.inmulti' to
     avoid accidental use of the wrong one (by software, or by users).
   * dgit sbuild: Check that the binary .changes file doesn't contain a
@@ -19,7 +24,7 @@ dgit (1.5~~) unstable; urgency=medium
   * Remove any pre-existing _source.changes file before building source,
     as a safety check.
   * No longer tolerate a multitude of .changes files when doing push.
-    Instead, insist on a single one.
+    Instead, insist on a single one.  Closes:#800110.
   * dgit sbuild no longer deletes extranious .changes files; instead
     we rely on --rm-old-changes, or failing that, fail early.
   * When doing quilt linearisation, treat upstream .gitignores not
@@ -35,6 +40,10 @@ dgit (1.5~~) unstable; urgency=medium
     any Gbp-Pq headers (that we understand).
   * Several dgit-generated commits now have slightly better annotations
     from dgit about what it was doing.
+  * Make --quilt=gbp the default for dgit gbp-build.
+  * New tag format (for dgit view) archive/debian/VERSION.
+  * Before committing to push, check that .dsc and .changes correspond.
+    Closes:#800060.
 
   Infrastructure:
   * Better error handling in dgit-repos-policy-debian.
@@ -43,6 +52,9 @@ dgit (1.5~~) unstable; urgency=medium
 
   Documentation:
   * Document the dgit-distro.DISTRO.quilt-mode config setting.
+  * Clarify the --clean= options' documentation.  Closes:#800054.
+  * Discourage use of the --PROGRAM:OPTION escape hatch.  (Apropos
+    of various bug reports including #800060.)
 
   Bugfixes:
   * When cleaning up after failed clone, stat the to-be-cleaned-up
@@ -67,6 +79,11 @@ dgit (1.5~~) unstable; urgency=medium
     .orig-comp components accorging to dpkg-source(1).
   * Fix up .orig detection to handle .asc's (and other signatures)
     of .orig components the same way as their tarballs.
+  * Tidy up refs/dgit-fetch/ after dgit fetch (if successful).
+  * Fix handling of in-archive copies.
+  * Don't break if user has push.followTags=true.  Closes:#827878.
+  * Arrange for the special dgit remote to be skipped by git fetch --all
+    etc.  Closes:#827892.
 
   Test suite:
   * When sbuild fails, do not crash due to sed not finding the log