chiark / gitweb /
dgit.1: Discourage use of the --PROGRAM:OPTION escape hatch.
[dgit.git] / debian / changelog
index 81589c4955c7cc0a2718d851fa126bf07fbb238f..83c602c122835722617a58f22d0b60aa25435851 100644 (file)
-dgit (1.2~~) UNRELEASED; urgency=low
+dgit (1.5~~) unstable; urgency=medium
 
-  * Fix manpage typo `dig' for `dgit'.
-  * Fix manpage typo `sourcefull'.
-  * Correct manpage cross-reference to point to browse.d.d.o.
+  Incompatible change:
+  * dgit sbuild does not pass -A to sbuild.  Consequently the default
+    build is now simply sbuild's default.  With older sbuilds it was
+    possible to override dgit's -A by passing another option.  But this
+    has been changed recently and now this default setting is very awkward
+    to change for the dgit user.
+
+  Major new feature:
+  * --quilt=gbp, --quilt=dpm, --quilt=unpacked: Introduce facility for
+    split view (dgit/mainiainer view), to improve compatibility with some
+    other workflow tools.
+
+  New checks and improved behaviours:
+  * When running dpkg-buildpackage, cope if user specified -g or -G.
+  * dgit sbuild: check that the set of .changes files found is as we
+    expect, before calling mergechanges.  Re:#800060.
+  * dgit sbuild: Rename the used-up .changes files to `.inmulti' to
+    avoid accidental use of the wrong one (by software, or by users).
+  * dgit sbuild: Check that the binary .changes file doesn't contain a
+    .dsc.
+  * Introduce --rm-old-changes to delete previous builds' changes files.
+  * Remove any pre-existing _source.changes file before building source,
+    as a safety check.
+  * No longer tolerate a multitude of .changes files when doing push.
+    Instead, insist on a single one.  Closes:#800110.
+  * dgit sbuild no longer deletes extranious .changes files; instead
+    we rely on --rm-old-changes, or failing that, fail early.
+  * When doing quilt linearisation, treat upstream .gitignores not
+    in the toplevel the same way we treat ones in the toplevel.
+  * When automatically generating quilt patch, honour GIT_COMMITTER_DATE
+    for filename creation (makes filename deterministic in test suite).
+  * New --overwrite option, replaces need to for user to use
+    git merge -s ours.  Closes:#838718.
+  * When generating quilt patches from git commits, make patches that
+    look quite like git-format-patch output (rather than strange things
+    based on an obselete interpretation of DEP-3).
+  * When generating quilt patches from git commits, honour (and strip)
+    any Gbp-Pq headers (that we understand).
+  * Several dgit-generated commits now have slightly better annotations
+    from dgit about what it was doing.
+  * Make --quilt=gbp the default for dgit gbp-build.
+  * New tag format (for dgit view) archive/debian/VERSION.
+  * Before committing to push, check that .dsc and .changes correspond.
+    Closes:#800060.
+
+  Infrastructure:
+  * Better error handling in dgit-repos-policy-debian.
+  * dgit-repos-policy-debian.: fix git-cat-file-handling with multiple
+    taints in db (!).
+
+  Documentation:
+  * Document the dgit-distro.DISTRO.quilt-mode config setting.
+  * Clarify the --clean= options' documentation.  Closes:#800054.
+  * Discourage use of the --PROGRAM:OPTION escape hatch.  (Apropos
+    of various bug reports including #800060.)
+
+  Bugfixes:
+  * When cleaning up after failed clone, stat the to-be-cleaned-up
+    directory before running rmtree on it.  Closes:#796773.
+  * Do not call "warn" on failure of cleanup handler in END block
+    (since warn has been made fatal and aborts the cleanup chain).
+  * Print better error message (with `fail' rather than `die') if
+    `dgit clone' cannot create the destination directory.
+  * Properly substitute $changesfile in one of the `You can retry'
+    messages.  Closes:#800078.
+  * Pass --ch:* and -v options to dpkg-buildpackage when building
+    source.  Fixes bad Perl poetry syntax.  Closes:#829121.
+  * When synthesing a commit from a .dsc from the archive, stop
+    internal git reset from printing a confusing message about HEAD.
+  * Turn off git gc in the private working areas.
+  * Do not fail to do some important quilt processing in some
+    --quilt modes.
+  * Fix two calls to chdir without proper error checking.
+  * Fix a couple of bugs in error reporting.
+  * Fix up .orig detection to be less trustful of (ambiguous) filenames.
+  * Fix up .orig detection to correctly allow exactly the right
+    .orig-comp components accorging to dpkg-source(1).
+  * Fix up .orig detection to handle .asc's (and other signatures)
+    of .orig components the same way as their tarballs.
+  * Tidy up refs/dgit-fetch/ after dgit fetch (if successful).
+  * Fix handling of in-archive copies.
+  * Don't break if user has push.followTags=true.  Closes:#827878.
+  * Arrange for the special dgit remote to be skipped by git fetch --all
+    etc.  Closes:#827892.
+
+  Test suite:
+  * When sbuild fails, do not crash due to sed not finding the log
+    file.  Instead, simply tolerate the absence of the log file.
+  * Put --no-arch-all in build-modes-sbuild act, not only its real_act.
+    Cosmetic change only.
+  * Set GIT_COMMITTER_DATE and GIT_AUTHOR_DATE and increment them
+    explicitly in drs-push-rejects test.  This avoids date dependencies
+    which can cause that test to fail on fast computers.
+  * Remove some spurios .debs from the example_1.0.tar.
+  * Increase sqlite_busy_timeout in debpolicy-dbretry, because
+    zealot is very slow and we need to give the other processes time
+    to rollback and release the lock.
+  * Test quilt single-debian-patch.
+  * Provide `tartree-edit gitfetchinfo' etc. to help with comparing
+    different test case git working tree tarballs.
+  * Test dgit-repos-policy-debian with multiple (identical, as it happens)
+    existing taints.
+  * Provide better log output for certain failures.
 
  --
 
+dgit (1.4) unstable; urgency=high
+
+  Bugfixes:
+  * Unbreak --dry-run (`exiting subroutine via next', broken in
+    ac221d67, bug released in 0.22).
+  * When running git-add in commit-quilty-patch, properly escape
+    filenames (which git-add treats as glob patterns).
+  * When running git-add in commit-quilty-patch, use -f and sometimes -A,
+    so as to avoid being broken by any .gitignore, etc.
+  * When quilt linearisation fails, print the right information in
+    the error message.  (This has been broken forever.)
+  * Cope properly with `3.0 (quilt)' with single-debian-patch.
+    Closes:#796016.  (Still does not work with wheezy's dpkg-source, so
+    no test case yet.)
+  * With dgit sbuild, pass our -d before the user's arguments, so that
+    the user can override it.  Closes:#796019.
+
+  New checks and improved behaviours:
+  * Detect and reject git trees containing debian/source/local-options
+    or debian/source/local-patch-header.
+  * In --dry-run mode, _do_ actually run dpkg-source --commit so that we
+    actually do construct the quilt fixup commit; instead, honour
+    --dry-run by avoiding pulling it back to your HEAD.
+  * quilt-fixup checks that the git tree is clean, as for build-prep.
+
+  Documentation:
+  * In dgit(7), discuss binaries and documentation present in upstream but
+    removed by rules clean.
+
+  Test suite:
+  * Run quilt-fixup with -wgf in distropatches-reject,
+    so that we don't need build-depends.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sat, 22 Aug 2015 15:31:02 +0100
+
+dgit (1.3) unstable; urgency=high
+
+  Important bugfixes:
+  * In option parser test `@ARGV' not `length @ARGV'.  Closes:#795710.
+  * Properly quote package name when constructing regexp in
+    complete_file_from_dsc.  Closes:#795736.  Also, grep the code for
+    likely similar problems elsewhere and improve a (harmless) instance in
+    dgit-repos-server.
+
+  Other improvements:
+  * If a .orig in .. is a symlink, hardlink the link target into our
+    private unpack directory, rather than the link itself (since latter
+    won't work if the symlink is relative).  Closes:#795665.
+  * Test suite: Fix t-restriction-x-dgit-schroot-build in non-adt mode.
+  * Infrastructure: Improve an error message in dgit-repos-policy-debian.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sun, 16 Aug 2015 17:51:02 +0100
+
+dgit (1.2) unstable; urgency=high
+
+  Improvements:
+  * Honour *.clean-mode configuration setting for --clean= mode.
+  * No longer require option values to be cuddled: support `--opt val' and
+    `-o val'.  Closes:#763332.
+
+  Manpages:
+  * Fix typos.
+  * Document that tags are in DEP-14 format, and that they
+    are used for authenticating pushes.
+  * Correct cross-reference to point to browse.d.d.o.
+  * Move dgit.default.* to main CONFIGURATION section.
+
+  Administrivia:
+  * Add missing close of #793060 to changelog for version 1.1.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Fri, 14 Aug 2015 18:27:20 +0100
+
 dgit (1.1) unstable; urgency=medium
 
   Bugfixes:
@@ -69,7 +241,7 @@ dgit (1.1) unstable; urgency=medium
     do the build, let it do its cleaning thing as part of its run, rather
     than running it twice.  When we are _not_ supposed to be using
     dpkg-buildpackage to clean, but we are running it to do the build,
-    pass -nc.
+    pass -nc.  Closes:#793060.
   * Also suppress spurious runs of the clean target when building using
     git-buildpackage.
   * When exec fails, always print the program name in the error message.