chiark / gitweb /
Dgit.pm: Call `confess' when shellquote gets an undef arg
[dgit.git] / debian / changelog
index 158bcaec1cb7013f9d9609bc1e56da33a4a6ed92..7c2faacc0aed959d97620b821321ade39008aefc 100644 (file)
@@ -1,4 +1,113 @@
-dgit (3.0~) unstable; urgency=medium
+dgit (3.6~) unstable; urgency=medium
+
+  Minor improvements:
+  * Call `confess' to print a stack trace when we pass undef to
+    shellquote (eg as a result of debugcmd).  Turns an undefined
+    warning into an explicit internal error.
+
+ --
+
+dgit (3.5) unstable; urgency=medium
+
+  Bugfixes:
+  * gitattributes: Defuse gitattributes in private working area even if we
+    don't do it in the user's tree (because of user configuration).
+  * gitattributes: When cloning, do not print spurious warning about
+    actually-defused gitattributes.  Closes:#851624.
+  * gitattributes: Improve comment left in .git/info/attributes.
+
+  Test suite:
+  * gitattributes: Many improvements to test case.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Tue, 17 Jan 2017 22:36:01 +0000
+
+dgit (3.4) unstable; urgency=low
+
+  Test suite:
+  * drs-push-rejects: Set origin's url to an ad-hoc expression
+    which produces the right ext:: rune, as dgit would.
+    Closes:#851580.
+  * Replace references to /home/ian in various worktrees with
+    references to /nonexistent, to catch inadvertant accesses.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Mon, 16 Jan 2017 17:27:35 +0000
+
+dgit (3.3) unstable; urgency=medium
+
+  Behavioural changes to work around gitattributes file transformations:
+  * Suppress file-transforming gitattributes in private work areas.
+  * Configure suppression in user's trees in dgit clone and setup-new-tree.
+  * Provide dgit setup-gitattributes to do this explicitly.
+  * Documentation.
+
+  Bugfixes:
+  * dgit: Remove a leftover debugging print.
+  * dgit: Set default dsc import distro when there is no Dgit field.
+  * dgit: Set default dsc import distro when suppressing Dgit field.
+  * dgit: Option parsing: Fix undefined $suite in some import-dsc.
+    Closes:#851213.
+
+  Packaging:
+  * Remove redundant use of List::Util qw(any).  Closes:#851280.
+  * Remove redundant Recommends on libtext-iconv-perl.
+
+  Test suite:
+  * Move default dsc distro config setting to lib.  We need this
+    for the .dscs we have in tests/pkg-srcs/.
+  * defdistro-import-dsc: Drop this test.
+  * protocol-compat: check that we use the right distro
+    information when importing.
+  * Internal change: fix handling of nonempty distro=
+  * gitattributes: New test for .gitattributes handling.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Mon, 16 Jan 2017 10:03:08 +0000
+
+dgit (3.2) unstable; urgency=medium
+
+  Bugfixes:
+  * dgit: Do not execute END blocks in children.  So far symptoms of this
+    bug seem to be limited to duplicated error messages but I have not
+    done a thorough analysis.  Closes:#850052.
+  * dgit-infrastructure: dgit-repos-policy-debian: Remirror a package when
+    it becomes public (ie, make the repo available much more promptly when
+    the package passes NEW).  Closes:#849789.
+  * dgit: Fix a warning message about ref (mainly, tag) updates.
+
+  Documentation:
+  * dgit-maint-merge(7): Use git-deborig(1).
+    [Sean Whitton]  Closes:#850953.
+  * dgit-user(7): Fix some typos.
+
+  Internals:
+  * Fix a typo in a comment.
+
+  Test suite:
+  * infra: mirroring and policy hooks: Improve some debugging output.
+  * infra: mirror-private: test that package becomes public.  (#849789)
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Thu, 12 Jan 2017 02:11:34 +0000
+
+dgit (3.1) unstable; urgency=medium
+
+  Bugfixes:
+  * dgit import-dsc: Do not crash with undefined $isuite.  Closes:#850781.
+  * dgit build: Do not sometimes crash with undefined $isuite.
+  * dgit: Do not nedlessly re-fetch the rewrite map.
+  * dgit: After downloading .debian.* files, save them in `..', too
+    (ie do this not just for .origs).
+  * dgit: When fetching, refetch files with hash mismatches (and save them
+    as `...,fetch'), so we can distinguish them from any built locally.
+    Closes:#850824.
+
+  Test suite:
+  * Add test for import-dsc with default distro.  (Detects #850781.)
+
+  Administrivia:
+  * Fix a dgit 3.0 changelog bullet referring to refs/dgit-fetch/DISTRO.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Tue, 10 Jan 2017 17:50:27 +0000
+
+dgit (3.0) unstable; urgency=medium
 
   Protocol change:
   * Dgit: field now records the nominal distro name, and a hint
@@ -13,6 +122,9 @@ dgit (3.0~) unstable; urgency=medium
     and is now fixed even for more-extended ones.
   * dgit clone-dgit-repos-server uses readonly access.
     Closes:#850521.
+  * fetch and pull ignore the changelog suite when it is UNRELEASED.
+    Closes:#848646.
+  * dgit-badcommit-fixup: Do not investigate symrefs.  Closes:#850547.
 
   Minor new feature:
   * distro alias facility in config space.  (Primarily for testing.)
@@ -20,17 +132,20 @@ dgit (3.0~) unstable; urgency=medium
   * Provide `dgit print-dgit-repos-server-source-url'.  Re:#850521.
   * Honour dgit-distro.*.default-suite and dgit.default.default-suite.
 
-  dgit-badcommit-fixup: 
-  * Do not investigate symrefs.  Closes:#850547.
-
+  Other improvements:
   * Improve debugging output a bit.
-  * Use refs/dgit-fetch/DISTRO rather than refs/dgit-fetch/DISTRO,
+  * Use refs/dgit-fetch/DISTRO rather than refs/dgit-fetch/SUITE,
     which leads to less duplication and so less clutter.
   * Enforce a reasonable syntax for nominal distro names.
+  * When generating orig+debian/patches view, copy debian/ from
+    HEAD.  This makes less noise in diffs.  Closes:#850095.
 
-  Docuentation [Sean Whitton]:
+  Docuentation [Sean Whitton and Ian Jackson]:
   * dgit-sponsorship(7): Use --no-dep14tag.  Closes:#849105.
   * dgit-maint-merge(7): Use debian/source/patch-header.  Closes:849120.
+  * dgit(7): Updated `trouble' section to suggest having dpkg-source
+    delete the autotools output (with a patch if necessary).
+  * dgit(1): Several minor updates and fixes.  Closes:#850519.
 
   Test suite:
   * Internal improvements.
@@ -43,7 +158,7 @@ dgit (3.0~) unstable; urgency=medium
   * Tests for the new protocol feature.
   * Fail tests if we look up any configuration relating to Debian.
 
- --
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Mon, 09 Jan 2017 16:43:10 +0000
 
 dgit (2.16.2) unstable; urgency=low