chiark / gitweb /
Test suite: Introduce setup/gnupg
[dgit.git] / debian / changelog
index 9c52188cec5d677c55e4aa31f4d3c3f0a3e9140f..55433891db33bb7119a0c968d648581f93a5cd42 100644 (file)
@@ -1,18 +1,79 @@
-dgit (1.5~~) unstable; urgency=medium
+dgit (2.5~) unstable; urgency=medium
+
+  * dgit-maint-merge(7): New tutorial manpage from Sean Whitton.
+  * Test suite bugfixes.
+  * Test suite: Introduce setup/gnupg, to work around #841143
+    and improve performance by amortising gnupg migration cost.
+
+ --
+
+dgit (2.4) unstable; urgency=low
+
+  Bugfixes:
+  * split brain cache: Fix a wrong implicit reference to $_.
+    Closes:#841383.
+  * split brain cache: Make sure to write reflog entries for cache updates
+    even if the eventual tree (and therefore commit) is the same.
+    Otherwise, after updating dgit, the cache might have the right answer
+    but not be refreshed even by a build.
+  * dgit gbp-build: No longer invent a --git-debian-branch option.
+    Usually the user is a maintainer using split brain, and we should rely
+    on their own gbp configuration to specify the right check.
+    Closes:#841100.
+
+  Minor docs fix:
+  * dgit(1): Document which --ch: options are a good idea.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Thu, 20 Oct 2016 16:31:54 +0100
+
+dgit (2.3) unstable; urgency=low
+
+  * With --overwrite, do not check all sorts of tags (which may
+    not exist, or might contain wrong things).  Closes:#841101.
+  * When generating pseudomerge in quilt split brain mode due to
+    --overwrite, actually include the version number in the commit
+    message.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Tue, 18 Oct 2016 01:58:05 +0100
+
+dgit (2.2) unstable; urgency=low
+
+  * Fix config relating to Debian to actually make split brain mode
+    work.  Closes:#841085.
+  * Detect SIGPIPE (and SIGCHLD) being blocked or ignored.
+    Closes:#841085.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Mon, 17 Oct 2016 17:31:18 +0100
+
+dgit (2.1) unstable; urgency=low
+
+  * Do not crash due in clone to failure to handle dpkg-parsechangelog
+    SIGPIPE.  Closes:#840989.  Avoids:
+       dgit: failed command: dpkg-parsechangelog --format rfc822 --all
+       dgit: subprocess died due to fatal signal PIPE
+  * git- prefixes: Fix some occurrences of `git-foo' in infrastructure,
+    messages, and test suite.  Filter out .../git-core from PATH in
+    test suite so that we catch future occurrences.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sun, 16 Oct 2016 19:05:14 +0100
+
+dgit (2.0) unstable; urgency=low
 
   Incompatible change:
-  * dgit sbuild does not pass -A to sbuild.  Consequently the default
+  * dgit sbuild: does not pass -A to sbuild.  Consequently the default
     build is now simply sbuild's default.  With older sbuilds it was
     possible to override dgit's -A by passing another option.  But this
     has been changed recently and now this default setting is very awkward
     to change for the dgit user.
+  * dgit gbp-build: Make --quilt=gbp the default.  (See below.)
+  * New tag format (for dgit view) archive/debian/VERSION.
 
   Major new feature:
   * --quilt=gbp, --quilt=dpm, --quilt=unpacked: Introduce facility for
     split view (dgit/mainiainer view), to improve compatibility with some
-    other workflow tools.
+    workflow tools.
 
-  New checks and improved behaviours:
+  New checks and improved behaviours in dgit:
   * When running dpkg-buildpackage, cope if user specified -g or -G.
   * dgit sbuild: check that the set of .changes files found is as we
     expect, before calling mergechanges.  Re:#800060.
@@ -40,8 +101,6 @@ dgit (1.5~~) unstable; urgency=medium
     any Gbp-Pq headers (that we understand).
   * Several dgit-generated commits now have slightly better annotations
     from dgit about what it was doing.
-  * Make --quilt=gbp the default for dgit gbp-build.
-  * New tag format (for dgit view) archive/debian/VERSION.
   * Before committing to push, check that .dsc and .changes correspond.
     Closes:#800060.
   * Better error message if non-split-brain patch stack no longer
@@ -49,11 +108,17 @@ dgit (1.5~~) unstable; urgency=medium
     Closes:#833025.
   * Better error message if HEAD contains changes unrepresentable
     by `3.0 (quilt)'.  Closes:#834618.
+  * Much better error message when HEAD and .dsc do not match.
+    Closes:#809516.
 
   Infrastructure:
-  * Better error handling in dgit-repos-policy-debian.
+  * dgit-repos-policy-debian: Better error handling.
   * dgit-repos-policy-debian.: fix git-cat-file-handling with multiple
     taints in db (!).
+  * dgit-infrastructure has, and uses, its own copies of the perl modules.
+    This avoids introducing a versioned dependency between dgit and
+    dgit-infrastructure (and also makes it easier to test cross-version
+    compatibility).
 
   Documentation:
   * Document the dgit-distro.DISTRO.quilt-mode config setting.
@@ -80,20 +145,17 @@ dgit (1.5~~) unstable; urgency=medium
     --quilt modes.
   * Fix two calls to chdir without proper error checking.
   * Fix a couple of bugs in error reporting.
-  * Fix up .orig detection to be less trustful of (ambiguous) filenames.
-  * Fix up .orig detection to correctly allow exactly the right
-    .orig-comp components accorging to dpkg-source(1).
-  * Fix up .orig detection to handle .asc's (and other signatures)
-    of .orig components the same way as their tarballs.
+  * Fix several bugs in .orig detection/recognition.
   * Tidy up refs/dgit-fetch/ after dgit fetch (if successful).
   * Fix handling of in-archive copies.
   * Don't break if user has push.followTags=true.  Closes:#827878.
   * Arrange for the special dgit remote to be skipped by git fetch --all
-    etc.  Closes:#827892.
+    etc.  And no longer configure a fetch spec, since it won't work
+    anyway.  Closes:#827892.
   * Allow local git config options to override user-global ones,
     as is proper.  Closes:#835858.
-  * Get sense of failed clone failed cleanup error reporting check
-    correct.  Closes:#796773.
+  * When generating patch filenames from titles, first transliterate
+    them (lossily) to ascii.  Closes:#834807.
 
   Test suite:
   * When sbuild fails, do not crash due to sed not finding the log
@@ -104,7 +166,7 @@ dgit (1.5~~) unstable; urgency=medium
     explicitly in drs-push-rejects test.  This avoids date dependencies
     which can cause that test to fail on fast computers.
   * Remove some spurios .debs from the example_1.0.tar.
-  * Increase sqlite_busy_timeout in debpolicy-dbretry, because
+  * Increase sqlite_busy_timeout in debpolicy-dbretry, because old
     zealot is very slow and we need to give the other processes time
     to rollback and release the lock.
   * Test quilt single-debian-patch.
@@ -113,8 +175,14 @@ dgit (1.5~~) unstable; urgency=medium
   * Test dgit-repos-policy-debian with multiple (identical, as it happens)
     existing taints.
   * Provide better log output for certain failures.
+  * Many new tests (especially for new functionality).
+  * Add missing debhelper (>=8) to test suite's global Depends.
+  * tstunt arrangements: Fix mishandling of PERLLIB, etc.
+  * tstunt-parsechangelog: Produce Timestamp field (like official one
+    does, now).
+  * Do not fail when git requires --allow-unrelated-histories.
 
- --
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sun, 16 Oct 2016 12:12:50 +0100
 
 dgit (1.4) unstable; urgency=high
 
@@ -266,7 +334,8 @@ dgit (1.1) unstable; urgency=medium
     currently only be updated with an actual upload, ie dgit push.)
   * Make warnings fatal in dpkg-repos-admin-debian, dgit-ssh-dispatch
     (using setup_sigwarn).
-  * Make warnings fatal in tstunt/dpkg-parsechangelog (directly).
+  * tstunt/dpkg-parsechangelog: Make warnings fatal (directly).
+  * tstunt/dpkg-parsechangelog: Do not complain if PERLLIB is empty.
   * Test suite: Honour DGIT_TEST_DEBUG=''.
   * With -DDDD, print out all gitcfg references (copious!)
   * Fix a debug message in the obsolete sshpsql archive access driver.