chiark / gitweb /
When receiving a push with dgit-repos-server, update the server's refs/heads/master...
[dgit.git] / debian / changelog
index 3c2b2447b5d26517cd5fae46aef5d43a66f09b8d..49b8777a7f1cb518cc0e7e7b31267f2b5efd279a 100644 (file)
@@ -1,3 +1,114 @@
+dgit (0.23~) unstable; urgency=low
+
+  * Check for new dgit git service on dgit-git.debian.net (ie
+    gideon.debian.org), with transition plan based on diversion feature.
+    Closes:#720172.
+
+  * New handling for .pc directory: dgit history now no longer contains
+    .pc at all.  It is deleted whenever we find it.  (When doing quilt
+    fixup, we recreate a suitable .pc in a temporary directory so that we
+    can do dpkg-source --comit.)  Closes:#764606.  INCOMPATIBLE CHANGE -
+    older versions of dgit will have trouble with these git histories.
+
+  * Replace many calls to stat with new wrapper stat_exists; improves
+    error handling and simplifies the code.
+
+  * Fix handling of rmadison-based and gitless distros (e.g., Ubuntu).
+
+  * Distro access configuration handling changes (should not be noticeable
+    to most users).
+
+  * Add :..; prefix to ssh remote commands, for the benefit of future
+    forced command wrappers.  Implicitly, this defines a new ssh-based
+    command protocol.  Closes:#720174, #720175.
+
+  * dgit-repos-server: Handle ' ' in SSH_ORIGINAL_COMMAND (which some
+    git versions send, sigh).
+
+  * New dgit-ssh-dispatch infrastructure script for use on dgit repos
+    server as part of ssh forced command.
+
+  * Test suite restructuring to support new tests.
+
+  * Add missing `gpgv' to test dependencies in debian/tests/control.
+
+  * New dgit-infrastructure binary package containing dgit-repos-server et
+    al.  Client users probably don't want this stuff.  Also, it provides a
+    convenient way to publish the dependencies.
+
+  * When generating quilt patches, try to linearise the git history into a
+    series of individual new patches for debian/patches.  Closes:#770710.
+
+  * Better documentation for quilt series handling.
+
+  * Strip `-b <branch>' from contents of Vcs-Git header, when setting up
+    the vcs-git remote.  Closes:#759374.
+
+  * Do not offer wget as an alternative dependency to curl.  We always
+    unconditionally invoke curl and have no code to use wget.
+    Closes:#760805.
+
+  * Complain about lack of cuddled values for value-taking single-letter
+    options, rather than thinking the user meat an empty value.
+    Closes:#763332.
+
+  * Reject (rather than ignoring) further options merged witht -wn, -wg,
+    -wd.
+
+  * Document in manpage under `dgit push' that it is best to build with
+    dgit too.  Closes:#763333.
+
+  * When receiving a push with dgit-repos-server, update the server's
+    refs/heads/master if we are pushing to what the distro regards as a
+    relevant branch, and the push would ff master.  Closes:#728209.
+
+  * Fix inaccurate error message when archive's git hash is not an
+    ancestor of git repo's git hash.
+
+  * Use ftpmasterapi archive query method.
+    (Closes:#727702.  Also partly obsoletes #768470.)
+
+  * Turn all perl warnings into errors using $SIG{__WARN__}.
+
+  * Show git config queries only with debuglevel 3 (-DDD) and higher.
+
+  * Fix an undef reference in error message processing when quilt
+    fixup linearisation fails.
+
+  * Quilt linearisation with .pc removal passes -f to git-rm.  (Otherwise
+    we may find that .pc/applied_patches prevents the commit.)
+
+  * Detect and bomb out on vendor-specific `3.0 (quilt)' patch series.
+
+  * Provide example workflow for dgit rpush.  Closes:#763334.
+    (Also part of the fix for #768470.)
+
+  * Document that dgit repos are cloneable with git, in dgit(1)
+    section MODEL.  [Andreas Barth.]  Closes:#768470.
+
+  * --clean=git and --clean=none cause dgit to pass -nc to
+    dpkg-buildpackage, suppressing calls to the package's clean target.
+    Also, expand the documentation in this area slightly.  Closes:#768590.
+
+  * Manpages: Break out dgit(7) from dgit(1).
+  * Manpages: Other clarifications and improvements.
+  * Change realpath dependency to `coreutils (>= 8.23-1~) | realpath'
+    (Closes:#786955.)
+  * For non-Debian distros, debiantag() uses distro name a la DEP-14.
+  * dgit: Be more careful about tag updates during fetch: only update
+    tags referring to uploads to distro we are trying to fetch from.
+
+ --
+
+dgit (0.22.1) unstable; urgency=high
+
+  * Use Dpkg::Version::version_compare everywhere, not
+    Dpkg::Version::version_compare_string.  The latter is entirely wrong,
+    meaning that dgit would get many version comparisons wrong.
+    Closes:#768038.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Tue, 04 Nov 2014 12:46:40 +0000
+
 dgit (0.22) unstable; urgency=medium
 
   Bugfixes:
@@ -56,7 +167,7 @@ dgit (0.22) unstable; urgency=medium
   * New git-check and git-create methods "true" which are no-ops.
   * test-dummy-drs `distro': for testing dgit and dgit-repos-server.
 
- -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Wed, 13 Aug 2014 17:57:27 +0100
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Tue, 19 Aug 2014 11:24:02 +0100
 
 dgit (0.21) unstable; urgency=medium