chiark / gitweb /
Infra: dgit-infrastructure has, and uses, its own copies of the perl modules
[dgit.git] / debian / changelog
index 37a746a4437dc69efd03b2f8bec26645538bd8a2..4992ddee888adfde674b43ccd75d500d2b83e8d9 100644 (file)
@@ -6,6 +6,8 @@ dgit (1.5~~) unstable; urgency=medium
     possible to override dgit's -A by passing another option.  But this
     has been changed recently and now this default setting is very awkward
     to change for the dgit user.
+  * Make --quilt=gbp the default for dgit gbp-build.  See below.
+  * New tag format (for dgit view) archive/debian/VERSION.
 
   Major new feature:
   * --quilt=gbp, --quilt=dpm, --quilt=unpacked: Introduce facility for
@@ -15,7 +17,7 @@ dgit (1.5~~) unstable; urgency=medium
   New checks and improved behaviours:
   * When running dpkg-buildpackage, cope if user specified -g or -G.
   * dgit sbuild: check that the set of .changes files found is as we
-    expect, before calling mergechanges.
+    expect, before calling mergechanges.  Re:#800060.
   * dgit sbuild: Rename the used-up .changes files to `.inmulti' to
     avoid accidental use of the wrong one (by software, or by users).
   * dgit sbuild: Check that the binary .changes file doesn't contain a
@@ -24,7 +26,7 @@ dgit (1.5~~) unstable; urgency=medium
   * Remove any pre-existing _source.changes file before building source,
     as a safety check.
   * No longer tolerate a multitude of .changes files when doing push.
-    Instead, insist on a single one.
+    Instead, insist on a single one.  Closes:#800110.
   * dgit sbuild no longer deletes extranious .changes files; instead
     we rely on --rm-old-changes, or failing that, fail early.
   * When doing quilt linearisation, treat upstream .gitignores not
@@ -40,16 +42,31 @@ dgit (1.5~~) unstable; urgency=medium
     any Gbp-Pq headers (that we understand).
   * Several dgit-generated commits now have slightly better annotations
     from dgit about what it was doing.
-  * Make --quilt=gbp the default for dgit gbp-build.
-  * New tag format (for dgit view) archive/debian/VERSION.
+  * Before committing to push, check that .dsc and .changes correspond.
+    Closes:#800060.
+  * Better error message if non-split-brain patch stack no longer
+    applies (due to new upstream version, or user messing with it).
+    Closes:#833025.
+  * Better error message if HEAD contains changes unrepresentable
+    by `3.0 (quilt)'.  Closes:#834618.
+  * Much better error message when HEAD and .dsc do not match.
+    Closes:#809516.
 
   Infrastructure:
   * Better error handling in dgit-repos-policy-debian.
   * dgit-repos-policy-debian.: fix git-cat-file-handling with multiple
     taints in db (!).
+  * dgit-infrastructure has, and uses, its own copies of the perl modules.
+    This avoids introducing a versioned dependency between dgit and
+    dgit-infrastructure (and also makes it easier to test cross-version
+    compatibility).
 
   Documentation:
   * Document the dgit-distro.DISTRO.quilt-mode config setting.
+  * Clarify the --clean= options' documentation.  Closes:#800054.
+  * Discourage use of the --PROGRAM:OPTION escape hatch.  (Apropos
+    of various bug reports including #800060 and #833025.)
+  * Document the expected form of HEAD for each --quilt= mode.
 
   Bugfixes:
   * When cleaning up after failed clone, stat the to-be-cleaned-up
@@ -69,11 +86,18 @@ dgit (1.5~~) unstable; urgency=medium
     --quilt modes.
   * Fix two calls to chdir without proper error checking.
   * Fix a couple of bugs in error reporting.
-  * Fix up .orig detection to be less trustful of (ambiguous) filenames.
-  * Fix up .orig detection to correctly allow exactly the right
-    .orig-comp components accorging to dpkg-source(1).
-  * Fix up .orig detection to handle .asc's (and other signatures)
-    of .orig components the same way as their tarballs.
+  * Fix several bugs in .orig detection/recognition.
+  * Tidy up refs/dgit-fetch/ after dgit fetch (if successful).
+  * Fix handling of in-archive copies.
+  * Don't break if user has push.followTags=true.  Closes:#827878.
+  * Arrange for the special dgit remote to be skipped by git fetch --all
+    etc.  And no longer configure a fetch spec, since it won't work
+    anyway.  Closes:#827892.
+  * Allow local git config options to override user-global ones,
+    as is proper.  Closes:#835858.
+  * When generating patch filenames from titles, first transliterate
+    them (lossily) to ascii.  Closes:#834807.
+  * Add debhelper (>=8) to test suite's global Depends.
 
   Test suite:
   * When sbuild fails, do not crash due to sed not finding the log
@@ -84,7 +108,7 @@ dgit (1.5~~) unstable; urgency=medium
     explicitly in drs-push-rejects test.  This avoids date dependencies
     which can cause that test to fail on fast computers.
   * Remove some spurios .debs from the example_1.0.tar.
-  * Increase sqlite_busy_timeout in debpolicy-dbretry, because
+  * Increase sqlite_busy_timeout in debpolicy-dbretry, because old
     zealot is very slow and we need to give the other processes time
     to rollback and release the lock.
   * Test quilt single-debian-patch.
@@ -93,6 +117,7 @@ dgit (1.5~~) unstable; urgency=medium
   * Test dgit-repos-policy-debian with multiple (identical, as it happens)
     existing taints.
   * Provide better log output for certain failures.
+  * Many new tests (especially for new functionality).
 
  --