chiark / gitweb /
Split brain: Make quiltify_trees_differ cleverer
[dgit.git] / debian / changelog
index 98a03d2173621b3f61a1b99370bfef5ce74a84f8..30db5c982766c157fb1010b32a1aeec5979477ed 100644 (file)
@@ -7,6 +7,32 @@ dgit (1.5~~) unstable; urgency=medium
     has been changed recently and now this default setting is very awkward
     to change for the dgit user.
 
+  New checks and improved behaviours:
+  * When running dpkg-buildpackage, cope if user specified -g or -G.
+  * dgit sbuild: check that the set of .changes files found is as we
+    expect, before calling mergechanges.
+  * dgit sbuild: Rename the used-up .changes files to `.inmulti' to
+    avoid accidental use of the wrong one (by software, or by users).
+  * dgit sbuild: Check that the binary .changes file doesn't contain a
+    .dsc.
+  * Introduce --rm-old-changes to delete previous builds' changes files.
+  * Remove any pre-existing _source.changes file before building source,
+    as a safety check.
+  * No longer tolerate a multitude of .changes files when doing push.
+    Instead, insist on a single one.
+  * dgit sbuild no longer deletes extranious .changes files; instead
+    we rely on --rm-old-changes, or failing that, fail early.
+  * When doing quilt linearisation, treat upstream .gitignores not
+    in the toplevel the same way we treat ones in the toplevel.
+
+  Infrastructure:
+  * Better error handling in dgit-repos-policy-debian.
+  * dgit-repos-policy-debian.: fix git-cat-file-handling with multiple
+    taints in db (!).
+
+  Documentation:
+  * Document the dgit-distro.DISTRO.quilt-mode config setting.
+
   Bugfixes:
   * When cleaning up after failed clone, stat the to-be-cleaned-up
     directory before running rmtree on it.  Closes:#796773.
@@ -16,12 +42,26 @@ dgit (1.5~~) unstable; urgency=medium
     `dgit clone' cannot create the destination directory.
   * Properly substitute $changesfile in one of the `You can retry'
     messages.  Closes:#800078.
+  * Pass --ch:* and -v options to dpkg-buildpackage when building
+    source.  Fixes bad Perl poetry syntax.  Closes:#829121.
 
   Test suite:
   * When sbuild fails, do not crash due to sed not finding the log
     file.  Instead, simply tolerate the absence of the log file.
   * Put --no-arch-all in build-modes-sbuild act, not only its real_act.
     Cosmetic change only.
+  * Set GIT_COMMITTER_DATE and GIT_AUTHOR_DATE and increment them
+    explicitly in drs-push-rejects test.  This avoids date dependencies
+    which can cause that test to fail on fast computers.
+  * Remove some spurios .debs from the example_1.0.tar.
+  * Increase sqlite_busy_timeout in debpolicy-dbretry, because
+    zealot is very slow and we need to give the other processes time
+    to rollback and release the lock.
+  * Test quilt single-debian-patch.
+  * Provide `tartree-edit gitfetchinfo' etc. to help with comparing
+    different test case git working tree tarballs.
+  * Test dgit-repos-policy-debian with multiple (identical, as it happens)
+    existing taints.
 
  --