chiark / gitweb /
dgit: do not crash on push of a new gdr package. Closes:#906784.
[dgit.git] / debian / changelog
index 1ca7cf01d3e3e9d44e4cfb1dd4da36677f31c9f6..29ff56e6e0249dc780ecf2c89b85e455aa4d3f99 100644 (file)
@@ -1,9 +1,77 @@
-dgit (6.6~) unstable; urgency=medium
+dgit (6.9~) unstable; urgency=medium
 
-  * 
+  * dgit: do not crash on push of a new gdr package.  Closes:#906784.
 
  --
 
+dgit (6.8) unstable; urgency=medium
+
+  * test suite: Fix dependencies of new gdr-merge-conflicts test.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Mon, 20 Aug 2018 14:52:03 +0100
+
+dgit (6.7) unstable; urgency=medium
+
+  git-debrebase, bugfixes:
+  * make-patches: Do not bail if there aren't any.
+  * scrap: works properly when it does only rebase --abort.
+  * On rebase: always save ffq-prev even if we were both stitched and
+    laundered.  Closes:#905975.
+
+  git-debrebase, improvements:
+  * Speed: improve laundry performance by a factor of ~55:1,
+    and analysis performance by factor of ~4.2:1.  Closes:#905995.
+  * prepush: this is now a silent no-op if the branch is
+    unstitched.  This is more friendly.
+  * convert-from-*: Snag on patches in d/patches which are not in series,
+    because they will be deleted.  Closes:#904997.
+  * Highly experimental merge resolution support, enabled only with
+    special command line option.
+  * Lots of internal changes to support merge, and other work.
+  * convert-from-*: Check whether ffq-prev or debrebase-last indicate that
+    we are already in gdr format.
+  * convert-from-*: leave debrebase-last refs to hint to everyone that
+    this is now a gdr branch.
+
+  git-debrebase, improved messages:
+  * Improve ffq head recording message.
+  * Better (less copious by default) debug output.
+  * convert-from-gbp: Improve messages.  Closes:#906641.
+  * Provide hints for unprocessable commits, depending on the apparent
+    branch ffq state, including possible suggestion to use convert-from-*.
+    Closes:#905005.  Closes:#905279.
+
+  dgit, improved messages:
+  * Mention bad origs as possible cause of quilt fixup failure,
+    in both dgit(7) and in error messages.  No longer suggest
+    --quilt=smash or dpkg-source --commit in the error message.
+    Closes:906196.
+  * Do not suggest --quilt modes if quilt fixup "stopped at"
+    a commit made by git-debrebase.  Closes:#906197.
+  * Mention gitattributes as a potential problem in quilt linearisation
+    failure, when appropriate.  Closes:#906199.
+
+  dgit, documentation:
+  * dgit(1): Encourage --overwrite rather than --overwrite=version.
+  * Document that we do not suppress attributes which affect git-archive.
+    This is related to #906199.
+
+  test suite:
+  * test suite: Set DEBFULLNAME
+  * test suite: unset GIT_EDITOR, so it works if user has that set.
+
+  Packaging:
+  * changelog: Add close note for #905400 to changelog entry for 6.5.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Mon, 20 Aug 2018 02:30:06 +0100
+
+dgit (6.6) unstable; urgency=medium
+
+  * test suite: Fix gdr's calls to dgit when run formally in
+    autopkgtest.  (Affects gdr-import-dgitview.)
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sun, 05 Aug 2018 10:42:01 +0100
+
 dgit (6.5) unstable; urgency=medium
 
   git-debrebase new features:
@@ -12,7 +80,7 @@ dgit (6.5) unstable; urgency=medium
   * git-debrebase: New subcommand `scrap'.  Closes:#905063.
 
   git-debrebase error handling improvements:
-  * git-debrebase: Properly reject bare dgit dsc imports
+  * git-debrebase: Properly reject bare dgit dsc imports.  Closes:905400.
   * git-debrebase: Improve some error message formatting.
   * git-debrebase: Check for git-rebase in progress and abort most operations.