chiark / gitweb /
Quilt output: Produce output like git-format-patch
[dgit.git] / debian / changelog
index 46e23dcdb1f65cb3d20f6483928ebcaaed5a3bc6..1ad499d717ce1bf18435a9d47489802575665871 100644 (file)
@@ -24,6 +24,13 @@ dgit (1.5~~) unstable; urgency=medium
     we rely on --rm-old-changes, or failing that, fail early.
   * When doing quilt linearisation, treat upstream .gitignores not
     in the toplevel the same way we treat ones in the toplevel.
+  * When automatically generating quilt patch, honour GIT_COMMITTER_DATE
+    for filename creation (makes filename deterministic in test suite).
+  * New --overwrite option, replaces need to for user to use
+    git merge -s ours.  Closes:#838718.
+  * When generating quilt patches from git commits, make patches that
+    look quite like git-format-patch output (rather than strange things
+    based on an obselete interpretation of DEP-3).
 
   Infrastructure:
   * Better error handling in dgit-repos-policy-debian.
@@ -46,6 +53,16 @@ dgit (1.5~~) unstable; urgency=medium
     source.  Fixes bad Perl poetry syntax.  Closes:#829121.
   * When synthesing a commit from a .dsc from the archive, stop
     internal git reset from printing a confusing message about HEAD.
+  * Turn off git gc in the private working areas.
+  * Do not fail to do some important quilt processing in some
+    --quilt modes.
+  * Fix two calls to chdir without proper error checking.
+  * Fix a couple of bugs in error reporting.
+  * Fix up .orig detection to be less trustful of (ambiguous) filenames.
+  * Fix up .orig detection to correctly allow exactly the right
+    .orig-comp components accorging to dpkg-source(1).
+  * Fix up .orig detection to handle .asc's (and other signatures)
+    of .orig components the same way as their tarballs.
 
   Test suite:
   * When sbuild fails, do not crash due to sed not finding the log
@@ -64,6 +81,7 @@ dgit (1.5~~) unstable; urgency=medium
     different test case git working tree tarballs.
   * Test dgit-repos-policy-debian with multiple (identical, as it happens)
     existing taints.
+  * Provide better log output for certain failures.
 
  --