chiark / gitweb /
dgit: Option parsing: Fix undefined $suite in some import-dsc.
[dgit.git] / debian / changelog
index 6d7ad9a7aea746f4f8a599d0aab76165a585fb0b..04328fe5fff8fa263be123bf2a2012cf3dbca866 100644 (file)
@@ -1,3 +1,68 @@
+dgit (3.3~) unstable; urgency=medium
+
+  Bugfixes:
+  * dgit: Remove a leftover debugging print.
+  * dgit: Set default dsc import distro when there is no Dgit field.
+  * dgit: Set default dsc import distro when suppressing Dgit field.
+  * dgit: Option parsing: Fix undefined $suite in some import-dsc.
+    Closes:#851213.
+
+  Packaging:
+  * Remove redundant Recommends on libtext-iconv-perl.
+
+  Test suite:
+  * Move default dsc distro config setting to lib.  We need this
+    for the .dscs we have in tests/pkg-srcs/.
+  * test suite: defdistro-import-dsc: Drop this test.
+  * test suite: Internal change: fix handling of nonempty distro=
+
+ --
+
+dgit (3.2) unstable; urgency=medium
+
+  Bugfixes:
+  * dgit: Do not execute END blocks in children.  So far symptoms of this
+    bug seem to be limited to duplicated error messages but I have not
+    done a thorough analysis.  Closes:#850052.
+  * dgit-infrastructure: dgit-repos-policy-debian: Remirror a package when
+    it becomes public (ie, make the repo available much more promptly when
+    the package passes NEW).  Closes:#849789.
+  * dgit: Fix a warning message about ref (mainly, tag) updates.
+
+  Documentation:
+  * dgit-maint-merge(7): Use git-deborig(1).
+    [Sean Whitton]  Closes:#850953.
+  * dgit-user(7): Fix some typos.
+
+  Internals:
+  * Fix a typo in a comment.
+
+  Test suite:
+  * infra: mirroring and policy hooks: Improve some debugging output.
+  * infra: mirror-private: test that package becomes public.  (#849789)
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Thu, 12 Jan 2017 02:11:34 +0000
+
+dgit (3.1) unstable; urgency=medium
+
+  Bugfixes:
+  * dgit import-dsc: Do not crash with undefined $isuite.  Closes:#850781.
+  * dgit build: Do not sometimes crash with undefined $isuite.
+  * dgit: Do not nedlessly re-fetch the rewrite map.
+  * dgit: After downloading .debian.* files, save them in `..', too
+    (ie do this not just for .origs).
+  * dgit: When fetching, refetch files with hash mismatches (and save them
+    as `...,fetch'), so we can distinguish them from any built locally.
+    Closes:#850824.
+
+  Test suite:
+  * Add test for import-dsc with default distro.  (Detects #850781.)
+
+  Administrivia:
+  * Fix a dgit 3.0 changelog bullet referring to refs/dgit-fetch/DISTRO.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Tue, 10 Jan 2017 17:50:27 +0000
+
 dgit (3.0) unstable; urgency=medium
 
   Protocol change:
@@ -25,7 +90,7 @@ dgit (3.0) unstable; urgency=medium
 
   Other improvements:
   * Improve debugging output a bit.
-  * Use refs/dgit-fetch/DISTRO rather than refs/dgit-fetch/DISTRO,
+  * Use refs/dgit-fetch/DISTRO rather than refs/dgit-fetch/SUITE,
     which leads to less duplication and so less clutter.
   * Enforce a reasonable syntax for nominal distro names.
   * When generating orig+debian/patches view, copy debian/ from