chiark / gitweb /
Add instructions how to mark a non-free package as auto-buildable.
[developers-reference.git] / debian / rules
index 9d3752e8944d69d825194260a7b377c5ef51719d..899b1452bdf3361ca3306ec3bc912b261e817823 100755 (executable)
@@ -11,7 +11,7 @@ docbasedir    := $(prefix)$(docbaserel)
 
 # list of language packages, in the form pkg-LANG; must jibe
 # with debian/control
-langs          := fr
+langs          := fr de
 langs_nopdf    := ja
 
 # tool abstraction
@@ -28,7 +28,12 @@ PUBDATE              := $(shell LC_ALL=C date --date="$(DEB_DATE)" -I)
 # debhelper verbose mode
 #export DH_VERBOSE=1
 
-build:
+build: build-arch build-indep
+
+build-arch:
+#      nothing arch dependant
+
+build-indep:
        $(checkdir)
        rm -f version.ent
        $(MAKE) VERSION=$(DEB_VERSION) PUBDATE=$(PUBDATE) LANGS="$(langs) $(langs_nopdf)"