chiark / gitweb /
fix a bug in how we deal with debian/control
[developers-reference.git] / debian / rules
index a24215d7299a128136f89c40ada83a854fdb7fb9..5dc8af327ace129f128f4c98353656918478c918 100755 (executable)
@@ -85,12 +85,7 @@ binary-indep:        build
 #       make sure control files are good
        sh -n debian/postinst
        sh -n debian/prerm
-#       install the control files
-       $(install_script) debian/postinst debian/prerm  $(prefix)/DEBIAN/
-       # be tricky about putting the TOC sections into the description of the package
-       cp debian/control debian/control.out
-       perl -ne '/^\d+\.\s/ && print "    $$_";' < developers-reference.txt >> debian/control.out
-       $(install_file) debian/control.out $(prefix)/DEBIAN/control
+       $(install_script) debian/postinst debian/prerm $(prefix)/DEBIAN/
 
 #       compress docdir (policy)       
        find $(docdir) -type f \( -size +4k -or -iname "change*" \)     \
@@ -98,6 +93,10 @@ binary-indep:        build
                ! -name "copyright" | xargs $(compress)
 
        dpkg-gencontrol -isp
+#       be tricky about putting the TOC sections into the description of the package
+       perl -ne '/^\d+\.\s/ && print "    $$_";' < developers-reference.txt \
+               >> $(prefix)/DEBIAN/control
+
        dpkg --build $(prefix) ..
 
 #       some extra-package files